summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2020-11-23 18:29:49 +0100
committerEmmanuel Gil Peyrot2020-11-23 18:30:33 +0100
commit1ed5025f90a329e53a0c55729a97c6665bbfaded (patch)
tree7840c11492a0d2d502e572efdb19b393a0dae63b
downloadaur-1ed5025f90a329e53a0c55729a97c6665bbfaded.tar.gz
Hello world!
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
-rw-r--r--capbattleship.desktop10
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f870961d2d14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = capbattleship-git
+ pkgdesc = A pirate-themed battleship game
+ pkgver = v1.0alpha2.r3.gb771f89
+ pkgrel = 1
+ url = https://forge.tedomum.net/captnfab/capbattleship
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python-pygame
+ provides = capbattleship
+ conflicts = capbattleship
+ source = git+https://forge.tedomum.net/captnfab/capbattleship.git
+ source = capbattleship.desktop
+ sha384sums = SKIP
+ sha384sums = 8ae97f48e815cd1ed8c45716cd315046063f147760439367a65b9a774976b36bb968a44d48159c5a6c7028f15d2bfb13
+
+pkgname = capbattleship-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3933a6513f5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+
+pkgname=capbattleship-git
+pkgver=v1.0alpha2.r3.gb771f89
+pkgrel=1
+pkgdesc="A pirate-themed battleship game"
+arch=('any')
+url="https://forge.tedomum.net/captnfab/capbattleship"
+license=('MIT')
+makedepends=('git')
+depends=('python-pygame')
+conflicts=('capbattleship')
+provides=('capbattleship')
+source=("git+https://forge.tedomum.net/captnfab/capbattleship.git"
+ "capbattleship.desktop")
+sha384sums=('SKIP'
+ '8ae97f48e815cd1ed8c45716cd315046063f147760439367a65b9a774976b36bb968a44d48159c5a6c7028f15d2bfb13')
+
+pkgver() {
+ cd capbattleship
+ git describe --tags --long | sed 's/^nbxmpp-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd capbattleship
+ python setup.py build
+}
+
+package() {
+ cd capbattleship
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+
+ # Otherwise the game doesn’t start.
+ mv "$pkgdir"/usr/bin/capbattleship.py "$pkgdir"/usr/bin/capbattleship
+
+ install -Dm644 assets/gfx/icon_256px.png "$pkgdir"/usr/share/icons/hicolor/256x256/apps/capbattleship.png
+ install -Dm644 ../capbattleship.desktop "$pkgdir"/usr/share/applications/capbattleship.desktop
+}
diff --git a/capbattleship.desktop b/capbattleship.desktop
new file mode 100644
index 000000000000..fee3e798ca3c
--- /dev/null
+++ b/capbattleship.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Name=CAP: Pirate Battleship
+GenericName=CAP: Pirate Battleship
+Keywords=chat;talk;im;message;xmpp;jabber;
+Exec=capbattleship
+Icon=capbattleship
+Terminal=false
+Type=Application
+Categories=Game;