summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Lopes2019-05-29 12:59:00 -0300
committerFrancisco Lopes2019-05-29 12:59:00 -0300
commit3ffe084053c05728198a4cf91346b2cc7ec1cdde (patch)
tree14ddcd35686674799908c8a6660bb6cdb58a0369
parentb4ca4051b7aa557e0f8aa1b8413c55246d887292 (diff)
downloadaur-3ffe084053c05728198a4cf91346b2cc7ec1cdde.tar.gz
Wait udev-settle for loading after /dev/input
This attempts to fix the issue of the service not recognizing devices on boot.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 2 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 518b382069d0..69fbf6bde9d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = caps2esc
pkgdesc = caps2esc: transforming the most useless key ever in the most useful one
pkgver = 1.0.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/oblitum/caps2esc
arch = x86_64
license = GPL3
makedepends = gcc
depends = libevdev
source = https://raw.githubusercontent.com/oblitum/caps2esc/v1.0.4/caps2esc.c
- source = https://raw.githubusercontent.com/oblitum/caps2esc/v1.0.4/LICENSE.md
source = caps2esc.service
md5sums = 45e8290bc91e9a297a1496770238d89c
- md5sums = 5ce903a740b8b693400618c62409e14d
md5sums = 404cfae39ca29735e26e2c37f93fe6b1
pkgname = caps2esc
diff --git a/PKGBUILD b/PKGBUILD
index b68a3ee3192d..2d6e4a8e27d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Francisco Lopes <francisco@oblita.com>
pkgname=caps2esc
pkgver=1.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="caps2esc: transforming the most useless key ever in the most useful one"
arch=('x86_64')
license=('GPL3')
@@ -9,10 +9,8 @@ url="https://github.com/oblitum/caps2esc"
depends=('libevdev')
makedepends=('gcc')
source=("https://raw.githubusercontent.com/oblitum/caps2esc/v${pkgver}/caps2esc.c"
- "https://raw.githubusercontent.com/oblitum/caps2esc/v${pkgver}/LICENSE.md"
'caps2esc.service')
md5sums=('45e8290bc91e9a297a1496770238d89c'
- '5ce903a740b8b693400618c62409e14d'
'404cfae39ca29735e26e2c37f93fe6b1')
build() {
@@ -23,9 +21,6 @@ package() {
mkdir -p "${pkgdir}/usr/bin"
install -m 755 caps2esc "${pkgdir}/usr/bin"
- mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m 444 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}"
-
mkdir -p "${pkgdir}/usr/lib/systemd/system"
install -m 644 "${srcdir}/caps2esc.service" "${pkgdir}/usr/lib/systemd/system"
}