summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Lopes2017-12-14 14:21:32 -0200
committerFrancisco Lopes2017-12-14 14:21:32 -0200
commitb4ca4051b7aa557e0f8aa1b8413c55246d887292 (patch)
tree7c21e1607561734cf30e82f24586f3a588e5ed8f
parent9a1521263ad013ba9fa8403803c4e3043991ad82 (diff)
downloadaur-b4ca4051b7aa557e0f8aa1b8413c55246d887292.tar.gz
1.0.4
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
-rw-r--r--caps2esc.service1
3 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9be204280f1c..518b382069d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = caps2esc
pkgdesc = caps2esc: transforming the most useless key ever in the most useful one
- pkgver = 1.0.3
+ pkgver = 1.0.4
pkgrel = 1
url = https://github.com/oblitum/caps2esc
- arch = i686
arch = x86_64
license = GPL3
makedepends = gcc
depends = libevdev
- source = https://raw.githubusercontent.com/oblitum/caps2esc/v1.0.3/caps2esc.c
+ source = https://raw.githubusercontent.com/oblitum/caps2esc/v1.0.4/caps2esc.c
+ source = https://raw.githubusercontent.com/oblitum/caps2esc/v1.0.4/LICENSE.md
source = caps2esc.service
- md5sums = 92b302db9c965b5e5046ac51f018cc70
- md5sums = b522d1654f2d04f703b8409ef4d5e7d0
+ md5sums = 45e8290bc91e9a297a1496770238d89c
+ md5sums = 5ce903a740b8b693400618c62409e14d
+ md5sums = 404cfae39ca29735e26e2c37f93fe6b1
pkgname = caps2esc
diff --git a/PKGBUILD b/PKGBUILD
index fd0947cc7e81..b68a3ee3192d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,19 @@
# Maintainer: Francisco Lopes <francisco@oblita.com>
pkgname=caps2esc
-pkgver=1.0.3
+pkgver=1.0.4
pkgrel=1
pkgdesc="caps2esc: transforming the most useless key ever in the most useful one"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL3')
url="https://github.com/oblitum/caps2esc"
depends=('libevdev')
makedepends=('gcc')
-source=("https://raw.githubusercontent.com/oblitum/caps2esc/v${pkgver}/caps2esc.c" 'caps2esc.service')
-md5sums=('92b302db9c965b5e5046ac51f018cc70' 'b522d1654f2d04f703b8409ef4d5e7d0')
+source=("https://raw.githubusercontent.com/oblitum/caps2esc/v${pkgver}/caps2esc.c"
+ "https://raw.githubusercontent.com/oblitum/caps2esc/v${pkgver}/LICENSE.md"
+ 'caps2esc.service')
+md5sums=('45e8290bc91e9a297a1496770238d89c'
+ '5ce903a740b8b693400618c62409e14d'
+ '404cfae39ca29735e26e2c37f93fe6b1')
build() {
gcc caps2esc.c -o caps2esc -I/usr/include/libevdev-1.0 -levdev -ludev
@@ -19,6 +23,9 @@ package() {
mkdir -p "${pkgdir}/usr/bin"
install -m 755 caps2esc "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 444 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}"
+
mkdir -p "${pkgdir}/usr/lib/systemd/system"
install -m 644 "${srcdir}/caps2esc.service" "${pkgdir}/usr/lib/systemd/system"
}
diff --git a/caps2esc.service b/caps2esc.service
index f189f2befc48..fbd58deca2a1 100644
--- a/caps2esc.service
+++ b/caps2esc.service
@@ -1,5 +1,6 @@
[Unit]
Description=caps2esc
+After=systemd-user-sessions.service
[Service]
ExecStart=/usr/bin/nice -n -20 /usr/bin/caps2esc