summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2017-01-12 11:43:43 +0100
committersmls2017-01-12 11:43:43 +0100
commit9d812a56ea65d9ee692e46e921cef8dab70a56f3 (patch)
tree6f42c27a31410b9ff20a135f5d84675cdadbe193
parent373f4c7d68622d578fda4345921b7a58d01944cd (diff)
downloadaur-9d812a56ea65d9ee692e46e921cef8dab70a56f3.tar.gz
bump to Humble Bundle installer version 12212015
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD71
2 files changed, 44 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd181069b171..d239adf2b525 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,9 +13,9 @@ pkgbase = capsized-hib
depends = gcc-libs
options = !strip
options = !upx
- source = hib://capsized-06132013-bin
+ source = hib://capsized-12212015-bin
source = capsized-hib.desktop
- md5sums = 710a25b2dc5f948f0a1cf6c6fe39690f
+ md5sums = 10515ca5f73e38151e17766cba97f3ed
md5sums = a6f5bc2ddf20690545cf095d59eec37b
pkgname = capsized-hib
diff --git a/PKGBUILD b/PKGBUILD
index 6ebef9ae6020..9c3611917d57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=capsized-hib
pkgver=1+h20130613
-_hibver=06132013
+_hibver=12212015
pkgrel=1
pkgdesc='A science-fiction action platformer (Humble Bundle version)'
url='http://www.capsizedgame.com/'
@@ -16,35 +16,48 @@ DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(p
source=("hib://capsized-$_hibver-bin"
'capsized-hib.desktop')
-md5sums=('710a25b2dc5f948f0a1cf6c6fe39690f'
+md5sums=('10515ca5f73e38151e17766cba97f3ed'
'a6f5bc2ddf20690545cf095d59eec37b')
-package() {
- cd $srcdir
- _installdir="/opt/Capsized"; _target="$pkgdir/$_installdir"
-
- # Remove files of wrong architecture
- [ $CARCH == "i686" ] && rm -r "data/"{lib64,NePlusUltra.bin.x86_64}
- [ $CARCH == "x86_64" ] && rm -r "data/"{lib,NePlusUltra.bin.x86}
-
- # Remove bundled libraries (use distro versions instead)
- rm "data/lib"*/{libogg.so.0,libopenal.so.1,libtheora.so.0,libtheoradec.so.1}
- rm "data/lib"*/{libvorbis.so.0,libvorbisfile.so.3}
-
- # Install game files
- mkdir -p "$_target"
- mv -T "data" "$_target"
-
- # Install desktop entry
- install -Dm644 "$pkgname.desktop" \
- "$pkgdir/usr/share/applications/$pkgname.desktop"
-
- # Install icon
- convert "$_target/Capsized.bmp" -resize 256x256 "capsized.png"
- install -Dm644 "capsized.png" "$pkgdir/usr/share/pixmaps/capsized.png"
+_installdir="/opt/Capsized"
+
+prepare() {
+ # Remove files of wrong architecture
+ [ $CARCH == "i686" ] && rm -r "data/"{lib64,NePlusUltra.bin.x86_64}
+ [ $CARCH == "x86_64" ] && rm -r "data/"{lib,NePlusUltra.bin.x86}
+
+ # Remove bundled libraries (use distro versions instead)
+ rm "data/lib"*/{libogg.so.0,libopenal.so.1,libtheora.so.0,libtheoradec.so.1}
+ rm "data/lib"*/{libvorbis.so.0,libvorbisfile.so.3}
+
+ # Set aside files for separate installation
+ mv "data/Linux.README" .
+
+ # Generate icon
+ convert "data/Capsized.bmp" -resize 256x256 "capsized.png"
+ rm "data/Capsized.bmp"
+
+ # Generate launch script
+ [ $CARCH == "i686" ] && _arch='x86' || _arch='x86_64'
+ echo -e "#!/bin/sh\ncd $_installdir && ./NePlusUltra.bin.$_arch" > "launcher.sh"
+}
- # Install launch script
- [ $CARCH == "i686" ] && _arch='x86' || _arch='x86_64'
- echo -e "#!/bin/sh\ncd $_installdir && ./NePlusUltra.bin.$_arch" > "launcher.sh"
- install -Dm755 "launcher.sh" "$pkgdir/usr/bin/capsized"
+package() {
+ cd $srcdir
+
+ # Install game files
+ mkdir -p "$pkgdir/$_installdir"
+ cp -alrT "data" "$pkgdir/$_installdir"
+
+ # Install desktop entry & icon
+ install -Dm644 "$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "capsized.png" "$pkgdir/usr/share/pixmaps/capsized.png"
+
+ # Install launch script
+ install -Dm755 "launcher.sh" "$pkgdir/usr/bin/capsized"
+
+ # Install docs
+ install -Dm644 "Linux.README" \
+ "$pkgdir"/usr/share/doc/$pkgname/Linux.README
}