summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorl0gic2016-01-22 20:49:46 +0100
committerl0gic2016-01-22 20:49:46 +0100
commit9f9155e5dfbed5ef991202c7bf97097a62d007d1 (patch)
treeec93d4d9fce5693ce2ada0fcc03e0f0a79b16324
parent274af505c2e5ff11ab8848584aab6cfe9404ba77 (diff)
downloadaur-9f9155e5dfbed5ef991202c7bf97097a62d007d1.tar.gz
Added workaround for linking error in make check
make check somehow expects libcapstone.so.4, whereas there is only a libcapstone.so present by the time the tests are run.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da30090d02ba..71433c916a9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Dec 29 21:41:01 UTC 2015
+# Fri Jan 22 19:48:41 UTC 2016
pkgbase = capstone-git
pkgdesc = A lightweight multi-platform, multi-architecture disassembly framework.
- pkgver = 20151229.2531.f9f0c80
+ pkgver = 20160122.2534.3722c74
pkgrel = 1
url = http://www.capstone-engine.org/
arch = i686
@@ -13,7 +13,7 @@ pkgbase = capstone-git
optdepends = python2: for python2 bindings
provides = capstone
conflicts = capstone
- source = capstone-git::git://github.com/aquynh/capstone.git#branch=next
+ source = capstone-git::git+https://github.com/aquynh/capstone.git#branch=next
md5sums = SKIP
pkgname = capstone-git
diff --git a/PKGBUILD b/PKGBUILD
index 389d35fc0418..0fc3275c2084 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=capstone-git
-pkgver=20151229.2531.f9f0c80
+pkgver=20160122.2534.3722c74
pkgrel=1
pkgdesc="A lightweight multi-platform, multi-architecture disassembly framework."
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ optdepends=('python: for python3 bindings'
provides=('capstone')
conflicts=('capstone')
-source=("$pkgname"::"git://github.com/aquynh/capstone.git#branch=next")
+source=("${pkgname}::git+https://github.com/aquynh/capstone.git#branch=next")
md5sums=('SKIP')
pkgver () {
@@ -38,7 +38,7 @@ build() {
check() {
cd "${srcdir}/${pkgname}"
- make check
+ LD_PRELOAD="./tests/libcapstone.so" make check
# uncomment as needed
#cd "./bindings/python"