summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Hros2021-02-06 16:48:46 +0100
committerMario Hros2021-02-06 16:48:46 +0100
commitb180825debdccbf27634506a68b0e39f8765348e (patch)
tree3a7b660ff70261137fbae6d3387ac917bb2d012b
parenta2db6f5c23d193c1e5b40e46c0ff465f33f1be08 (diff)
downloadaur-b180825debdccbf27634506a68b0e39f8765348e.tar.gz
minimum golang ver to match go.mod file, helper Makefile
-rw-r--r--Makefile7
-rw-r--r--PKGBUILD2
2 files changed, 8 insertions, 1 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..390bba4293c1
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,7 @@
+.PHONY: all clean
+all:
+ updpkgsums
+ makepkg --printsrcinfo > .SRCINFO
+
+clean:
+ rm -rf *.tar.* *.gz src pkg
diff --git a/PKGBUILD b/PKGBUILD
index 4e612c77b502..bf0ced9f005c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=(i686 x86_64)
url='https://github.com/go-graphite/carbonapi'
license=('BSD')
depends=(glibc cairo)
-makedepends=('go>=1.8')
+makedepends=('go>=1.14')
backup=('etc/carbonapi.yaml')
_gopkg=github.com/go-graphite/$pkgname
source=($pkgname-$pkgver.tar.gz::https://$_gopkg/archive/$pkgver.tar.gz