summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2015-12-28 08:57:53 -0500
committerTed Alff2015-12-28 08:57:53 -0500
commit1a687bc3c1562c39415b2da541c2651d4b08c713 (patch)
treed614354679e99fa5b9b7a4d3cdf78554797c9a47
parent3511c1b93f43f388fa31ec3cd4283d2b606500f3 (diff)
downloadaur-1a687bc3c1562c39415b2da541c2651d4b08c713.tar.gz
Added xdg patch per melkhatt's comment. Updated PKGBUILD to current VCS methods.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD63
-rw-r--r--xdg_fix.patch61
3 files changed, 89 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a5c98df98b5..53b5d418ad68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Dec 28 13:56:09 UTC 2015
pkgbase = cardapio-bzr
pkgdesc = An alternative Gnome menu, launcher, and much more!
pkgver = 886
- pkgrel = 1
+ pkgrel = 2
url = https://launchpad.net/cardapio
arch = i686
arch = x86_64
@@ -18,8 +20,12 @@ pkgbase = cardapio-bzr
optdepends = tracker: search capability
provides = cardapio
conflicts = cardapio
+ source = cardapio::bzr+https://launchpad.net/cardapio/trunk
source = arch_and_python_stuff.patch
+ source = xdg_fix.patch
+ sha256sums = SKIP
sha256sums = 3fdaae9f4248c10d665492fb85f018d22d1a7120c65a1491efe58a2437bb98d0
+ sha256sums = 7c9915154d57c50724a5670b4dd4bb831f89208225690c3a0bcc039b60eefea3
pkgname = cardapio-bzr
diff --git a/PKGBUILD b/PKGBUILD
index 8192d36a6d9d..758f959cb48d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=cardapio
pkgname=${_pkgname}-bzr
pkgver=886
-pkgrel=1
+pkgrel=2
pkgdesc="An alternative Gnome menu, launcher, and much more!"
arch=('i686' 'x86_64')
url="https://launchpad.net/cardapio"
@@ -15,54 +15,33 @@ provides=('cardapio')
depends=('python2-xdg' 'xdg-user-dirs' 'python2-dbus' 'python2-gnomedesktop' 'python2-keybinder2' 'python2-simplejson' 'gnome-control-center' 'tk')
makedepends=('bzr')
optdepends=('tracker: search capability')
-source=(arch_and_python_stuff.patch)
+source=('cardapio::bzr+https://launchpad.net/cardapio/trunk'
+ 'arch_and_python_stuff.patch'
+ 'xdg_fix.patch')
-_bzrmod=cardapio
-_bzrtrunk=https://launchpad.net/cardapio/trunk
-
-build() {
- cd "${srcdir}"
- msg "Connecting to Bazaar server...."
-
- if [ -d $_bzrmod ] ; then
- cd ${_bzrmod} && bzr --no-plugins pull ${_bzrtrunk} -r ${pkgver}
- msg "The local files are updated."
- else
- bzr --no-plugins branch ${_bzrtrunk} ${_bzrmod} -q -r ${pkgver}
- fi
-
- msg "Bazaar checkout done or server timeout"
+pkgver() {
+ cd "${_pkgname}"
+ printf "%s" "$(bzr revno)"
+}
- msg "Removing old build directory..."
- rm -rf $srcdir/$_bzrmod-build
- msg "Creating build directory..."
- cp -r $srcdir/$_bzrmod $srcdir/$_bzrmod-build
-
+prepare() {
msg "Arch and Python2 adjustments..."
- cd "${srcdir}/$_bzrmod-build"
+ cd "${srcdir}/${_pkgname}"
patch -uNp2 -r- -i ../arch_and_python_stuff.patch || return 1
+ patch -uNp2 -r- -i ../xdg_fix.patch || return 1
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
make
}
package() {
- msg "Building cardapio...."
- cd "${srcdir}/${_pkgname}-build/"
- make DESTDIR="'${pkgdir}'" install || return 1
- ln -s "/usr/lib/cardapio/cardapio" "$pkgdir/usr/bin/"
- ln -s "/usr/lib/cardapio/cardapio-gnome-panel-applet" "$pkgdir/usr/bin/"
- ln -s "/usr/lib/cardapio/cardapio-gnome3-panel-applet" "$pkgdir/usr/bin/"
- ln -s "/usr/lib/cardapio/cardapio-mate-panel-applet" "$pkgdir/usr/bin/"
-
- #msg "Building cardapio-docky...."
- #cd "${srcdir}/${_pkgname}-build/src/docky"
- #make DESTDIR="'${pkgdir}'" install || return 1
-
- #msg "Building cardapio-awn...."
- #cd "${srcdir}/${_pkgname}-build/src/awn"
- #make DESTDIR="'${pkgdir}'" install || return 1
-
- msg "Cleaning package...."
- rm "${pkgdir}"/usr/share/locale/cardapio.pot || return 1
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+ rm "${pkgdir}"/usr/share/locale/cardapio.pot
}
-sha256sums=('3fdaae9f4248c10d665492fb85f018d22d1a7120c65a1491efe58a2437bb98d0')
+sha256sums=('SKIP'
+ '3fdaae9f4248c10d665492fb85f018d22d1a7120c65a1491efe58a2437bb98d0'
+ '7c9915154d57c50724a5670b4dd4bb831f89208225690c3a0bcc039b60eefea3')
diff --git a/xdg_fix.patch b/xdg_fix.patch
new file mode 100644
index 000000000000..64449efcb51a
--- /dev/null
+++ b/xdg_fix.patch
@@ -0,0 +1,61 @@
+diff -Naur ./cardapio.old/src/Cardapio.py ./cardapio/src/Cardapio.py
+--- ./cardapio.old/src/Cardapio.py 2015-12-27 23:12:03.443879297 -0500
++++ ./cardapio/src/Cardapio.py 2015-12-27 23:12:29.254221586 -0500
+@@ -41,6 +41,7 @@
+ import gio
+ import glib
+ import json
++ import xdg
+
+ import urllib2
+ import gettext
+@@ -53,6 +54,7 @@
+
+ from time import time
+ from xdg import DesktopEntry
++ from xdg import BaseDirectory
+ from pango import ELLIPSIZE_END
+ from threading import Lock, Thread
+ from locale import setlocale, LC_ALL
+@@ -453,7 +455,7 @@
+ self._plugin_database['pinned'] = {'class' : plugin_class, 'instances' : []}
+
+ plugin_dirs = [
+- os.path.join(DesktopEntry.xdg_config_home, 'Cardapio', 'plugins'),
++ os.path.join(BaseDirectory.xdg_config_home, 'Cardapio', 'plugins'),
+ os.path.join(self.cardapio_path, 'plugins'),
+ ]
+
+@@ -631,7 +633,7 @@
+ ~/.cache/Cardapio)
+ """
+
+- self._config_folder_path = os.path.join(DesktopEntry.xdg_config_home, 'Cardapio')
++ self._config_folder_path = os.path.join(BaseDirectory.xdg_config_home, 'Cardapio')
+
+ if not os.path.exists(self._config_folder_path):
+ os.mkdir(self._config_folder_path)
+@@ -640,7 +642,7 @@
+ fatal_error('Error creating config folder!', 'Cannot create folder "%s" because a file with that name already exists!' % self._config_folder_path)
+ self._quit()
+
+- self._cache_folder_path = os.path.join(DesktopEntry.xdg_cache_home, 'Cardapio')
++ self._cache_folder_path = os.path.join(BaseDirectory.xdg_cache_home, 'Cardapio')
+
+ if not os.path.exists(self._cache_folder_path):
+ os.mkdir(self._cache_folder_path)
+@@ -1931,7 +1933,7 @@
+
+ self._add_app_button(_('Home'), 'user-home', section, 'xdg', self._home_folder_path, _('Open your personal folder'), self._app_list)
+
+- xdg_folders_file_path = os.path.join(DesktopEntry.xdg_config_home, 'user-dirs.dirs')
++ xdg_folders_file_path = os.path.join(BaseDirectory.xdg_config_home, 'user-dirs.dirs') #***
+ xdg_folders_file = file(xdg_folders_file_path, 'r')
+ # TODO: xdg_folders_file = codecs.open(xdg_folders_file_path, mode='r', encoding='utf-8')
+
+@@ -3303,5 +3305,3 @@
+ __builtin__.get_output = get_output
+ __builtin__.fatal_error = fatal_error
+ __builtin__.which = which
+-
+-