summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilkii Brewster2021-10-29 00:35:26 +0100
committerMilkii Brewster2021-10-29 00:35:26 +0100
commit6bf9651ae703304512805dc9eb87e9920cb4c21e (patch)
tree1811bdcfe8e9677553c55521a32993ebc77871c9
downloadaur-6bf9651ae703304512805dc9eb87e9920cb4c21e.tar.gz
fix name and add initial lv2 only
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e4b90971569
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = cardinal.lv2-git
+ pkgdesc = DPF'ied build of VCVRack, allowing it to be used as an audio plugin.
+ pkgver = r163.e111534
+ pkgrel = 1
+ url = https://github.com/DISTRHO/Cardinal
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = jansson
+ depends = libarchive
+ depends = libgl
+ depends = libsamplerate
+ depends = libx11
+ depends = speexdsp
+ provides = cardinal
+ conflicts = cardinal
+ source = cardinal::git+https://github.com/DISTRHO/Cardinal
+ sha512sums = SKIP
+
+pkgname = cardinal.lv2-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0230a98c9e0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# experimental/wip: not using sys dependencies
+#
+# Maintainer: milkii on irc
+# Creator: redtide <redtid3@gmail.com>
+
+_pkgname="cardinal"
+pkgname="${_pkgname}.lv2-git"
+pkgver=r163.e111534
+pkgrel=1
+pkgdesc="DPF'ied build of VCVRack, allowing it to be used as an audio plugin."
+url="https://github.com/DISTRHO/Cardinal"
+arch=("x86_64")
+license=("GPL3")
+makedepends=("git")
+depends=("jansson" "libarchive" "libgl" "libsamplerate" "libx11" "speexdsp")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}"::"git+https://github.com/DISTRHO/Cardinal")
+sha512sums=("SKIP")
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ git submodule update --init --recursive
+}
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make PREFIX=/usr
+}
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}/" PREFIX=/usr install
+ rm -rf ${pkgdir}/usr/bin
+ rm -rf ${pkgdir}/usr/lib/vst
+ rm -rf ${pkgdir}/usr/lib/vst3
+ rm -rf ${pkgdir}/usr/share
+}