summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkpcyrd2018-06-30 13:30:14 +0100
committerkpcyrd2018-06-30 13:30:14 +0100
commit886ba19e398d3443a23c6b63b84bfe7f84c4dc91 (patch)
tree2175da213e7c27c8f41e758a47fea28c926cdb07
downloadaur-886ba19e398d3443a23c6b63b84bfe7f84c4dc91.tar.gz
v0.2.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..925468f0dd49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cargo-audit
+ pkgdesc = Audit Cargo.lock for crates with security vulnerabilities
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/RustSec/cargo-audit
+ arch = i686
+ arch = x86_64
+ license = MIT
+ license = APACHE
+ depends = cargo
+ source = https://github.com/RustSec/cargo-audit/archive/v0.2.1/cargo-audit-0.2.1.tar.gz
+ sha256sums = 67c1037014ec5c3925d0cca928425ca41f3ce20eaa06fe4c3f5c476c2feaf926
+
+pkgname = cargo-audit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83d757a70aca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: kpcyrd <git@rxv.cc>
+
+pkgname=cargo-audit
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Audit Cargo.lock for crates with security vulnerabilities"
+url="https://github.com/RustSec/cargo-audit"
+depends=('cargo')
+arch=('i686' 'x86_64')
+license=('MIT' 'APACHE')
+source=("https://github.com/RustSec/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('67c1037014ec5c3925d0cca928425ca41f3ce20eaa06fe4c3f5c476c2feaf926')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE-MIT LICENSE-APACHE -t "$pkgdir/usr/share/licenses/$pkgname"
+}