summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominic2022-12-07 17:30:17 +0100
committerDominic2022-12-07 17:30:17 +0100
commit8b1e4d4b269ec0148200cc586113b3c922c3656f (patch)
tree7969245c8d9e7a080260a426ff5e970d2bb5bc17
downloadaur-8b1e4d4b269ec0148200cc586113b3c922c3656f.tar.gz
auto-update cargo-clean-all 0.5.0
-rw-r--r--.SRCINFO15
-rw-r--r--.index.json5
-rw-r--r--PKGBUILD39
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abf33194dbae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cargo-clean-all
+ pkgdesc = Recursively clean all cargo projects in a given directory that match the spec...
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/dnlmlr/cargo-clean-all
+ arch = aarch64
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ depends = gcc-libs
+ source = cargo-clean-all-0.5.0.tar.gz::https://crates.io/api/v1/crates/cargo-clean-all/0.5.0/download
+ sha512sums = 152752294c66b0498ee6ceff85e82f2f69ceaa6de21a744b57189516b4ed4919711ea82a0817791a412c5adcbc22165faaf590d1e07f4e2a05c74910c1534106
+
+pkgname = cargo-clean-all \ No newline at end of file
diff --git a/.index.json b/.index.json
new file mode 100644
index 000000000000..29ad4bdb6e2f
--- /dev/null
+++ b/.index.json
@@ -0,0 +1,5 @@
+{
+ ".i": 1,
+ "crate": "cargo-clean-all",
+ "version": "0.5.0"
+} \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..660cbd299937
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# -*- mode: Shell-script; eval: (setq indent-tabs-mode 't); eval: (setq tab-width 4) -*-
+# Maintainer: Dominic Meiser [git at msrd0 dot de]
+
+_crate="cargo-clean-all"
+pkgname="cargo-clean-all"
+pkgver=0.5.0
+pkgrel=1
+pkgdesc='Recursively clean all cargo projects in a given directory that match the spec...'
+url='https://github.com/dnlmlr/cargo-clean-all'
+license=('MIT')
+
+depends=('gcc-libs')
+makedepends=('cargo')
+
+source=("$_crate-$pkgver.tar.gz::https://crates.io/api/v1/crates/cargo-clean-all/0.5.0/download")
+sha512sums=('152752294c66b0498ee6ceff85e82f2f69ceaa6de21a744b57189516b4ed4919711ea82a0817791a412c5adcbc22165faaf590d1e07f4e2a05c74910c1534106')
+
+# Tier 1 architectures supported by Rust (https://doc.rust-lang.org/nightly/rustc/platform-support.html#tier-1)
+arch=('aarch64' 'i686' 'x86_64')
+
+prepare() {
+ cd "$srcdir/$_crate-$pkgver"
+
+ cargo fetch --locked
+}
+
+build() {
+ cd "$srcdir/$_crate-$pkgver"
+ cargo build \
+ --offline \
+ --locked \
+ --release
+}
+
+package() {
+ cd "$srcdir/$_crate-$pkgver"
+ install -Dm755 "target/release/cargo-clean-all" -t "$pkgdir/usr/bin"
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+} \ No newline at end of file