summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormsrd0.dev2023-11-22 21:19:57 +0000
committermsrd0.dev2023-11-22 21:19:57 +0000
commitcb926f3891b9198c06629e33a967893bf5a07859 (patch)
tree820bba20fb94025f54ff8f757eaffd772d3cc221
parent0457667d35c229a6bd4a8b1ff5839b73c83357ea (diff)
downloadaur-cb926f3891b9198c06629e33a967893bf5a07859.tar.gz
auto-update cargo-clean-all 0.6.1
-rw-r--r--.SRCINFO6
-rw-r--r--.index.json2
-rw-r--r--PKGBUILD17
3 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8cc6c01494f..58303e011a91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cargo-clean-all
pkgdesc = Recursively clean all cargo projects in a given directory that match the spec...
- pkgver = 0.6.0
+ pkgver = 0.6.1
pkgrel = 1
url = https://github.com/dnlmlr/cargo-clean-all
arch = aarch64
@@ -9,7 +9,7 @@ pkgbase = cargo-clean-all
license = MIT
makedepends = cargo
depends = gcc-libs
- source = cargo-clean-all-0.6.0.tar.gz::https://crates.io/api/v1/crates/cargo-clean-all/0.6.0/download
- sha512sums = 574c672223a5c768134455ae6a525bd152c3ddf38c08d3ee8f2378276234b5d3f915cb8b6f4c1dc966a7e9d3b27af04623a6b783971d85f787db521f94205ab1
+ source = cargo-clean-all-0.6.1.tar.gz::https://crates.io/api/v1/crates/cargo-clean-all/0.6.1/download
+ sha512sums = 51a5ca85236d274ec588383fe18cbe14ca16be8260091f8bbe806d4728346b0e77d79be5e0c2e6d53c41b2c8ac160d2b6fed046bf18fd1549199c511ec501dec
pkgname = cargo-clean-all \ No newline at end of file
diff --git a/.index.json b/.index.json
index 25195f4c0a14..9d4f152ee846 100644
--- a/.index.json
+++ b/.index.json
@@ -1,5 +1,5 @@
{
".i": 1,
"crate": "cargo-clean-all",
- "version": "0.6.0"
+ "version": "0.6.1"
} \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index edb2cef08fd1..9ad1982391f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_crate="cargo-clean-all"
pkgname="cargo-clean-all"
-pkgver=0.6.0
+pkgver=0.6.1
pkgrel=1
pkgdesc='Recursively clean all cargo projects in a given directory that match the spec...'
url='https://github.com/dnlmlr/cargo-clean-all'
@@ -12,8 +12,8 @@ license=('MIT')
depends=('gcc-libs')
makedepends=('cargo')
-source=("$_crate-$pkgver.tar.gz::https://crates.io/api/v1/crates/cargo-clean-all/0.6.0/download")
-sha512sums=('574c672223a5c768134455ae6a525bd152c3ddf38c08d3ee8f2378276234b5d3f915cb8b6f4c1dc966a7e9d3b27af04623a6b783971d85f787db521f94205ab1')
+source=("$_crate-$pkgver.tar.gz::https://crates.io/api/v1/crates/cargo-clean-all/0.6.1/download")
+sha512sums=('51a5ca85236d274ec588383fe18cbe14ca16be8260091f8bbe806d4728346b0e77d79be5e0c2e6d53c41b2c8ac160d2b6fed046bf18fd1549199c511ec501dec')
# Tier 1 architectures supported by Rust (https://doc.rust-lang.org/nightly/rustc/platform-support.html#tier-1)
arch=('aarch64' 'i686' 'x86_64')
@@ -21,11 +21,18 @@ arch=('aarch64' 'i686' 'x86_64')
prepare() {
cd "$srcdir/$_crate-$pkgver"
- cargo fetch --locked
+ export RUSTUP_TOOLCHAIN=stable
+
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
cd "$srcdir/$_crate-$pkgver"
+
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+
+
cargo build \
--offline \
--locked \
@@ -35,5 +42,5 @@ build() {
package() {
cd "$srcdir/$_crate-$pkgver"
install -Dm755 "target/release/cargo-clean-all" -t "$pkgdir/usr/bin"
- install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 'LICENSE' -t "$pkgdir/usr/share/licenses/$pkgname/"
} \ No newline at end of file