summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominic2022-11-29 14:12:41 +0000
committerDominic2022-11-29 14:12:41 +0000
commit30303d8c3d62697ae2685af8c8a5b572c9d4b675 (patch)
treed1538e7bd0cb8fb0fe460bd3356fd53dd4ec8aa0
parent3b8ac2bbe3549e70e35d192e39ab6d97e2f4b0f5 (diff)
downloadaur-30303d8c3d62697ae2685af8c8a5b572c9d4b675.tar.gz
auto-update cargo-duplicates 0.5.1
-rw-r--r--.SRCINFO2
-rw-r--r--.index.json1
-rw-r--r--PKGBUILD28
3 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9a2a4a8b931..702608623acb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,4 +13,4 @@ pkgbase = cargo-duplicates
source = cargo-duplicates-0.5.1.tar.gz::https://crates.io/api/v1/crates/cargo-duplicates/0.5.1/download
sha512sums = 825414d3bcd19e728f6adab7689ee66697957ac4d0dd82b73012cb18ce79fd583d4857e7fe9644907cee577219091c594c2e506977ebf041700650eb4555ad8b
-pkgname = cargo-duplicates
+pkgname = cargo-duplicates \ No newline at end of file
diff --git a/.index.json b/.index.json
index 00b17c8308eb..dcdf1dfd367e 100644
--- a/.index.json
+++ b/.index.json
@@ -1,4 +1,5 @@
{
+ ".i": 1,
"crate": "cargo-duplicates",
"version": "0.5.1"
} \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 1000624e6474..de166416ba77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,39 @@
# -*- mode: Shell-script; eval: (setq indent-tabs-mode 't); eval: (setq tab-width 4) -*-
# Maintainer: Dominic Meiser [git at msrd0 dot de]
-# Package Information
_crate="cargo-duplicates"
-pkgname="$_crate"
+pkgname="cargo-duplicates"
pkgver=0.5.1
pkgrel=1
pkgdesc='Cargo subcommand for displaying when different versions of a same dependency ...'
+url='https://crates.io/crates/cargo-duplicates'
license=('MIT')
-# Tier 1 architectures supported by Rust (https://doc.rust-lang.org/nightly/rustc/platform-support.html#tier-1)
-arch=('aarch64' 'i686' 'x86_64')
-
-# Generic Stuff for cargo packages
-url="https://crates.io/crates/$_crate"
depends=('gcc-libs' 'curl')
makedepends=('cargo')
-source=("$pkgname-$pkgver.tar.gz::https://crates.io/api/v1/crates/$_crate/$pkgver/download")
+
+source=("$_crate-$pkgver.tar.gz::https://crates.io/api/v1/crates/cargo-duplicates/0.5.1/download")
sha512sums=('825414d3bcd19e728f6adab7689ee66697957ac4d0dd82b73012cb18ce79fd583d4857e7fe9644907cee577219091c594c2e506977ebf041700650eb4555ad8b')
+# Tier 1 architectures supported by Rust (https://doc.rust-lang.org/nightly/rustc/platform-support.html#tier-1)
+arch=('aarch64' 'i686' 'x86_64')
+
+prepare() {
+ cd "$srcdir/$_crate-$pkgver"
+
+ cargo fetch --locked
+}
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$_crate-$pkgver"
LIBSSH2_SYS_USE_PKG_CONFIG='1' \
cargo build \
+ --offline \
--locked \
--release
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$_crate-$pkgver"
install -Dm755 "target/release/cargo-duplicates" -t "$pkgdir/usr/bin"
-}
+} \ No newline at end of file