summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanpi2024-02-04 14:27:03 +0100
committerSanpi2024-02-04 14:27:03 +0100
commit952d06452dfa9e10641f1456a4c07db9f27fa518 (patch)
treec03955003bbb0a46a119a303e4c76cdeb87228cb
parentab897191a7f3ffb323646fcd1fc3b1cbb7195a7a (diff)
downloadaur-cargo-flash.tar.gz
v0.18.0
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE-MIT21
-rw-r--r--PKGBUILD11
3 files changed, 33 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 431c77a037b1..b8abe2ea9fa2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = cargo-flash
pkgdesc = A cargo extension for programming microcontrollers
- pkgver = 0.13.0
- pkgrel = 2
+ pkgver = 0.18.0
+ pkgrel = 1
url = https://probe.rs/
arch = x86_64
license = MIT
license = Apache
depends = cargo
- source = 0.13.0.tar.gz::https://crates.io/api/v1/crates/cargo-flash/0.13.0/download
- sha256sums = 43949520e65576c80825308c6854029f12d9b96cb47030a57d6df2636dbac01f
+ source = 0.18.0.tar.gz::https://crates.io/api/v1/crates/cargo-flash/0.18.0/download
+ source = LICENSE-MIT
+ sha256sums = ae83883ae0a2d3e80d22c903dedceaa948faba5eee2da535da57c522b6f145ed
+ sha256sums = e9ac8b0c948a4c685b8280dd1a40dbd16bca3a089c9499f123a178725da1a411
pkgname = cargo-flash
diff --git a/LICENSE-MIT b/LICENSE-MIT
new file mode 100644
index 000000000000..164e58a8affb
--- /dev/null
+++ b/LICENSE-MIT
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 probe-rs
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 602773f62f7f..0aa13b4290bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Sanpi <sanpi+aur@homecomputing.fr>
pkgname=cargo-flash
-pkgver=0.13.0
-pkgrel=2
+pkgver=0.18.0
+pkgrel=1
pkgdesc="A cargo extension for programming microcontrollers"
url="https://probe.rs/"
arch=("x86_64")
license=("MIT" "Apache")
depends=("cargo")
-source=("$pkgver.tar.gz::https://crates.io/api/v1/crates/$pkgname/$pkgver/download")
-sha256sums=('43949520e65576c80825308c6854029f12d9b96cb47030a57d6df2636dbac01f')
+source=("$pkgver.tar.gz::https://crates.io/api/v1/crates/$pkgname/$pkgver/download" "LICENSE-MIT")
+sha256sums=('ae83883ae0a2d3e80d22c903dedceaa948faba5eee2da535da57c522b6f145ed'
+ 'e9ac8b0c948a4c685b8280dd1a40dbd16bca3a089c9499f123a178725da1a411')
prepare()
{
@@ -29,5 +30,5 @@ package()
cd "$srcdir/$pkgname-$pkgver"
install -Dm 755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm 644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 "$srcdir/LICENSE-MIT" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}