summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTatsuyuki Ishi2017-02-04 20:46:32 +0900
committerTatsuyuki Ishi2017-02-04 20:46:32 +0900
commit3053c167524d9a51ad9c4be301110bd16fc888ce (patch)
tree5f3ce6221982065b3b27664f3ddc5f828a147bae
downloadaur-3053c167524d9a51ad9c4be301110bd16fc888ce.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD56
2 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8aa06ab974c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Sat Feb 4 11:44:05 UTC 2017
+pkgbase = cargo-git
+ pkgdesc = Rust package manager
+ pkgver = 0.18.0.ad929304
+ pkgrel = 1
+ url = http://crates.io/
+ arch = x86_64
+ arch = i686
+ license = APACHE
+ license = MIT
+ license = custom
+ makedepends = git
+ makedepends = python
+ makedepends = cmake
+ makedepends = cargo
+ depends = curl
+ depends = rust
+ optdepends = gcc: for compiling C source code with gcc
+ optdepends = clang: for compiling C source code with clang
+ provides = cargo
+ conflicts = cargo
+ options = !emptydirs
+ source = git+https://github.com/rust-lang/cargo.git
+ sha512sums = SKIP
+
+pkgname = cargo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a81c8445887e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+pkgname=cargo-git
+_gitname=cargo
+pkgver=0.18.0.ad929304
+pkgrel=1
+pkgdesc='Rust package manager'
+url='http://crates.io/'
+arch=('x86_64' 'i686')
+license=('APACHE' 'MIT' 'custom')
+depends=('curl' 'rust')
+provides=('cargo')
+conflicts=('cargo')
+makedepends=('git' 'python' 'cmake' 'cargo')
+optdepends=('gcc: for compiling C source code with gcc'
+ 'clang: for compiling C source code with clang')
+options=('!emptydirs')
+source=("git+https://github.com/rust-lang/cargo.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ echo $(grep '^CFG_RELEASE_NUM=' Makefile.in|head -n1|cut -d\= -f2).$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd "$_gitname"
+
+ git submodule update --init --recursive
+ sed 's^share/doc^share/licenses^g' -i configure
+}
+
+build() {
+ cd "$_gitname"
+
+ ./configure --prefix=/usr --disable-debug
+ make
+}
+
+package() {
+ cd "$_gitname"
+
+ make DESTDIR="$pkgdir" install
+
+ # Remove files that contains references to $srcdir or $pkgdir,
+ # or that conflicts with the rust package.
+ rm -f "$pkgdir/usr/lib/rustlib/"{install.log,manifest-cargo,uninstall.sh}
+
+ install -d "$pkgdir/usr/share/bash-completion/completions"
+ mv "$pkgdir/usr/etc/bash_completion.d/cargo" \
+ "$pkgdir/usr/share/bash-completion/completions/cargo"
+
+ for f in LICENSE-APACHE LICENSE-MIT LICENSE-THIRD-PARTY; do
+ install -Dm644 "$f" "$pkgdir/usr/share/licenses/$pkgname/$f"
+ done
+}
+
+# vim:set ts=2 sw=2 et: