summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2022-07-11 15:29:10 +0200
committerKokaKiwi2022-07-11 15:29:10 +0200
commit0c9376c5f1fcf673037f2a5c30bf0551c0c73d57 (patch)
tree3e979b0334886e466865f3cb65e85bcd63483a64
downloadaur-0c9376c5f1fcf673037f2a5c30bf0551c0c73d57.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5961e82eb84f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cargo-i18n
+ pkgdesc = Cargo sub-command to extract and build localization resources to embed in your application/library
+ pkgver = 0.2.10
+ pkgrel = 1
+ url = https://github.com/kellpossible/cargo-i18n
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = cargo
+ source = cargo-i18n-0.2.10.tar.gz::https://github.com/kellpossible/cargo-i18n/archive/refs/tags/v0.2.10.tar.gz
+ cksums = 4016571452
+ sha256sums = 80482a9107ae20014c657b385b19414200acea74f67494f08c9386781cd3ec36
+ b2sums = 713bc2073e3ef5c71ffe3483ac1dcdfbc2e7c7a8be5fbb7cd67dc0b16ecb4b3e82d6a5b042c6408416e78b789e5985086f11aaaa9eabcc687800372fa0298493
+ depends_x86_64 = gcc-libs
+ depends_i686 = gcc-libs
+
+pkgname = cargo-i18n
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3480ae90305
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: KokaKiwi <kokakiwi+aur at kokakiwi dot net>
+
+pkgname=cargo-i18n
+pkgver=0.2.10
+pkgrel=1
+pkgdesc="Cargo sub-command to extract and build localization resources to embed in your application/library"
+url="https://github.com/kellpossible/cargo-i18n"
+license=('MIT')
+arch=('x86_64' 'i686')
+depends_x86_64=('gcc-libs')
+depends_i686=('gcc-libs')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/kellpossible/cargo-i18n/archive/refs/tags/v$pkgver.tar.gz")
+cksums=('4016571452')
+sha256sums=('80482a9107ae20014c657b385b19414200acea74f67494f08c9386781cd3ec36')
+b2sums=('713bc2073e3ef5c71ffe3483ac1dcdfbc2e7c7a8be5fbb7cd67dc0b16ecb4b3e82d6a5b042c6408416e78b789e5985086f11aaaa9eabcc687800372fa0298493')
+
+export RUSTUP_TOOLCHAIN=${RUSTUP_TOOLCHAIN:-stable}
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ CARGO_TARGET_DIR='target' \
+ cargo build --bin cargo-i18n --frozen --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm0755 -t "$pkgdir/usr/bin" target/release/cargo-i18n
+
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE.txt
+}