summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Malaco2020-10-17 06:50:24 -0300
committerJonas Malaco2020-10-17 06:50:24 -0300
commit2dda0f3d4676d5f13708dbcd334a28824a69008e (patch)
tree8973c1404508da4c6531711f6591511c72c6a245
parenta35c90f408fc939f0ad746230c2b545986945158 (diff)
downloadaur-2dda0f3d4676d5f13708dbcd334a28824a69008e.tar.gz
List and install alternative MIT license
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fa03a2c8637..58c859c260f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = cargo-llvm-lines
pkgdesc = Count the number of lines of LLVM IR across all instantiations of a generic function
pkgver = 0.4.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dtolnay/cargo-llvm-lines
arch = any
license = Apache
+ license = MIT
depends = cargo
depends = rust-nightly
depends = rustfmt
diff --git a/PKGBUILD b/PKGBUILD
index d3ad508d7402..e01fb219c396 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Jonas Malaco <jonas@protocubo.io>
pkgname=cargo-llvm-lines
pkgver=0.4.7
-pkgrel=1
+pkgrel=2
pkgdesc="Count the number of lines of LLVM IR across all instantiations of a generic function"
arch=('any')
url='https://github.com/dtolnay/cargo-llvm-lines'
-license=( 'Apache')
+license=('Apache' 'MIT')
depends=('cargo' 'rust-nightly' 'rustfmt')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('80b59e77dee53834dd2b0769f5719fc053c197c8d452a561de4998cc99f65b92')
@@ -24,4 +24,5 @@ check() {
package() {
cd "$pkgname-$pkgver"
install -Dm 755 target/release/${pkgname} -t "${pkgdir}/usr/bin"
+ install -Dm644 "LICENSE-MIT" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE-MIT"
}