summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Malaco2020-10-17 20:32:06 -0300
committerJonas Malaco2020-10-17 20:32:06 -0300
commit5f739a74dee41555fbd9e061c2c393278a394f3f (patch)
tree16e4947ebcaf989ca270e2139c97c9aa53380383
parent2309095a635a6948a8132fef9c6e3d6255367fe3 (diff)
downloadaur-5f739a74dee41555fbd9e061c2c393278a394f3f.tar.gz
Run cargo-llvm-lines on itself as an alternative test
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e95e4a89b3a1..26064ff848f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cargo-llvm-lines
pkgdesc = Count the number of lines of LLVM IR across all instantiations of a generic function
pkgver = 0.4.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dtolnay/cargo-llvm-lines
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index e667af22c93a..e87c702a0b1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonas Malaco <jonas@protocubo.io>
pkgname=cargo-llvm-lines
pkgver=0.4.8
-pkgrel=1
+pkgrel=2
pkgdesc="Count the number of lines of LLVM IR across all instantiations of a generic function"
arch=('any')
url='https://github.com/dtolnay/cargo-llvm-lines'
@@ -18,6 +18,10 @@ build() {
check() {
cd "$pkgname-$pkgver"
cargo test --release --locked --target-dir=target
+
+ # since currently the above runs no tests (kept only for future
+ # proofing) run cargo llvm-lines on itself
+ target/release/cargo-llvm-lines llvm-lines | head -n 8
}
package() {