summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2023-03-10 23:44:30 +0300
committerOrhun Parmaksız2023-03-10 23:44:30 +0300
commitb8709b33bf44b38ad052a285d92ac84c587fabb2 (patch)
tree21aba971833789fc9e0d4a407f14fb7e5e93fc68
parente52825a9e9d1b3250b7e22cbe239ab2fd9e165aa (diff)
downloadaur-b8709b33bf44b38ad052a285d92ac84c587fabb2.tar.gz
upgpkg: cargo-public-api-git 0.27.3.r4.g10e912b-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b03f6b40168..4b08bf21f3d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cargo-public-api-git
pkgdesc = List and diff the public API of Rust library crates (git)
- pkgver = 0.27.2.r0.ge733bb9
+ pkgver = 0.27.3.r4.g10e912b
pkgrel = 1
url = https://github.com/Enselic/cargo-public-api
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 8867d6c2713f..c20ba4732959 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# https://github.com/orhun/pkgbuilds
pkgname=cargo-public-api-git
-pkgver=0.27.2.r0.ge733bb9
+pkgver=0.27.3.r4.g10e912b
pkgrel=1
pkgdesc="List and diff the public API of Rust library crates (git)"
arch=('x86_64')
@@ -25,11 +25,16 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+ mkdir completions
}
build() {
cd "${pkgname%-git}"
cargo build --release --frozen
+ local compgen="target/release/${pkgname%-git} completions"
+ $compgen bash > "completions/${pkgname%-git}"
+ $compgen fish > "completions/${pkgname%-git}.fish"
+ $compgen zsh > "completions/_${pkgname%-git}"
}
# tests require nightly
@@ -43,4 +48,7 @@ package() {
install -Dm 755 "target/release/${pkgname%-git}" -t "${pkgdir}/usr/bin"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm 644 "completions/${pkgname%-git}" -t "$pkgdir/usr/share/bash-completion/completions/"
+ install -Dm 644 "completions/${pkgname%-git}.fish" -t "$pkgdir/usr/share/fish/vendor_completions.d/"
+ install -Dm 644 "completions/_${pkgname%-git}" -t "$pkgdir/usr/share/zsh/site-functions/"
}