summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Frankenau2017-11-04 19:01:33 +0100
committerJohannes Frankenau2017-11-04 19:02:20 +0100
commit709bb8205b1a39c9574065dbc88a731907680712 (patch)
tree057fb5d24e5b686f96d891799678ceb649919aa8
parent7117bc305d4e0aa95ea2e626b502f8129b16ca97 (diff)
downloadaur-709bb8205b1a39c9574065dbc88a731907680712.tar.gz
Update to version 0.2.9 and add README and LICENSE
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f9bafe43bd1..0f1bd0dea632 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = cargo-script
pkgdesc = Quickly and easily run Rust "scripts"
- pkgver = 0.2.0
+ pkgver = 0.2.9
pkgrel = 1
url = https://github.com/DanielKeep/cargo-script
arch = i686
arch = x86_64
license = MIT
depends = cargo
- source = git+https://github.com/DanielKeep/cargo-script.git#commit=11ad368ff6dfa862629b2d0864dcaa958caba33f
+ depends = rust
+ source = git+https://github.com/DanielKeep/cargo-script.git#commit=614e60e5932e218ebff1e471303eb0d59870d03b
sha256sums = SKIP
pkgname = cargo-script
diff --git a/PKGBUILD b/PKGBUILD
index b53a63689e37..ef2593cbf8aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
pkgname=cargo-script
-pkgver=0.2.0
+pkgver=0.2.9
pkgrel=1
pkgdesc="Quickly and easily run Rust \"scripts\""
url="https://github.com/DanielKeep/cargo-script"
-depends=('cargo')
+depends=('cargo' 'rust')
arch=('i686' 'x86_64')
license=('MIT')
-source=("git+https://github.com/DanielKeep/cargo-script.git#commit=11ad368ff6dfa862629b2d0864dcaa958caba33f")
+source=("git+https://github.com/DanielKeep/cargo-script.git#commit=614e60e5932e218ebff1e471303eb0d59870d03b")
sha256sums=('SKIP')
build() {
@@ -16,6 +16,10 @@ build() {
package() {
cd "$pkgname"
+
install -Dm755 target/release/run-cargo-script "$pkgdir/usr/bin/run-cargo-script"
install -Dm755 target/release/cargo-script "$pkgdir/usr/bin/cargo-script"
+
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}