summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanpi2020-06-11 11:03:08 +0200
committerSanpi2020-06-11 11:03:08 +0200
commitd08961b058118033675a059f13923f2be48c0958 (patch)
treecfc1ef7a2312feff5f9222a7634c5c6e81b1423c
downloadaur-d08961b058118033675a059f13923f2be48c0958.tar.gz
v0.0.16
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6c6b1c650a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cargo-spellcheck
+ pkgdesc = Checks all your documentation for spelling mistakes
+ pkgver = 0.0.16
+ pkgrel = 1
+ url = https://github.com/drahnr/cargo-spellcheck
+ arch = x86_64
+ license = MIT
+ license = Apache
+ depends = cargo
+ depends = hunspell
+ source = 0.0.16.tar.gz::https://crates.io/api/v1/crates/cargo-spellcheck/0.0.16/download
+ sha256sums = f190db5a9f20e0e8473a9c0fc8cc5e0188d17ceb8f58f8be95a227629eb1a7b7
+
+pkgname = cargo-spellcheck
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..39f18da64cb8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/*.pkg.tar.xz
+/*.tar.gz
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e5f9231f1c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sanpi <sanpi+aur@homecomputing.fr>
+pkgname=cargo-spellcheck
+pkgver=0.0.16
+pkgrel=1
+pkgdesc="Checks all your documentation for spelling mistakes"
+url="https://github.com/drahnr/$pkgname"
+arch=("x86_64")
+license=("MIT" "Apache")
+depends=("cargo" "hunspell")
+source=("$pkgver.tar.gz::https://crates.io/api/v1/crates/$pkgname/$pkgver/download")
+sha256sums=('f190db5a9f20e0e8473a9c0fc8cc5e0188d17ceb8f58f8be95a227629eb1a7b7')
+
+build()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+
+ cargo build --release
+}
+
+package()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm 755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}