summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Yang2019-03-23 12:12:29 +0800
committerMichael Yang2019-03-23 12:12:29 +0800
commitcda48828637ff3bf32eff07476321fc73643ace4 (patch)
tree7dd19783e21d1f01e3282d2198435f5d42c16455
downloadaur-cda48828637ff3bf32eff07476321fc73643ace4.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a9243b88021
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cargo-watch-git
+ pkgdesc = Watches over your Cargo project’s source
+ pkgver = 7.2.0.r234.faa34e1
+ pkgrel = 1
+ url = https://github.com/passcod/cargo-watch
+ arch = x86_64
+ license = custom: CC0-1.0
+ makedepends = cargo
+ provides = cargo-watch
+ conflicts = cargo-watch
+ source = git+https://github.com/passcod/cargo-watch.git
+ sha512sums = SKIP
+
+pkgname = cargo-watch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..766a76272af4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Michael Yang <ohmyarchlinux@protonmail.com>
+
+_pkgname=cargo-watch
+pkgname=${_pkgname}-git
+pkgver=7.2.0.r234.faa34e1
+pkgrel=1
+pkgdesc='Watches over your Cargo project’s source'
+arch=('x86_64')
+url='https://github.com/passcod/cargo-watch'
+license=('custom: CC0-1.0')
+makedepends=('cargo')
+conflicts=('cargo-watch')
+provides=('cargo-watch')
+source=('git+https://github.com/passcod/cargo-watch.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ echo $(git describe --tags).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD) | cut --characters=2-
+}
+
+build() {
+ cd ${_pkgname}
+ cargo build --release
+}
+
+package() {
+ cd ${_pkgname}
+ install -Dm755 target/release/${_pkgname} "${pkgdir}"/usr/bin/${_pkgname}
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}