summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2024-01-24 16:50:54 +0300
committerOrhun Parmaksız2024-01-24 16:50:54 +0300
commit24ce64c20c288281c07134223f56723f0dbbfd77 (patch)
tree72f7eecbc487b4babf1a08a16ed7fddc304e2974
parent0945dce357867463371eb744327fe740c1667f0d (diff)
downloadaur-24ce64c20c288281c07134223f56723f0dbbfd77.tar.gz
upgpkg: cargo-workspaces 0.3.1-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f4e54b0440e..ae1b259d2317 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cargo-workspaces
pkgdesc = Cargo plugin for managing cargo workspaces and their crates
- pkgver = 0.3.0
+ pkgver = 0.3.1
pkgrel = 1
url = https://github.com/pksunkara/cargo-workspaces
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = cargo-workspaces
depends = openssl
depends = zlib
options = !lto
- source = cargo-workspaces-0.3.0.tar.gz::https://github.com/pksunkara/cargo-workspaces/archive/v0.3.0.tar.gz
- sha512sums = 008fec3e993f239104a67065802f6c9be2bbaabace1264854e3319a2c6475bccaf8032bb8c98e78d45016b6149613d256c5fd39a04322792ab0671f7b49c1801
+ source = cargo-workspaces-0.3.1.tar.gz::https://github.com/pksunkara/cargo-workspaces/archive/v0.3.1.tar.gz
+ sha512sums = 663f515196b40bcb39cf74aafcf0088dfcb19a17ba320bc3e6ac957dc9a159ca37ad1f527b24ba787a2e751eb0912b0970c328c1eaf366077003a8ff91b8564c
pkgname = cargo-workspaces
diff --git a/PKGBUILD b/PKGBUILD
index 99fb88846f40..54ce035f0838 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# https://github.com/orhun/pkgbuilds
pkgname=cargo-workspaces
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
pkgdesc="Cargo plugin for managing cargo workspaces and their crates"
url="https://github.com/pksunkara/cargo-workspaces"
@@ -13,12 +13,12 @@ makedepends=('cargo')
arch=('x86_64')
license=('MIT')
source=("${pkgname}-${pkgver}.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha512sums=('008fec3e993f239104a67065802f6c9be2bbaabace1264854e3319a2c6475bccaf8032bb8c98e78d45016b6149613d256c5fd39a04322792ab0671f7b49c1801')
+sha512sums=('663f515196b40bcb39cf74aafcf0088dfcb19a17ba320bc3e6ac957dc9a159ca37ad1f527b24ba787a2e751eb0912b0970c328c1eaf366077003a8ff91b8564c')
options=('!lto')
prepare() {
cd "${pkgname}-${pkgver}/${pkgname}"
- cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
}
build() {