summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2017-01-05 14:21:15 -0800
committerLlewelyn Trahaearn2017-01-05 14:21:15 -0800
commite65bc8bd0ddff9c90d65570f0578a54f574b2b94 (patch)
tree85d2052bb23a2e4505c1050591ab0ad28f4a9756
parente623c5310d664e00797b5c3f7a39ad5c3bc60cd6 (diff)
downloadaur-e65bc8bd0ddff9c90d65570f0578a54f574b2b94.tar.gz
Update to latest beta release.
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD31
-rw-r--r--gcc6.patch141
3 files changed, 29 insertions, 171 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f5ce229f399..8d86ecfc7e00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Oct 2 02:33:00 UTC 2016
+# Thu Jan 5 22:20:38 UTC 2017
pkgbase = carla
pkgdesc = Audio Plugin Host
- pkgver = 1.2.4
- pkgrel = 4
+ pkgver = 1.9.7
+ pkgrel = 1
url = http://kxstudio.sf.net/carla
arch = i686
arch = x86_64
@@ -13,30 +13,34 @@ pkgbase = carla
makedepends = pygtk
makedepends = python-pyliblo
makedepends = python-pyqt4
+ makedepends = python-pyqt5
makedepends = python-rdflib
+ makedepends = qt4
makedepends = qt5-base
makedepends = zynaddsubfx
+ depends = file
depends = fftw
depends = fluidsynth
+ depends = glu
depends = liblo
- depends = libsmf
- depends = linuxsampler
+ depends = linuxsampler-svn
depends = mxml
depends = ntk-git
+ depends = projectm
depends = python
- depends = qt4
depends = zlib
optdepends = gtk2: LV2 GTK2 UI support
optdepends = gtk3: LV2 GTK3 UI support
optdepends = pygtk: NekoFilter UI
- optdepends = python-pyliblo: Carla-Control
+ optdepends = python-pyliblo: OSC support
optdepends = python-rdflib: LADSPA-RDF support
- optdepends = qt5-base: LV2 UI support
+ optdepends = qt4: LV2 QT4 UI support
+ optdepends = qt5-base: LV2 QT5 UI support
optdepends = zynaddsubfx: ZynAddSubFX banks
- source = https://downloads.sourceforge.net/project/kxstudio/Releases/carla/Carla-1.2.4-src.tar.bz2
- source = gcc6.patch
- sha512sums = bc0fd43cc2237abafc5676d1e0a002d0d85ccdf588d681f6f9e63fd4af99125de2dd31c442ae55b17d2ebfc732dfbeaf238f4cab018e100c2e76df719298fe51
- sha512sums = 8d76bc717f10f8bca22391a31d76ab97f46cf6bf586154d472c532863a562c71f79811ff6432e8923e30807b263f2135531216da04e53ae45b355dc339b03c21
+ provides = carla
+ conflicts = carla-git
+ source = https://github.com/falkTX/Carla/archive/1.9.7.tar.gz
+ sha512sums = f8b7247eace54a49398800a377efa9fb88267d52ccd0297a6fb4b64c04da24ac10260bdfe8ee8f7d15e13928dcc15c3e84a66f7c97c6a11c2bbe0e74b1d60587
pkgname = carla
diff --git a/PKGBUILD b/PKGBUILD
index 2ff109d93a0b..0825aa309dc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,35 @@
# Contributor: falkTX <falktx at gmail dot com>
pkgname=carla
-pkgver=1.2.4
-pkgrel=4
+pkgver=1.9.7
+pkgrel=1
pkgdesc="Audio Plugin Host"
arch=('i686' 'x86_64')
url="http://kxstudio.sf.net/carla"
license=('GPL2')
-depends=('fftw' 'fluidsynth' 'liblo' 'libsmf' 'linuxsampler' 'mxml' 'ntk-git' 'python' 'qt4' 'zlib')
-makedepends=('gtk2' 'gtk3' 'pygtk' 'python-pyliblo' 'python-pyqt4' 'python-rdflib' 'qt5-base' 'zynaddsubfx')
+depends=('file' 'fftw' 'fluidsynth' 'glu' 'liblo' 'linuxsampler-svn' 'mxml' 'ntk-git' 'projectm' 'python' 'zlib')
+makedepends=('gtk2' 'gtk3' 'pygtk' 'python-pyliblo' 'python-pyqt4' 'python-pyqt5' 'python-rdflib' 'qt4' 'qt5-base' 'zynaddsubfx')
optdepends=(
'gtk2: LV2 GTK2 UI support'
'gtk3: LV2 GTK3 UI support'
'pygtk: NekoFilter UI'
- 'python-pyliblo: Carla-Control'
+ 'python-pyliblo: OSC support'
'python-rdflib: LADSPA-RDF support'
- 'qt5-base: LV2 UI support'
+ 'qt4: LV2 QT4 UI support'
+ 'qt5-base: LV2 QT5 UI support'
'zynaddsubfx: ZynAddSubFX banks'
)
-source=("https://downloads.sourceforge.net/project/kxstudio/Releases/${pkgname}/Carla-${pkgver}-src.tar.bz2"
- "gcc6.patch")
-sha512sums=('bc0fd43cc2237abafc5676d1e0a002d0d85ccdf588d681f6f9e63fd4af99125de2dd31c442ae55b17d2ebfc732dfbeaf238f4cab018e100c2e76df719298fe51'
- '8d76bc717f10f8bca22391a31d76ab97f46cf6bf586154d472c532863a562c71f79811ff6432e8923e30807b263f2135531216da04e53ae45b355dc339b03c21')
-
-prepare() {
- cp gcc6.patch Carla-${pkgver}
- cd "Carla-${pkgver}"
- patch -Np1 -i ${srcdir}/gcc6.patch
-}
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+source=("https://github.com/falkTX/Carla/archive/${pkgver}.tar.gz")
+sha512sums=('f8b7247eace54a49398800a377efa9fb88267d52ccd0297a6fb4b64c04da24ac10260bdfe8ee8f7d15e13928dcc15c3e84a66f7c97c6a11c2bbe0e74b1d60587')
build() {
- cd "Carla-${pkgver}"
+ cd "${srcdir}/Carla-${pkgver}"
make
}
package() {
- cd "Carla-${pkgver}"
+ cd "${srcdir}/Carla-${pkgver}"
make DESTDIR="${pkgdir}/" PREFIX=/usr install
}
diff --git a/gcc6.patch b/gcc6.patch
deleted file mode 100644
index 99c26add9bc9..000000000000
--- a/gcc6.patch
+++ /dev/null
@@ -1,141 +0,0 @@
-From a168e5587671ec637178125d8b752dff38f39e68 Mon Sep 17 00:00:00 2001
-From: falkTX <falktx@gmail.com>
-Date: Sun, 31 Jul 2016 12:07:50 +0200
-Subject: [PATCH] Fix some compiler warnings; Fix build with new gcc
-
----
- source/backend/engine/CarlaEngineBridge.cpp | 1 +
- source/backend/plugin/CarlaPluginGui.cpp | 4 ++++
- source/backend/plugin/CarlaPluginInternal.hpp | 2 ++
- source/backend/plugin/FluidSynthPlugin.cpp | 2 +-
- source/bridges/CarlaBridgeClient.cpp | 4 ++++
- source/bridges/CarlaBridgeOsc.cpp | 3 +++
- source/bridges/CarlaBridgePlugin.cpp | 6 ++++++
- source/utils/RtList.hpp | 5 +++--
- 8 files changed, 24 insertions(+), 3 deletions(-)
-
-diff --git a/source/backend/engine/CarlaEngineBridge.cpp b/source/backend/engine/CarlaEngineBridge.cpp
-index 3e60270..91cee3b 100644
---- a/source/backend/engine/CarlaEngineBridge.cpp
-+++ b/source/backend/engine/CarlaEngineBridge.cpp
-@@ -267,6 +267,7 @@ class CarlaEngineBridge : public CarlaEngine,
- if (kData->bufEvents.in != nullptr)
- {
- // TODO
-+ (void)data; (void)time;
- }
-
- break;
-diff --git a/source/backend/plugin/CarlaPluginGui.cpp b/source/backend/plugin/CarlaPluginGui.cpp
-index e98c744..923009a 100644
---- a/source/backend/plugin/CarlaPluginGui.cpp
-+++ b/source/backend/plugin/CarlaPluginGui.cpp
-@@ -67,6 +67,10 @@ CarlaPluginGui::CarlaPluginGui(CarlaEngine* const engine, Callback* const callba
- if (! lastGeometry.isNull())
- restoreGeometry(lastGeometry);
- }
-+
-+ return;
-+ // may be unused
-+ (void)engine;
- }
-
- CarlaPluginGui::~CarlaPluginGui()
-diff --git a/source/backend/plugin/CarlaPluginInternal.hpp b/source/backend/plugin/CarlaPluginInternal.hpp
-index 97c776a..f01e402 100644
---- a/source/backend/plugin/CarlaPluginInternal.hpp
-+++ b/source/backend/plugin/CarlaPluginInternal.hpp
-@@ -29,6 +29,8 @@
-
- #include "RtList.hpp"
-
-+#include <cmath>
-+
- #define CARLA_PROCESS_CONTINUE_CHECK if (! fEnabled) { kData->engine->callback(CALLBACK_DEBUG, fId, 0, 0, 0.0f, "Processing while plugin is disabled!!"); return; }
-
- CARLA_BACKEND_START_NAMESPACE
-diff --git a/source/backend/plugin/FluidSynthPlugin.cpp b/source/backend/plugin/FluidSynthPlugin.cpp
-index 301e9aa..058a586 100644
---- a/source/backend/plugin/FluidSynthPlugin.cpp
-+++ b/source/backend/plugin/FluidSynthPlugin.cpp
-@@ -907,7 +907,7 @@ class FluidSynthPlugin : public CarlaPlugin
- fluid_preset_t f_preset;
-
- bool hasDrums = false;
-- uint32_t drumIndex, drumProg;
-+ uint32_t drumIndex = 0, drumProg = 0;
-
- f_sfont = fluid_synth_get_sfont_by_id(fSynth, fSynthId);
-
-diff --git a/source/bridges/CarlaBridgeClient.cpp b/source/bridges/CarlaBridgeClient.cpp
-index d2fb0a1..08ee15f 100644
---- a/source/bridges/CarlaBridgeClient.cpp
-+++ b/source/bridges/CarlaBridgeClient.cpp
-@@ -40,6 +40,10 @@ CarlaBridgeClient::CarlaBridgeClient(const char* const uiTitle)
- CARLA_ASSERT(uiTitle != nullptr);
- #endif
- carla_debug("CarlaBridgeClient::CarlaBridgeClient(\"%s\")", uiTitle);
-+ return;
-+
-+ // may be unused
-+ (void)uiTitle;
- }
-
- CarlaBridgeClient::~CarlaBridgeClient()
-diff --git a/source/bridges/CarlaBridgeOsc.cpp b/source/bridges/CarlaBridgeOsc.cpp
-index bcd2fd6..2fcc37f 100644
---- a/source/bridges/CarlaBridgeOsc.cpp
-+++ b/source/bridges/CarlaBridgeOsc.cpp
-@@ -207,6 +207,9 @@ int CarlaBridgeOsc::handleMessage(const char* const path, const int argc, const
-
- carla_stderr("CarlaBridgeOsc::handleMessage(\"%s\", ...) - received unsupported OSC method '%s'", path, method);
- return 1;
-+
-+ // may be unused
-+ (void)msg;
- }
-
- #ifdef BUILD_BRIDGE_UI
-diff --git a/source/bridges/CarlaBridgePlugin.cpp b/source/bridges/CarlaBridgePlugin.cpp
-index 09b23c0..32b8c34 100644
---- a/source/bridges/CarlaBridgePlugin.cpp
-+++ b/source/bridges/CarlaBridgePlugin.cpp
-@@ -438,6 +438,9 @@ int CarlaBridgeOsc::handleMsgPluginSetParameterMidiChannel(CARLA_BRIDGE_OSC_HAND
- // TODO
-
- return 0;
-+
-+ // unused
-+ (void)argc; (void)argv; (void)types;
- }
-
- int CarlaBridgeOsc::handleMsgPluginSetParameterMidiCC(CARLA_BRIDGE_OSC_HANDLE_ARGS)
-@@ -449,6 +452,9 @@ int CarlaBridgeOsc::handleMsgPluginSetParameterMidiCC(CARLA_BRIDGE_OSC_HANDLE_AR
- // TODO
-
- return 0;
-+
-+ // unused
-+ (void)argc; (void)argv; (void)types;
- }
-
- int CarlaBridgeOsc::handleMsgPluginSetChunk(CARLA_BRIDGE_OSC_HANDLE_ARGS)
-diff --git a/source/utils/RtList.hpp b/source/utils/RtList.hpp
-index 43c6715..80660b5 100644
---- a/source/utils/RtList.hpp
-+++ b/source/utils/RtList.hpp
-@@ -27,11 +27,12 @@ extern "C" {
-
- // Declare non copyable and prevent heap allocation
- #define LIST_DECLARATIONS(ClassName) \
-+private: \
- ClassName(ClassName&); \
- ClassName(const ClassName&); \
-+ ClassName& operator=(ClassName&); \
- ClassName& operator=(const ClassName&); \
-- static void* operator new (size_t) { return nullptr; } \
-- static void operator delete (void*) {}
-+ static void* operator new (size_t);
-
- typedef struct list_head k_list_head;
-