summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2016-07-31 16:35:42 -0700
committerLlewelyn Trahaearn2016-07-31 16:35:42 -0700
commitf6b957feb489bb48a2d88de1f8a386d07a81a5f8 (patch)
tree20685698c4245f18a03714c23fb26120b5948992
parent57146fa6223d2b0827d81bb59c0d32a6b90d899b (diff)
downloadaur-f6b957feb489bb48a2d88de1f8a386d07a81a5f8.tar.gz
Patch for GCC 6.1.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
-rw-r--r--gcc6.patch141
3 files changed, 158 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4633a321a48c..a781fe360a3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Feb 14 00:29:40 UTC 2016
+# Sun Jul 31 23:35:28 UTC 2016
pkgbase = carla
pkgdesc = Audio Plugin Host
pkgver = 1.2.4
- pkgrel = 3
+ pkgrel = 4
url = http://kxstudio.sf.net/carla
install = carla.install
arch = i686
@@ -37,7 +37,9 @@ pkgbase = carla
provides = carla
conflicts = carla-git
source = https://downloads.sourceforge.net/project/kxstudio/Releases/carla/Carla-1.2.4-src.tar.bz2
+ source = gcc6.patch
sha512sums = bc0fd43cc2237abafc5676d1e0a002d0d85ccdf588d681f6f9e63fd4af99125de2dd31c442ae55b17d2ebfc732dfbeaf238f4cab018e100c2e76df719298fe51
+ sha512sums = 8d76bc717f10f8bca22391a31d76ab97f46cf6bf586154d472c532863a562c71f79811ff6432e8923e30807b263f2135531216da04e53ae45b355dc339b03c21
pkgname = carla
diff --git a/PKGBUILD b/PKGBUILD
index 25cafc34200d..b3bbf277b8dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=carla
pkgver=1.2.4
-pkgrel=3
+pkgrel=4
pkgdesc="Audio Plugin Host"
arch=('i686' 'x86_64')
url="http://kxstudio.sf.net/carla"
@@ -22,15 +22,23 @@ optdepends=(
provides=("${pkgname}")
conflicts=("${pkgname}-git")
install=${pkgname}.install
-source=("https://downloads.sourceforge.net/project/kxstudio/Releases/${pkgname}/Carla-${pkgver}-src.tar.bz2")
-sha512sums=('bc0fd43cc2237abafc5676d1e0a002d0d85ccdf588d681f6f9e63fd4af99125de2dd31c442ae55b17d2ebfc732dfbeaf238f4cab018e100c2e76df719298fe51')
+source=("https://downloads.sourceforge.net/project/kxstudio/Releases/${pkgname}/Carla-${pkgver}-src.tar.bz2"
+ "gcc6.patch")
+sha512sums=('bc0fd43cc2237abafc5676d1e0a002d0d85ccdf588d681f6f9e63fd4af99125de2dd31c442ae55b17d2ebfc732dfbeaf238f4cab018e100c2e76df719298fe51'
+ '8d76bc717f10f8bca22391a31d76ab97f46cf6bf586154d472c532863a562c71f79811ff6432e8923e30807b263f2135531216da04e53ae45b355dc339b03c21')
+
+prepare() {
+ cp gcc6.patch Carla-${pkgver}
+ cd "Carla-${pkgver}"
+ patch -Np1 -i ${srcdir}/gcc6.patch
+}
build() {
- cd "${srcdir}/Carla-${pkgver}"
+ cd "Carla-${pkgver}"
make
}
package() {
- cd "${srcdir}/Carla-${pkgver}"
+ cd "Carla-${pkgver}"
make DESTDIR="${pkgdir}/" PREFIX=/usr install
}
diff --git a/gcc6.patch b/gcc6.patch
new file mode 100644
index 000000000000..99c26add9bc9
--- /dev/null
+++ b/gcc6.patch
@@ -0,0 +1,141 @@
+From a168e5587671ec637178125d8b752dff38f39e68 Mon Sep 17 00:00:00 2001
+From: falkTX <falktx@gmail.com>
+Date: Sun, 31 Jul 2016 12:07:50 +0200
+Subject: [PATCH] Fix some compiler warnings; Fix build with new gcc
+
+---
+ source/backend/engine/CarlaEngineBridge.cpp | 1 +
+ source/backend/plugin/CarlaPluginGui.cpp | 4 ++++
+ source/backend/plugin/CarlaPluginInternal.hpp | 2 ++
+ source/backend/plugin/FluidSynthPlugin.cpp | 2 +-
+ source/bridges/CarlaBridgeClient.cpp | 4 ++++
+ source/bridges/CarlaBridgeOsc.cpp | 3 +++
+ source/bridges/CarlaBridgePlugin.cpp | 6 ++++++
+ source/utils/RtList.hpp | 5 +++--
+ 8 files changed, 24 insertions(+), 3 deletions(-)
+
+diff --git a/source/backend/engine/CarlaEngineBridge.cpp b/source/backend/engine/CarlaEngineBridge.cpp
+index 3e60270..91cee3b 100644
+--- a/source/backend/engine/CarlaEngineBridge.cpp
++++ b/source/backend/engine/CarlaEngineBridge.cpp
+@@ -267,6 +267,7 @@ class CarlaEngineBridge : public CarlaEngine,
+ if (kData->bufEvents.in != nullptr)
+ {
+ // TODO
++ (void)data; (void)time;
+ }
+
+ break;
+diff --git a/source/backend/plugin/CarlaPluginGui.cpp b/source/backend/plugin/CarlaPluginGui.cpp
+index e98c744..923009a 100644
+--- a/source/backend/plugin/CarlaPluginGui.cpp
++++ b/source/backend/plugin/CarlaPluginGui.cpp
+@@ -67,6 +67,10 @@ CarlaPluginGui::CarlaPluginGui(CarlaEngine* const engine, Callback* const callba
+ if (! lastGeometry.isNull())
+ restoreGeometry(lastGeometry);
+ }
++
++ return;
++ // may be unused
++ (void)engine;
+ }
+
+ CarlaPluginGui::~CarlaPluginGui()
+diff --git a/source/backend/plugin/CarlaPluginInternal.hpp b/source/backend/plugin/CarlaPluginInternal.hpp
+index 97c776a..f01e402 100644
+--- a/source/backend/plugin/CarlaPluginInternal.hpp
++++ b/source/backend/plugin/CarlaPluginInternal.hpp
+@@ -29,6 +29,8 @@
+
+ #include "RtList.hpp"
+
++#include <cmath>
++
+ #define CARLA_PROCESS_CONTINUE_CHECK if (! fEnabled) { kData->engine->callback(CALLBACK_DEBUG, fId, 0, 0, 0.0f, "Processing while plugin is disabled!!"); return; }
+
+ CARLA_BACKEND_START_NAMESPACE
+diff --git a/source/backend/plugin/FluidSynthPlugin.cpp b/source/backend/plugin/FluidSynthPlugin.cpp
+index 301e9aa..058a586 100644
+--- a/source/backend/plugin/FluidSynthPlugin.cpp
++++ b/source/backend/plugin/FluidSynthPlugin.cpp
+@@ -907,7 +907,7 @@ class FluidSynthPlugin : public CarlaPlugin
+ fluid_preset_t f_preset;
+
+ bool hasDrums = false;
+- uint32_t drumIndex, drumProg;
++ uint32_t drumIndex = 0, drumProg = 0;
+
+ f_sfont = fluid_synth_get_sfont_by_id(fSynth, fSynthId);
+
+diff --git a/source/bridges/CarlaBridgeClient.cpp b/source/bridges/CarlaBridgeClient.cpp
+index d2fb0a1..08ee15f 100644
+--- a/source/bridges/CarlaBridgeClient.cpp
++++ b/source/bridges/CarlaBridgeClient.cpp
+@@ -40,6 +40,10 @@ CarlaBridgeClient::CarlaBridgeClient(const char* const uiTitle)
+ CARLA_ASSERT(uiTitle != nullptr);
+ #endif
+ carla_debug("CarlaBridgeClient::CarlaBridgeClient(\"%s\")", uiTitle);
++ return;
++
++ // may be unused
++ (void)uiTitle;
+ }
+
+ CarlaBridgeClient::~CarlaBridgeClient()
+diff --git a/source/bridges/CarlaBridgeOsc.cpp b/source/bridges/CarlaBridgeOsc.cpp
+index bcd2fd6..2fcc37f 100644
+--- a/source/bridges/CarlaBridgeOsc.cpp
++++ b/source/bridges/CarlaBridgeOsc.cpp
+@@ -207,6 +207,9 @@ int CarlaBridgeOsc::handleMessage(const char* const path, const int argc, const
+
+ carla_stderr("CarlaBridgeOsc::handleMessage(\"%s\", ...) - received unsupported OSC method '%s'", path, method);
+ return 1;
++
++ // may be unused
++ (void)msg;
+ }
+
+ #ifdef BUILD_BRIDGE_UI
+diff --git a/source/bridges/CarlaBridgePlugin.cpp b/source/bridges/CarlaBridgePlugin.cpp
+index 09b23c0..32b8c34 100644
+--- a/source/bridges/CarlaBridgePlugin.cpp
++++ b/source/bridges/CarlaBridgePlugin.cpp
+@@ -438,6 +438,9 @@ int CarlaBridgeOsc::handleMsgPluginSetParameterMidiChannel(CARLA_BRIDGE_OSC_HAND
+ // TODO
+
+ return 0;
++
++ // unused
++ (void)argc; (void)argv; (void)types;
+ }
+
+ int CarlaBridgeOsc::handleMsgPluginSetParameterMidiCC(CARLA_BRIDGE_OSC_HANDLE_ARGS)
+@@ -449,6 +452,9 @@ int CarlaBridgeOsc::handleMsgPluginSetParameterMidiCC(CARLA_BRIDGE_OSC_HANDLE_AR
+ // TODO
+
+ return 0;
++
++ // unused
++ (void)argc; (void)argv; (void)types;
+ }
+
+ int CarlaBridgeOsc::handleMsgPluginSetChunk(CARLA_BRIDGE_OSC_HANDLE_ARGS)
+diff --git a/source/utils/RtList.hpp b/source/utils/RtList.hpp
+index 43c6715..80660b5 100644
+--- a/source/utils/RtList.hpp
++++ b/source/utils/RtList.hpp
+@@ -27,11 +27,12 @@ extern "C" {
+
+ // Declare non copyable and prevent heap allocation
+ #define LIST_DECLARATIONS(ClassName) \
++private: \
+ ClassName(ClassName&); \
+ ClassName(const ClassName&); \
++ ClassName& operator=(ClassName&); \
+ ClassName& operator=(const ClassName&); \
+- static void* operator new (size_t) { return nullptr; } \
+- static void operator delete (void*) {}
++ static void* operator new (size_t);
+
+ typedef struct list_head k_list_head;
+