summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2017-07-20 23:38:23 +0200
committerChristopher Arndt2017-07-20 23:38:23 +0200
commit0cf68307e48e496172843f60eabc8ed078d5a72c (patch)
treea78be2e330acb6cb31bd90a097f2dc63e56988f9
parent8cb4e80c171b18cc91cfac758b701c7eb16b1cd7 (diff)
downloadaur-0cf68307e48e496172843f60eabc8ed078d5a72c.tar.gz
New maintainer, cleanup
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD73
-rw-r--r--carla-git.install0
-rw-r--r--changelog.txt9
4 files changed, 82 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74adb0ff9ad4..d587997b5644 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,39 @@
# Generated by mksrcinfo v8
-# Fri Jan 6 12:38:06 UTC 2017
+# Thu Jul 20 21:37:39 UTC 2017
pkgbase = carla-git
pkgdesc = Audio Plugin Host
- pkgver = 1.9.7.r6.g3075aa2c
+ pkgver = 1.9.7b.r2.gc57e8169
pkgrel = 1
+ epoch = 1
url = http://kxstudio.sf.net/carla
- install = carla-git.install
+ changelog = changelog.txt
arch = i686
arch = x86_64
license = GPL2
+ makedepends = clxclient
+ makedepends = fluidsynth
makedepends = git
- depends = python-pyqt5
- depends = qt5-svg
+ makedepends = gtk2
+ makedepends = gtk3
+ makedepends = qt4
+ depends = file
depends = fluidsynth
- depends = gtk2
- depends = gtk3
- depends = qt4
+ depends = glu
depends = liblo
depends = linuxsampler
depends = mxml
depends = ntk-git
- depends = fftw
- depends = file
- optdepends = zlib: extra native plugins
- optdepends = zynaddsubfx: zynaddsubfx banks
+ depends = projectm
+ depends = python-pyqt5
+ depends = zita-convolver
+ depends = zita-resampler
+ optdepends = clxclient: internal plugins UI support
+ optdepends = gtk2: LV2 GTK2 UI support
+ optdepends = gtk3: LV2 GTK3 UI support
+ optdepends = python-pyliblo: OSC control support
+ optdepends = python-rdflib: LADSPA-RDF support
+ optdepends = qt4: LV2 QT4 UI support
+ optdepends = zynaddsubfx: zynaddsubfx sound banks
provides = carla
conflicts = carla
source = carla-git::git://github.com/falkTX/Carla.git
diff --git a/PKGBUILD b/PKGBUILD
index ce884537028c..2e65952aa803 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,50 @@
-# Maintainer: cocreature <moritz.kiefer<at>purelyfunctional<dot>org>
-# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Contributor: cocreature <moritz.kiefer<at>purelyfunctional<dot>org>
pkgname=carla-git
-pkgver=1.9.7.r16.g5a95517b
+pkgver=1.9.7b.r2.gc57e8169
pkgrel=1
+epoch=1
pkgdesc="Audio Plugin Host"
arch=("i686" "x86_64")
url="http://kxstudio.sf.net/carla"
license=("GPL2")
conflicts=("carla")
provides=("carla")
-depends=("python-pyqt5"
- "qt5-svg"
- "fluidsynth"
- "gtk2"
- "gtk3"
- "qt4"
- "liblo"
- "linuxsampler"
- "mxml"
- "ntk-git"
- "fftw"
- "file")
-makedepends=("git")
-optdepends=("pygtk: NekoFilter UI"
- "zlib: extra native plugins"
- "zynaddsubfx: zynaddsubfx banks")
+depends=(
+ 'file'
+ 'fluidsynth'
+ 'glu'
+ 'liblo'
+ 'linuxsampler'
+ 'mxml'
+ 'ntk-git'
+ 'projectm'
+ 'python-pyqt5'
+ 'zita-convolver'
+ 'zita-resampler'
+)
+makedepends=(
+ 'clxclient'
+ 'fluidsynth'
+ 'git'
+ 'gtk2'
+ 'gtk3'
+ 'qt4'
+)
+optdepends=(
+ 'clxclient: internal plugins UI support'
+ 'gtk2: LV2 GTK2 UI support'
+ 'gtk3: LV2 GTK3 UI support'
+ 'python-pyliblo: OSC control support'
+ 'python-rdflib: LADSPA-RDF support'
+ 'qt4: LV2 QT4 UI support'
+ 'zynaddsubfx: zynaddsubfx sound banks'
+)
source=("$pkgname"::"git://github.com/falkTX/Carla.git")
md5sums=('SKIP')
-install="$pkgname.install"
+changelog='changelog.txt'
+
pkgver() {
cd "$srcdir/$pkgname"
@@ -43,10 +59,23 @@ prepare() {
build() {
cd "$srcdir/$pkgname"
- make DEFAULT_QT=5 EXPERIMENTAL_PLUGINS=true
+ make \
+ EXPERIMENTAL_PLUGINS=true \
+ DEFAULT_QT=5 \
+ MOC_QT5=/usr/bin/moc-qt5 \
+ RCC_QT5=/usr/bin/rcc-qt5 \
+ UIC_QT5=/usr/bin/uic-qt5
}
package() {
cd "$srcdir/$pkgname"
- make DEFAULT_QT=5 EXPERIMENTAL_PLUGINS=true DESTDIR="$pkgdir/" PREFIX=/usr install
+ make \
+ EXPERIMENTAL_PLUGINS=true \
+ DEFAULT_QT=5 \
+ MOC_QT5=/usr/bin/moc-qt5 \
+ RCC_QT5=/usr/bin/rcc-qt5 \
+ UIC_QT5=/usr/bin/uic-qt5 \
+ DESTDIR="$pkgdir/" \
+ PREFIX=/usr \
+ install
}
diff --git a/carla-git.install b/carla-git.install
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/carla-git.install
+++ /dev/null
diff --git a/changelog.txt b/changelog.txt
new file mode 100644
index 000000000000..0b9880271e7e
--- /dev/null
+++ b/changelog.txt
@@ -0,0 +1,9 @@
+2017-07-20 Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+ * 1:1.9.7b.r2.gc57e8169-1 :
+ New PKBUILD maintainer.
+ Added 'changelog.txt' file.
+ Set epoch to 1, since version number now has a 'b' prefix.
+ Fixed missing Qt5 plugin bridge.
+ Removed obsolete 'carla.install' file.
+ Updated / cleaned / fixed dependencies.