summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-07-16 16:00:17 +0200
committerChristopher Arndt2022-07-16 16:00:17 +0200
commita618943e6f83fbe469243f9485b7a75b22f6fc01 (patch)
tree4d89c668e6b332a0c0c46522588155cda6ca4752
parentd5b9b3e5358d6c9237f607d0763ff48065004e1a (diff)
downloadaur-a618943e6f83fbe469243f9485b7a75b22f6fc01.tar.gz
New upstzream release and PKGBUILD improvements
-rw-r--r--.SRCINFO52
-rw-r--r--PKGBUILD70
-rw-r--r--changelog.txt5
3 files changed, 85 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2afb62c8f36e..7e3af769f9c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,59 @@
pkgbase = carla-git
pkgdesc = Audio Plugin Host
- pkgver = 2.4.0.r8.g846312632
+ pkgver = 2.5.0.r1.ge3b25116d
pkgrel = 1
epoch = 1
- url = http://kxstudio.sf.net/carla
+ url = https://kx.studio/Applications:Carla
changelog = changelog.txt
arch = i686
arch = x86_64
- license = GPL2+
+ license = GPL2
+ makedepends = file
+ makedepends = fluidsynth
+ makedepends = freetype2
makedepends = git
- makedepends = gtk2
- makedepends = gtk3
- depends = ffmpeg
- depends = file
- depends = fluidsynth
- depends = liblo
+ makedepends = liblo
+ makedepends = libpulse
+ makedepends = libsndfile
+ makedepends = qt5-tools
+ depends = alsa-lib
+ depends = gcc-libs
+ depends = glibc
+ depends = hicolor-icon-theme
+ depends = libglvnd
+ depends = libx11
depends = python-pyqt5
+ depends = qt5-base
depends = qt5-svg
- optdepends = gtk2: LV2 GTK2 UI support
- optdepends = gtk3: LV2 GTK3 UI support
+ optdepends = jack: for using carla with JACK
+ optdepends = lv2-host: for the LV2 plugin
+ optdepends = vst-host: for the VST plugin
optdepends = python-pyliblo: OSC control support
optdepends = python-rdflib: LADSPA-RDF support
provides = carla
+ provides = dssi-host
+ provides = ladspa-host
+ provides = lv2-host
+ provides = vst-host
+ provides = vst3-host
conflicts = carla
source = carla::git+https://github.com/falkTX/Carla.git
md5sums = SKIP
pkgname = carla-git
+ depends = alsa-lib
+ depends = gcc-libs
+ depends = glibc
+ depends = hicolor-icon-theme
+ depends = libglvnd
+ depends = libx11
+ depends = python-pyqt5
+ depends = qt5-base
+ depends = qt5-svg
+ depends = libasound.so
+ depends = libfluidsynth.so
+ depends = libfreetype.so
+ depends = liblo.so
+ depends = libmagic.so
+ depends = libpulse.so
+ depends = libsndfile.so
diff --git a/PKGBUILD b/PKGBUILD
index dac99bcd5788..9f1bf6b608cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,64 +1,72 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
# Contributor: cocreature <moritz.kiefer<at>purelyfunctional<dot>org>
-_pkgname="carla"
-pkgname="${_pkgname}-git"
-pkgver=2.4.0.r8.g846312632
+_name=Carla
+_pkgname="${_name,,}"
+pkgname="$_pkgname-git"
+pkgver=2.5.0.r1.ge3b25116d
pkgrel=1
epoch=1
pkgdesc="Audio Plugin Host"
-arch=("i686" "x86_64")
-url="http://kxstudio.sf.net/carla"
-license=("GPL2+")
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
+arch=(i686 x86_64)
+url='https://kx.studio/Applications:Carla'
+license=(GPL2)
+conflicts=("$_pkgname")
+provides=("$_pkgname" dssi-host ladspa-host lv2-host vst-host vst3-host)
depends=(
- 'ffmpeg'
- 'file'
- 'fluidsynth'
- 'liblo'
- 'python-pyqt5'
- 'qt5-svg'
+ alsa-lib
+ gcc-libs
+ glibc
+ hicolor-icon-theme
+ libglvnd
+ libx11
+ python-pyqt5
+ qt5-base
+ qt5-svg
)
makedepends=(
- 'git'
- 'gtk2'
- 'gtk3'
+ file
+ fluidsynth
+ freetype2
+ git
+ liblo
+ libpulse
+ libsndfile
+ qt5-tools
)
optdepends=(
- 'gtk2: LV2 GTK2 UI support'
- 'gtk3: LV2 GTK3 UI support'
+ 'jack: for using carla with JACK'
+ 'lv2-host: for the LV2 plugin'
+ 'vst-host: for the VST plugin'
'python-pyliblo: OSC control support'
'python-rdflib: LADSPA-RDF support'
)
-source=("${_pkgname}::git+https://github.com/falkTX/Carla.git")
+source=("$_pkgname::git+https://github.com/falkTX/$_name.git")
md5sums=('SKIP')
changelog='changelog.txt'
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
git describe --long --tags | sed "s/\([^-]*-g\)/r\1/;s/-/./g;s/^v//"
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
make features
make \
- HAVE_QT4=false \
- MOC_QT5=/usr/bin/moc-qt5 \
- RCC_QT5=/usr/bin/rcc-qt5 \
- UIC_QT5=/usr/bin/uic-qt5
+ DEFAULT_QT=5 \
+ HAVE_QT4=false
}
package() {
- cd "${srcdir}/${_pkgname}"
+ depends+=(libasound.so libfluidsynth.so libfreetype.so liblo.so libmagic.so
+ libpulse.so libsndfile.so)
+ cd $_pkgname
make \
+ DEFAULT_QT=5 \
HAVE_QT4=false \
- MOC_QT5=/usr/bin/moc-qt5 \
- RCC_QT5=/usr/bin/rcc-qt5 \
- UIC_QT5=/usr/bin/uic-qt5 \
- DESTDIR="${pkgdir}/" \
+ DESTDIR="$pkgdir" \
PREFIX=/usr \
install
}
diff --git a/changelog.txt b/changelog.txt
index aad9c515e0f5..e02b1971a341 100644
--- a/changelog.txt
+++ b/changelog.txt
@@ -1,3 +1,8 @@
+2022-07-16 Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+ * 2.5.0.r1.ge3b25116d
+ Updated to be more in line with release package in community repo
+
2021-03-17 Christopher Arndt <aur -at- chrisarndt -dot- de>
* 2.3.0.RC2.r0.g2294a5c86-1