summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Elkouby2020-10-04 14:59:40 +0300
committerDan Elkouby2020-10-04 14:59:40 +0300
commitbc1f60451e4019cd489362187af16a71e3b38802 (patch)
treeb3160a22e63a82e204c5468d8b09ae85844abcf8
parent36013f64918a71508c372a661f3e2df5f07a003a (diff)
downloadaur-bc1f60451e4019cd489362187af16a71e3b38802.tar.gz
Minor fixes
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD30
4 files changed, 21 insertions, 32 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index bc4d9dd88ea6..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,14 +0,0 @@
-pkgbase = carps-cups
- pkgdesc = CUPS driver for Canon CARPS printers
- pkgver = r149.778be89
- pkgrel = 1
- url = https://github.com/ondrej-zary/carps-cups
- arch = i686
- arch = x86_64
- license = GPL
- makedepends = git
- depends = libcups
- source = git://github.com/ondrej-zary/carps-cups.git
-
-pkgname = carps-cups
-
diff --git a/.SRCINFO b/.SRCINFO
index fafe62aa5eaf..3f4d1abfc825 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
-pkgbase = carps-cups
+pkgbase = carps-cups-git
pkgdesc = CUPS driver for Canon CARPS printers
- pkgver = r149.778be89
+ pkgver = r158.18d80d1
pkgrel = 1
url = https://github.com/ondrej-zary/carps-cups
- arch = i686
arch = x86_64
license = GPL
makedepends = git
@@ -11,5 +10,5 @@ pkgbase = carps-cups
source = git://github.com/ondrej-zary/carps-cups.git
md5sums = SKIP
-pkgname = carps-cups
+pkgname = carps-cups-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e9d11f65457e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.tar*
+carps-cups
diff --git a/PKGBUILD b/PKGBUILD
index 69163d409d50..9f37b8949eb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,12 @@
+# Maintainer: Dan Elkouby <streetwalkermc@gmail.com>
# Maintainer: Aerion <Aerion (emile [at] aerion [dot] co [dot] uk>
-pkgname=carps-cups
-pkgver=r149.778be89
+_pkgname=carps-cups
+pkgname=${_pkgname}-git
+pkgver=r158.18d80d1
pkgrel=1
pkgdesc="CUPS driver for Canon CARPS printers"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/ondrej-zary/carps-cups"
license=('GPL')
depends=('libcups')
@@ -13,24 +15,24 @@ source=('git://github.com/ondrej-zary/carps-cups.git')
md5sums=('SKIP')
pkgver() {
- cd "${pkgname}"
+ cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build () {
- cd "${pkgname}"
- make
+ cd "${_pkgname}"
+ make CFLAGS+="$LDFLAGS"
}
package() {
- # install CARPS drivers
- cd "${pkgname}"
- install -d "${pkgdir}/usr/lib/cups/filter"
- install -s rastertocarps "${pkgdir}/usr/lib/cups/filter/rastertocarps"
- install -D -m 644 carps.drv "${pkgdir}/usr/share/cups/drv/carps.drv"
+ # install CARPS drivers
+ cd "${_pkgname}"
+ install -d "${pkgdir}/usr/lib/cups/filter"
+ install -s rastertocarps "${pkgdir}/usr/lib/cups/filter/rastertocarps"
+ install -D -m 644 carps.drv "${pkgdir}/usr/share/cups/drv/carps.drv"
- # install CARPS PPDs
- cd "$srcdir/$pkgname/ppd"
- find . -type f -exec install -D -m 644 {,${pkgdir}/usr/share/cups/model/CARPS/}{} \;
+ # install CARPS PPDs
+ cd "$srcdir/$_pkgname/ppd"
+ find . -type f -exec install -D -m 644 {,${pkgdir}/usr/share/cups/model/CARPS/}{} \;
}