summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Solimano2020-09-24 13:13:25 -0300
committerManuel Solimano2020-10-02 19:33:25 -0300
commit3ee0c1382a9943f6fec68a10085231f64e5c37fd (patch)
tree9c2d2bbc4134135a03741af69d50ec85ce787035
downloadaur-3ee0c1382a9943f6fec68a10085231f64e5c37fd.tar.gz
First commit
Fixed missing .so files Email disguise Added .SRCINFO
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD54
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fcbcb52263b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = carta-appimage
+ pkgdesc = Cube Analysis and Rendering Tool for Astronomy
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://cartavis.github.io
+ arch = x86_64
+ license = GPL3
+ depends = zlib
+ depends = hicolor-icon-theme
+ depends = electron
+ depends = libidn11
+ depends = rtmpdump
+ noextract = CARTA.AppImage
+ options = !strip
+ source_x86_64 = carta-appimage-v1.4.tgz::https://github.com/CARTAvis/carta-releases/releases/download/v1.4/CARTA-v1.4-ubuntu.tgz
+ source_x86_64 = LICENSE::https://raw.githubusercontent.com/CARTAvis/carta-backend/v1.4.0/COPYING.md
+ sha256sums_x86_64 = c1e1ac5b1dd76ee066f4e74cfcbbbdbaeddf000427e96f97803ec936f66875b5
+ sha256sums_x86_64 = 26c03bc049c15fc5b9e52d791a06f1a6bc32f89edc8f8c701ab0aadf66e85b82
+
+pkgname = carta-appimage
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e38d3aab59be
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+# Created by https://www.toptal.com/developers/gitignore/api/archlinuxpackages
+# Edit at https://www.toptal.com/developers/gitignore?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+LICENSE
+
+pkg/
+src/
+
+# End of https://www.toptal.com/developers/gitignore/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3b1a90f6e5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Manuel Solimano <masolimano at uc dot cl>
+
+pkgname=carta-appimage
+_pkgname="carta"
+pkgver=1.4
+pkgrel=1
+pkgdesc="Cube Analysis and Rendering Tool for Astronomy"
+arch=('x86_64')
+url="https://cartavis.github.io"
+license=('GPL3')
+depends=('zlib' 'hicolor-icon-theme' 'electron' 'libidn11' 'rtmpdump')
+options=(!strip)
+_appimage="CARTA.AppImage"
+source_x86_64=("${pkgname}-v${pkgver}.tgz::https://github.com/CARTAvis/carta-releases/releases/download/v${pkgver}/CARTA-v${pkgver}-ubuntu.tgz"
+ "LICENSE::https://raw.githubusercontent.com/CARTAvis/carta-backend/v${pkgver}.0/COPYING.md"
+ )
+noextract=("${_appimage}")
+sha256sums_x86_64=('c1e1ac5b1dd76ee066f4e74cfcbbbdbaeddf000427e96f97803ec936f66875b5'
+ '26c03bc049c15fc5b9e52d791a06f1a6bc32f89edc8f8c701ab0aadf66e85b82')
+
+prepare() {
+ chmod +x "${_appimage}"
+ ./"${_appimage}" --appimage-extract
+}
+
+build() {
+ # Adjust .desktop so it will work outside of AppImage container
+ sed -i -E "s|Exec=AppRun|Exec=env DESKTOPINTEGRATION=false /usr/bin/${_pkgname}|"\
+ "squashfs-root/${_pkgname^^}.desktop"
+ # Fix permissions; .AppImage permissions are 700 for all directories
+ chmod -R a-x+rX squashfs-root/usr
+}
+
+package() {
+ # AppImage
+ install -Dm755 "${srcdir}/${_appimage}" "${pkgdir}/opt/${pkgname}/${pkgname}.AppImage"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/opt/${pkgname}/LICENSE"
+
+ # Desktop file
+ install -Dm644 "${srcdir}/squashfs-root/${_pkgname^^}.desktop"\
+ "${pkgdir}/usr/share/applications/${_pkgname^^}.desktop"
+
+ # Icon images
+ install -dm755 "${pkgdir}/usr/share/"
+ cp -a "${srcdir}/squashfs-root/usr/share/icons" "${pkgdir}/usr/share/"
+
+ # Symlink executable
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/${pkgname}.AppImage" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # Symlink license
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ ln -s "/opt/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}