summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZezadas2015-10-27 11:50:34 +0000
committerZezadas2015-10-27 11:50:34 +0000
commit385a7723efbd9ddb91c4149854a48f8ee059a9ff (patch)
tree11525c4d6c54484f4ec258b513f64ae62ca66914
downloadaur-385a7723efbd9ddb91c4149854a48f8ee059a9ff.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD61
-rw-r--r--cartao-cidadao-svn.install9
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d0aa4ed5726
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = cartao-cidadao-svn
+ pkgdesc = Cartao de Cidadaozadas
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://svn.gov.pt/projects/ccidadao
+ install = cartao-cidadao-svn.install
+ arch = any
+ license = GPL
+ depends = qtchooser
+ depends = svn
+ depends = qt4
+ depends = pcsclite>=1.5.0
+ depends = jasper
+ depends = openssl
+ depends = xerces-c
+ depends = ccid
+ depends = pcsclite
+ conflicts = cartao-cidadao
+ source = svn+https://svn.gov.pt/projects/ccidadao/repository/middleware-offline/trunk/_src/
+ md5sums = SKIP
+
+pkgname = cartao-cidadao-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39b607c1bb06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: zezadas jmrm@ua.pt https://www.github.com/zezadas
+pkgname=cartao-cidadao-svn
+pkgver=1.0
+pkgrel=0
+pkgdesc="Cartao de Cidadaozadas"
+depends=('qtchooser' 'svn' 'qt4' 'pcsclite>=1.5.0' 'jasper' 'openssl' 'xerces-c' 'ccid' 'pcsclite')
+arch=('any')
+url="https://svn.gov.pt/projects/ccidadao"
+license=('GPL')
+source=(svn+https://svn.gov.pt/projects/ccidadao/repository/middleware-offline/trunk/_src/)
+md5sums=('SKIP')
+conflicts=('cartao-cidadao')
+install=$pkgname.install
+
+build() {
+
+
+ cd "${pkgsrc}"
+ # #svn co https://svn.gov.pt/projects/ccidadao/repository/middleware-offline/trunk/_src/
+ # cd "${srcdir}/_src/eidmw/"
+ # chmod +x ./configure
+ # #some error with static libs and .rodata solved
+ # unset CPPFLAGS
+ # unset CFLAGS
+ # unset CXXFLAGS
+ # unset LDFLAGS
+ # #compile with qt4
+ # export QT_SELECT=4
+ # export QTDIR=/usr/share/qt4
+ # export QMAKESPEC=/usr/share/qt4/mkspecs/linux-g++
+ # export QT_LIBRARY_PATH=/usr/include/Qt
+ #
+ ##dunno what I'm doing.
+ ##soo ashamed of this sed :()
+ ##dunno why it keeps copying files to /usr/local
+ #grep -ir usr\/local | cut -d ':' -f 1 | uniq | grep -v secmod.db > replaces
+ #FILE=replaces
+ #
+ #while read CMD; do
+ # sed -i 's/usr\/local/usr/g' "$CMD"
+ #done < "$FILE"
+ #
+ #./configure --prefix=/usr
+ #make
+}
+
+
+
+package() {
+ cd "${srcdir}/_src/eidmw/"
+ make DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install
+ echo "...fixing things for arch..."
+ cd "${srcdir}/_src/eDT"
+ mkdir -p "$pkgdir/usr/include/"
+ cp -r "DiagLib" "$pkgdir/usr/include/pteid"
+ find "$pkgdir/usr/local/bin/" -maxdepth 1 -type f -print0 | xargs -0 mv -t "$pkgdir/usr/bin"
+ mv "$pkgdir/usr/local/include/xsec" "$pkgdir/usr/include"
+ find "$pkgdir/usr/local/lib/" -maxdepth 1 -type f -print0 | xargs -0 mv -t "$pkgdir/usr/lib"
+ find "$pkgdir/usr/local/lib/" -maxdepth 1 -type l -print0 | xargs -0 mv -t "$pkgdir/usr/lib"
+ rm -rf "$pkgdir/usr/local"
+} \ No newline at end of file
diff --git a/cartao-cidadao-svn.install b/cartao-cidadao-svn.install
new file mode 100644
index 000000000000..a79ecc4a5def
--- /dev/null
+++ b/cartao-cidadao-svn.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo -e "\n"
+ echo ">>Do not forget to systemctl start pcscd"
+ echo ">>If reader not start, try to add your username to usb permission group or run as sudo"
+}
+
+post_upgrade() {
+ post_install
+}