summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2023-01-31 11:53:07 +0100
committerAlexander F. Rødseth2023-01-31 11:53:07 +0100
commit1d0984fa27c448b7b17cb63d64e7abdd19c2aa4d (patch)
treedc74dd4702c9d3a8ceda4f8cb2c6aa4766022989
downloadaur-1d0984fa27c448b7b17cb63d64e7abdd19c2aa4d.tar.gz
Initial release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ce26cb88bb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = carveimg
+ pkgdesc = Two image viewing utilities for the terminal, where one uses seam carving
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/xyproto/carveimg
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = go
+ source = git+https://github.com/xyproto/carveimg#commit=248fe686214588e85bb0bcc54e9f96628699cb14
+ b2sums = SKIP
+
+pkgname = carveimg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..546e1c5353b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=carveimg
+pkgver=1.2.1
+pkgrel=1
+pkgdesc='Two image viewing utilities for the terminal, where one uses seam carving'
+arch=(x86_64)
+url='https://github.com/xyproto/carveimg'
+license=(BSD)
+makedepends=(git go)
+source=("git+$url#commit=248fe686214588e85bb0bcc54e9f96628699cb14") # tag: v1.2.1
+b2sums=('SKIP')
+
+build() {
+ (cd $pkgname/cmd/img && go build -v -mod=vendor -buildmode=pie -trimpath -ldflags="-s -w -extldflags \"${LDFLAGS}\"")
+ (cd $pkgname/cmd/carve && go build -v -mod=vendor -buildmode=pie -trimpath -ldflags="-s -w -extldflags \"${LDFLAGS}\"")
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 cmd/img/img "$pkgdir/usr/bin/img"
+ install -Dm755 cmd/carve/carve "$pkgdir/usr/bin/carve"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}