summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleg Shparber2021-01-03 02:20:27 -0500
committerOleg Shparber2021-01-03 02:20:27 -0500
commit2cfe55cbfd0479b46dec47588bfff71daf950fc9 (patch)
tree772a529884de87179011f8b1c498af1eb7aa766a
parent7057e3b30b9d3842d37ce384c0edbee9e16c58fd (diff)
downloadaur-2cfe55cbfd0479b46dec47588bfff71daf950fc9.tar.gz
Fix build with Python 3.9
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
-rw-r--r--python-deps.patch22
3 files changed, 43 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d257ca93ef18..0ad9a82e1a1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = cascadia-code-git
pkgdesc = A new monospaced font that includes programming ligatures
- pkgver = 2008.25.r1.gc6492c66
- pkgrel = 2
+ pkgver = 2009.22.r4.g643858a5
+ pkgrel = 1
url = https://github.com/microsoft/cascadia-code
arch = any
license = custom:OFL
makedepends = git
makedepends = python
- provides = otf-cascadia-code=2008.25.r1.gc6492c66
- provides = ttf-cascadia-code=2008.25.r1.gc6492c66
+ makedepends = ttfautohint
+ provides = otf-cascadia-code=2009.22.r4.g643858a5
+ provides = ttf-cascadia-code=2009.22.r4.g643858a5
conflicts = nerd-fonts-cascadia-code
conflicts = ttf-cascadia-code
source = git+https://github.com/microsoft/cascadia-code.git
+ source = python-deps.patch
sha256sums = SKIP
+ sha256sums = 201882415e4420730df7d787e3578bff8358551acf1b37d0ececdc25b8f24ce3
pkgname = otf-cascadia-code-git
diff --git a/PKGBUILD b/PKGBUILD
index a5b4064c28cd..0c6c05c5aa5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,30 @@
_gitname=cascadia-code
pkgbase=cascadia-code-git
pkgname=("otf-${pkgbase}" "ttf-${pkgbase}")
-pkgver=2008.25.r1.gc6492c66
-pkgrel=2
+pkgver=2009.22.r4.g643858a5
+pkgrel=1
pkgdesc="A new monospaced font that includes programming ligatures"
url="https://github.com/microsoft/${_gitname}"
arch=('any')
license=('custom:OFL')
-makedepends=('git' 'python')
+makedepends=('git' 'python' 'ttfautohint')
provides=("otf-cascadia-code=${pkgver}" "ttf-cascadia-code=${pkgver}")
conflicts=('nerd-fonts-cascadia-code' 'ttf-cascadia-code')
-source=("git+${url}.git")
-sha256sums=('SKIP')
+source=("git+${url}.git"
+ 'python-deps.patch')
+sha256sums=('SKIP'
+ '201882415e4420730df7d787e3578bff8358551acf1b37d0ececdc25b8f24ce3')
pkgver() {
cd "${_gitname}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${_gitname}"
+ patch --forward --strip=1 --input="${srcdir}/python-deps.patch"
+}
+
build() {
cd "${_gitname}"
# Using pip because deps in AUR are broken.
@@ -31,12 +38,12 @@ build() {
package_otf-cascadia-code-git() {
cd "${_gitname}"
- install -Dm644 build/static/*.otf -t "$pkgdir"/usr/share/fonts/OTF
+ install -Dm644 build/otf/static/*.otf -t "$pkgdir"/usr/share/fonts/OTF
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
package_ttf-cascadia-code-git() {
cd "${_gitname}"
- install -Dm644 build/*.ttf -t "$pkgdir"/usr/share/fonts/TTF
+ install -Dm644 build/ttf/*.ttf -t "$pkgdir"/usr/share/fonts/TTF
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/python-deps.patch b/python-deps.patch
new file mode 100644
index 000000000000..4a32bfe77097
--- /dev/null
+++ b/python-deps.patch
@@ -0,0 +1,22 @@
+diff --git a/requirements.txt b/requirements.txt
+index 07691de8..60a8cc54 100755
+--- a/requirements.txt
++++ b/requirements.txt
+@@ -8,7 +8,7 @@ appdirs==1.4.4 # via fs
+ attrs==20.2.0 # via cattrs, fontmake, statmake, ufolib2
+ booleanoperations==0.9.0 # via fontmake, ufo2ft
+ brotli==1.0.9 # via fonttools
+-cattrs==1.0.0 # via statmake
++cattrs==1.1.2 # via statmake
+ cffsubr==0.2.7 # via ufo2ft
+ compreffor==0.5.0 # via ufo2ft
+ cu2qu==1.6.7 # via fontmake, ufo2ft
+@@ -23,7 +23,7 @@ pyclipper==1.2.0 # via booleanoperations
+ pyparsing==2.4.7 # via vttlib
+ pytz==2020.1 # via fs
+ six==1.15.0 # via fs
+-skia-pathops==0.4.1 # via -r requirements.in
++skia-pathops==0.6.0 # via -r requirements.in
+ statmake==0.3.0 # via -r requirements.in
+ ufo2ft[cffsubr]==2.16.0 # via fontmake
+ ufolib2==0.8.0 # via fontmake, glyphslib, vttlib