summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Smith2020-08-10 00:29:37 -0400
committerStephen Smith2020-08-10 00:29:37 -0400
commitb0faae30cbb9019293814a508dc3dc72486eefab (patch)
treebbbcd224868c56b0c5157efba31f2c953e506a17
downloadaur-b0faae30cbb9019293814a508dc3dc72486eefab.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b84c85082d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = castblock
+ pkgdesc = CastBlock skips integrated youtube sponsors on all chromecasts on the network.
+ pkgver = 8.40aafd0
+ pkgrel = 1
+ url = https://github.com/stephen304/castblock
+ arch = any
+ license = GPL3
+ depends = jq
+ depends = bc
+ depends = diffutils
+ depends = coreutils
+ provides = castblock
+ conflicts = castblock
+ source = git+https://github.com/stephen304/castblock.git#branch=master
+ sha512sums = SKIP
+
+pkgname = castblock-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad87ed7ee9f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Stephen Smith <stephen304@gmail.com>
+
+pkgname=castblock-git
+pkgbase=castblock
+pkgver=9.5ac271c
+pkgrel=1
+pkgdesc="CastBlock skips integrated youtube sponsors on all chromecasts on the network."
+arch=('any')
+url="https://github.com/stephen304/castblock"
+license=('GPL3')
+depends=('jq' 'bc' 'diffutils' 'coreutils')
+provides=('castblock')
+conflicts=('castblock')
+source=("git+${url}.git#branch=master")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgbase"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir/$pkgbase"
+
+ install -Dm755 castblock "${pkgdir}/usr/bin/castblock"
+ install -Dm644 contrib/castblock.service "$pkgdir"/usr/lib/systemd/system/castblock.service
+}