summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-09-22 16:24:42 +0200
committerwillemw122023-09-22 16:24:42 +0200
commit1b7b32f0937cf61de57741ebc0ff7a3f9cc6a655 (patch)
tree84931de093733930c0e0cca04445812d462869aa
parentf4c44d571e2a51dbc760921e7f2cce2500958297 (diff)
downloadaur-1b7b32f0937cf61de57741ebc0ff7a3f9cc6a655.tar.gz
Update to standards based install
Add git clean. Add python-pytz.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD36
2 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab4d3a4a37ef..fa598c2bff39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = castero-git
pkgdesc = Podcast client for the command line
- pkgver = 0.8.0.r45.g29f42b1
+ pkgver = 0.9.5.r6.gd229ebe
pkgrel = 1
url = https://github.com/xgi/castero
arch = any
license = MIT
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-beautifulsoup4
depends = python-cjkwrap
depends = python-grequests
depends = python-lxml
depends = python-mpv
depends = python-requests
+ depends = python-pytz
depends = python-vlc
provides = castero
conflicts = castero
@@ -19,4 +23,3 @@ pkgbase = castero-git
sha256sums = SKIP
pkgname = castero-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 590c4d0c1830..a3661beb680b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: willemw <willemw12@gmail.com>
pkgname=castero-git
-pkgver=0.8.0.r45.g29f42b1
+pkgver=0.9.5.r6.gd229ebe
pkgrel=1
-pkgdesc="Podcast client for the command line"
-arch=('any')
-url="https://github.com/xgi/castero"
-license=('MIT')
-depends=('python-beautifulsoup4' 'python-cjkwrap' 'python-grequests' 'python-lxml' 'python-mpv' 'python-requests' 'python-vlc')
-#checkdepends=('python-codacy-coverage' 'python-coverage' 'python-pytest')
-makedepends=('git')
+pkgdesc='Podcast client for the command line'
+arch=(any)
+url=https://github.com/xgi/castero
+license=(MIT)
+depends=(python-beautifulsoup4 python-cjkwrap python-grequests python-lxml python-mpv python-requests python-pytz python-vlc)
+#checkdepends=(python-codacy-coverage python-coverage python-pytest)
+makedepends=(git python-build python-installer python-wheel)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=($pkgname::git+https://github.com/xgi/castero.git)
+source=("$pkgname::git+$url.git")
sha256sums=('SKIP')
pkgver() {
@@ -20,18 +20,16 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-#build() {
-# cd $pkgname
-# python setup.py build
-#}
+prepare() {
+ git -C $pkgname clean -dfx
+}
-#check() {
-# cd $pkgname
-# python -m pytest tests
-#}
+build() {
+ cd $pkgname
+ python -m build --wheel --no-isolation
+}
package() {
cd $pkgname
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
-