summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122018-05-09 18:33:36 +0200
committerwillemw122018-05-09 18:33:36 +0200
commit967d70bacb33f8d98bc161f78e1d0fc3d63b7389 (patch)
tree22d3b78a7b1db09301185a4abefefb7bbbe06c40
parentb9f02c784570195cb639e5a4fe1328e1af7bff98 (diff)
downloadaur-967d70bacb33f8d98bc161f78e1d0fc3d63b7389.tar.gz
First version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e8795881085..98789b13f2da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed May 9 15:49:22 UTC 2018
+# Wed May 9 16:32:48 UTC 2018
pkgbase = castero-git
pkgdesc = Podcast client for the command line
pkgver = 0.2.3.r12.g9d7edb3
@@ -7,6 +7,9 @@ pkgbase = castero-git
url = https://xgi.github.io/castero
arch = any
license = MIT
+ makedepends = git
+ depends = python-requests
+ depends = python-vlc
provides = castero
conflicts = castero
source = castero-git::git+https://github.com/xgi/castero.git
diff --git a/PKGBUILD b/PKGBUILD
index 561ea34eac67..783c86ffd522 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,10 @@ pkgdesc="Podcast client for the command line"
arch=('any')
url="https://xgi.github.io/castero"
license=('MIT')
+depends=('python-requests' 'python-vlc')
+makedepends=('git')
provides=($_pkgname)
conflicts=($_pkgname)
-#backup=('...')
source=($pkgname::git+https://github.com/xgi/castero.git)
sha256sums=('SKIP')
@@ -19,8 +20,13 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+#build() {
+# cd $pkgname
+# python setup.py build
+#}
+
package() {
cd $pkgname
- echo TODO
+ python setup.py install --root="$pkgdir/" --optimize=1
}