summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeposite Pirate2020-05-02 17:11:39 +0200
committerDeposite Pirate2020-05-02 17:11:39 +0200
commit0cf0e86feaa5351491015ab82a3f5c07b1cb5634 (patch)
tree7eb52fe6b3b3b00e3fe99cce8a7e9e369538dd52
parent6e26879b47499c3ac64b9a03697576d495fd0cb3 (diff)
downloadaur-0cf0e86feaa5351491015ab82a3f5c07b1cb5634.tar.gz
* Update build.
modified: .SRCINFO modified: PKGBUILD deleted: castor-0.4.0-install.patch new file: castor-0.7.0-makefile.patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--castor-0.4.0-install.patch19
-rw-r--r--castor-0.7.0-makefile.patch17
4 files changed, 24 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7916ff0958c..cc37c93718f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = castor-git
pkgdesc = A gemini, gopher and finger graphical client
- pkgver = 0.4.0.r1.g7f50a34
+ pkgver = 0.7.0.r6.g188cd6c
pkgrel = 1
url = https://git.sr.ht/~julienxx/castor
arch = i686
@@ -16,9 +16,9 @@ pkgbase = castor-git
depends = cairo
depends = openssl
source = castor::git+https://git.sr.ht/~julienxx/castor
- source = castor-0.4.0-install.patch
+ source = castor-0.7.0-makefile.patch
sha256sums = SKIP
- sha256sums = a659bb60626aa505b6f61f2a4669304a9806717858c79facc69b101879e4d0e2
+ sha256sums = 5ac7e5460d00176db71ec0d7972af1adee58c57dd9d7dff29ddecbadb07f4ee9
pkgname = castor-git
diff --git a/PKGBUILD b/PKGBUILD
index 91638f4c36f5..dfdd19d1c38a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=castor
pkgname=castor-git
-pkgver=0.4.0.r1.g7f50a34
+pkgver=0.7.0.r6.g188cd6c
pkgrel=1
pkgdesc="A gemini, gopher and finger graphical client"
arch=('i686' 'x86_64')
@@ -13,9 +13,9 @@ license=('unknown')
depends=('gtk3' 'gdk-pixbuf2' 'pango' 'atk' 'cairo' 'openssl')
makedepends=('git' 'rust' 'cargo')
source=("${_pkgname}::git+${url}"
- 'castor-0.4.0-install.patch')
+ castor-0.7.0-makefile.patch)
sha256sums=('SKIP'
- 'a659bb60626aa505b6f61f2a4669304a9806717858c79facc69b101879e4d0e2')
+ '5ac7e5460d00176db71ec0d7972af1adee58c57dd9d7dff29ddecbadb07f4ee9')
pkgver() {
cd "${_pkgname}"
@@ -29,7 +29,7 @@ prepare() {
cd "${_pkgname}"
# Fix installing to pkgdir
- patch -p1 -i ../castor-0.4.0-install.patch
+ patch -p1 -i ../castor-0.7.0-makefile.patch
}
build() {
diff --git a/castor-0.4.0-install.patch b/castor-0.4.0-install.patch
deleted file mode 100644
index 678194fdd9b8..000000000000
--- a/castor-0.4.0-install.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -r -u -N castor/Makefile castor-install/Makefile
---- castor/Makefile 2020-01-24 15:28:53.812889790 +0100
-+++ castor-install/Makefile 2020-01-24 16:11:36.809011148 +0100
-@@ -36,12 +36,10 @@
- $(INSTALL_DATA) data/org.typed-hole.castor-32.png $(sharedir)/icons/hicolor/32x32/apps/org.typed-hole.castor.png
- $(INSTALL_DATA) data/org.typed-hole.castor-64.png $(sharedir)/icons/hicolor/64x64/apps/org.typed-hole.castor.png
- $(INSTALL_DATA) data/org.typed-hole.castor-128.png $(sharedir)/icons/hicolor/128x128/apps/org.typed-hole.castor.png
-- # Force icon cache refresh
-- touch $(sharedir)/icons/hicolor
-- cp target/release/castor /usr/bin/castor
-- # Install desktop file
-+ # Create the applications dir if needed
-+ mkdir -p $(sharedir)/applications
-+ # Install desktop file
- $(INSTALL_DATA) data/Castor.desktop $(sharedir)/applications/Castor.desktop
-- update-desktop-database
-
- uninstall :
- # Remove the .desktop
diff --git a/castor-0.7.0-makefile.patch b/castor-0.7.0-makefile.patch
new file mode 100644
index 000000000000..ec585dd19403
--- /dev/null
+++ b/castor-0.7.0-makefile.patch
@@ -0,0 +1,17 @@
+Common subdirectories: castor/data and castor-makefile/data
+Common subdirectories: castor/.git and castor-makefile/.git
+diff -u castor/Makefile castor-makefile/Makefile
+--- castor/Makefile 2020-04-24 23:57:59.119673418 +0200
++++ castor-makefile/Makefile 2020-04-24 23:58:41.033151139 +0200
+@@ -29,8 +29,8 @@
+ # Install the data files and update the caches
+ install-data : copy-data
+ # Force icon cache refresh
+- touch $(sharedir)/icons/hicolor
+- update-desktop-database
++ #touch $(sharedir)/icons/hicolor
++ #update-desktop-database
+
+ # Just copy the data files, without updating caches
+ copy-data :
+Common subdirectories: castor/src and castor-makefile/src