summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeposite Pirate2020-01-24 16:22:30 +0100
committerDeposite Pirate2020-01-24 16:22:30 +0100
commit6e26879b47499c3ac64b9a03697576d495fd0cb3 (patch)
treea9327f3fee3554f0d3bd9261fee6dd2de30bedb1
downloadaur-6e26879b47499c3ac64b9a03697576d495fd0cb3.tar.gz
* Castor, a graphical gemini/gopher/finger client.
new file: .SRCINFO new file: PKGBUILD new file: castor-0.4.0-install.patch
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD43
-rw-r--r--castor-0.4.0-install.patch19
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7916ff0958c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = castor-git
+ pkgdesc = A gemini, gopher and finger graphical client
+ pkgver = 0.4.0.r1.g7f50a34
+ pkgrel = 1
+ url = https://git.sr.ht/~julienxx/castor
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ makedepends = rust
+ makedepends = cargo
+ depends = gtk3
+ depends = gdk-pixbuf2
+ depends = pango
+ depends = atk
+ depends = cairo
+ depends = openssl
+ source = castor::git+https://git.sr.ht/~julienxx/castor
+ source = castor-0.4.0-install.patch
+ sha256sums = SKIP
+ sha256sums = a659bb60626aa505b6f61f2a4669304a9806717858c79facc69b101879e4d0e2
+
+pkgname = castor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91638f4c36f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Deposite Pirate <dpirate at metalpunks dot info>
+#
+# Upstream: https://git.metalpunks.info/arch-ports
+
+_pkgname=castor
+pkgname=castor-git
+pkgver=0.4.0.r1.g7f50a34
+pkgrel=1
+pkgdesc="A gemini, gopher and finger graphical client"
+arch=('i686' 'x86_64')
+url="https://git.sr.ht/~julienxx/castor"
+license=('unknown')
+depends=('gtk3' 'gdk-pixbuf2' 'pango' 'atk' 'cairo' 'openssl')
+makedepends=('git' 'rust' 'cargo')
+source=("${_pkgname}::git+${url}"
+ 'castor-0.4.0-install.patch')
+sha256sums=('SKIP'
+ 'a659bb60626aa505b6f61f2a4669304a9806717858c79facc69b101879e4d0e2')
+
+pkgver() {
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "${_pkgname}"
+
+ # Fix installing to pkgdir
+ patch -p1 -i ../castor-0.4.0-install.patch
+}
+
+build() {
+ cd "${_pkgname}"
+ cargo build --release
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/castor-0.4.0-install.patch b/castor-0.4.0-install.patch
new file mode 100644
index 000000000000..678194fdd9b8
--- /dev/null
+++ b/castor-0.4.0-install.patch
@@ -0,0 +1,19 @@
+diff -r -u -N castor/Makefile castor-install/Makefile
+--- castor/Makefile 2020-01-24 15:28:53.812889790 +0100
++++ castor-install/Makefile 2020-01-24 16:11:36.809011148 +0100
+@@ -36,12 +36,10 @@
+ $(INSTALL_DATA) data/org.typed-hole.castor-32.png $(sharedir)/icons/hicolor/32x32/apps/org.typed-hole.castor.png
+ $(INSTALL_DATA) data/org.typed-hole.castor-64.png $(sharedir)/icons/hicolor/64x64/apps/org.typed-hole.castor.png
+ $(INSTALL_DATA) data/org.typed-hole.castor-128.png $(sharedir)/icons/hicolor/128x128/apps/org.typed-hole.castor.png
+- # Force icon cache refresh
+- touch $(sharedir)/icons/hicolor
+- cp target/release/castor /usr/bin/castor
+- # Install desktop file
++ # Create the applications dir if needed
++ mkdir -p $(sharedir)/applications
++ # Install desktop file
+ $(INSTALL_DATA) data/Castor.desktop $(sharedir)/applications/Castor.desktop
+- update-desktop-database
+
+ uninstall :
+ # Remove the .desktop