summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-11-20 16:22:06 -0500
committerKyle Keen2015-11-20 16:22:49 -0500
commit00ef719efd4488ca2810309452d91a3fd03f2303 (patch)
tree2115f3850083b81a2be24484100da10ebe778f54
parentc174c63fa540192bd11264e292d45a2c54ac56f1 (diff)
downloadaur-00ef719efd4488ca2810309452d91a3fd03f2303.tar.gz
overhaul to match official package
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD100
-rw-r--r--cataclysm-dda.install6
3 files changed, 80 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2f41ffd69f2..9abc4716372a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,27 @@
pkgbase = cataclysm-dda-git
- pkgdesc = Cataclysm: Dark Days Ahead is an actively maintained roguelike set in a post-apocalyptic world. Both SDL tiles and ascii version included.
- pkgver = 0.C.r7422.ge98a0e1
- pkgrel = 2
+ pkgdesc = A post-apocalyptic roguelike.
+ pkgver = 0.C.2015.11.20
+ pkgrel = 1
url = http://en.cataclysmdda.com/
+ install = cataclysm-dda.install
arch = i686
arch = x86_64
license = CCPL:by-sa
+ makedepends = sdl2_image
+ makedepends = sdl2_ttf
+ makedepends = sdl2_mixer
+ makedepends = freetype2
makedepends = git
- makedepends = gettext
depends = ncurses
- depends = sdl2
- depends = sdl2_image
- depends = sdl2_ttf
- depends = sdl2_mixer
- depends = freetype2
- depends = zlib
- optdepends = lua51
+ depends = lua51
+ optdepends = sdl2_image: for tiles
+ optdepends = sdl2_ttf: for tiles
+ optdepends = freetype2: for tiles
+ optdepends = sdl2_mixer: for tiles
conflicts = cataclysm-dda,
conflicts = cataclysm-dda-ncurses
- source = cataclysm-dda-git::git://github.com/CleverRaven/Cataclysm-DDA.git#branch=master
+ conflicts = cataclysm-dda-sdl-git
+ source = https://github.com/CleverRaven/Cataclysm-DDA/archive/master.zip
md5sums = SKIP
pkgname = cataclysm-dda-git
diff --git a/PKGBUILD b/PKGBUILD
index 898ecfec2faa..f5982ff23e25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,64 +1,82 @@
-# Maintainer : Frederic Bezies <fredbezies at gmail dot com>
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+# Contributor: Frederic Bezies <fredbezies at gmail dot com>
# Contributor: Fernando Carmona Varo <ferkiwi @t gmail dot com>
# Contributor: Klemen Košir <klemen913@gmail.com>
pkgname=cataclysm-dda-git
-pkgver=0.C.r7422.ge98a0e1
-pkgrel=2
-pkgdesc="Cataclysm: Dark Days Ahead is an actively maintained roguelike set in a post-apocalyptic world. Both SDL tiles and ascii version included."
-arch=('i686' 'x86_64')
+pkgver=0.C.2015.11.20
+_pkgver=0.C
+pkgrel=1
+pkgdesc="A post-apocalyptic roguelike."
+#url="http://cataclysmrl.blogspot.com/"
+#url="http://www.cataclysm.glyphgryph.com/"
url="http://en.cataclysmdda.com/"
-license=('CCPL:by-sa')
-conflicts=('cataclysm-dda', 'cataclysm-dda-ncurses')
-depends=('ncurses' 'sdl2' 'sdl2_image' 'sdl2_ttf' 'sdl2_mixer' 'freetype2' 'zlib')
-makedepends=('git' 'gettext')
-optdepends=('lua51')
-install=
-source=("$pkgname"::'git://github.com/CleverRaven/Cataclysm-DDA.git#branch=master')
+arch=('i686' 'x86_64')
+license=("CCPL:by-sa")
+depends=('ncurses' 'lua51')
+makedepends=('sdl2_image' 'sdl2_ttf' 'sdl2_mixer' 'freetype2' 'git')
+optdepends=('sdl2_image: for tiles'
+ 'sdl2_ttf: for tiles'
+ 'freetype2: for tiles'
+ 'sdl2_mixer: for tiles')
+install=cataclysm-dda.install
+conflicts=('cataclysm-dda', 'cataclysm-dda-ncurses' 'cataclysm-dda-sdl-git')
+#source=("$pkgname"::'git://github.com/CleverRaven/Cataclysm-DDA.git#branch=master')
+# The git repo is more than a GB
+# so download a snapshot while waiting for shallow clone support in makepkg
+source=('https://github.com/CleverRaven/Cataclysm-DDA/archive/master.zip')
md5sums=('SKIP')
+# for some reason this one autodetects lua51?
+
pkgver() {
- cd "${srcdir}/${pkgname}"
- git describe --tags --long | sed 's/-/.r/; s/-/./'
+ cd "Cataclysm-DDA-master"
+ #git describe --tags --long | sed 's/-/.r/; s/-/./'
+ # no git metadata in the snapshot, so fake it
+ echo "${_pkgver}.$(date +%Y.%m.%d)"
}
prepare() {
- cd "${srcdir}/${pkgname}"
-
- sed -i 's/-Werror//' Makefile
-
+ cd "Cataclysm-DDA-master"
+ sed -i 's/ncursesw5-config/ncursesw6-config/' Makefile
+ #sed -i 's|"\(l.*h\)"|"lua5.1/\1"|' src/catalua.{h,cpp}
}
-build() {
- #LUA=1 is deactivated for now. Got bug while trying to build.
- cd "${srcdir}/${pkgname}"
-
- msg 'Building ncurses version...'
- make PREFIX=/usr RELEASE=1 USE_XDG_DIR=1
+build() {
+ cd "Cataclysm-DDA-master"
+ make PREFIX=/usr RELEASE=1 ZLEVELS=1 USE_HOME_DIR=1 LUA=1
+ make PREFIX=/usr RELEASE=1 ZLEVELS=1 USE_HOME_DIR=1 LUA=1 TILES=1 SOUND=1
+ #LUA_BINARY="/usr/bin/lua5.1"
+ # USE_XDG_DIR=1 ?
- msg 'Building SDL version...'
- make PREFIX=/usr RELEASE=1 USE_XDG_DIR=1 TILES=1 SOUND=1
+ # 'make install' needs this
+ touch README.txt
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "Cataclysm-DDA-master"
- PREFIX="$pkgdir/usr" make install TILES=1 SOUND=1
+ # no DESTDIR
+ make PREFIX="$pkgdir/usr" \
+ RELEASE=1 ZLEVELS=1 USE_HOME_DIR=1 LUA=1 TILES=0 SOUND=0 \
+ install
+ # doesn't install executable?
+ install -Dm755 cataclysm "$pkgdir/usr/bin/cataclysm"
- # Desktop file
- #install -dm755 "$pkgdir/usr/share/applications"
- #cp "$srcdir/cataclysm-dda.desktop" "$pkgdir/usr/share/applications"
+ make PREFIX="$pkgdir/usr" \
+ RELEASE=1 ZLEVELS=1 USE_HOME_DIR=1 LUA=1 TILES=1 SOUND=1 \
+ install
- # Icon
- install -D 'data/osx/AppIcon.iconset/icon_128x128.png' "$pkgdir/usr/share/icons/hicolor/128x128/apps/cataclysm-dda.png"
+ # Icon
+ install -D 'data/osx/AppIcon.iconset/icon_128x128.png' "$pkgdir/usr/share/icons/hicolor/128x128/apps/cataclysm-dda.png"
- # Docs
- install -d "$pkgdir/usr/share/doc/cataclysm-dda"
- cp -r doc/* "$pkgdir/usr/share/doc/cataclysm-dda"
- rm "$pkgdir/usr/share/doc/cataclysm-dda/JSON_LOADING_ORDER.md"
- cp 'data/json/LOADING_ORDER.md' "$pkgdir/usr/share/doc/cataclysm-dda/JSON_LOADING_ORDER.md"
+ # Docs
+ install -d "$pkgdir/usr/share/doc/cataclysm-dda"
+ cp -r doc/* "$pkgdir/usr/share/doc/cataclysm-dda"
+ # undo symlink
+ rm "$pkgdir/usr/share/doc/cataclysm-dda/JSON_LOADING_ORDER.md"
+ cp 'data/json/LOADING_ORDER.md' "$pkgdir/usr/share/doc/cataclysm-dda/ JSON_LOADING_ORDER.md"
- # License file
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+ # License
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
diff --git a/cataclysm-dda.install b/cataclysm-dda.install
new file mode 100644
index 000000000000..61f0651b637e
--- /dev/null
+++ b/cataclysm-dda.install
@@ -0,0 +1,6 @@
+
+post_upgrade() {
+ echo "Save formats are almost always incompatible"
+ echo "Please delete all files in ~/.cataclysm-dda/save/"
+}
+