summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgileri2023-03-19 19:07:50 +0100
committergileri2023-03-19 20:38:26 +0100
commit1ac2431a7d3d53270146c3c95889c976915a9e31 (patch)
treeac67d46ded0c1fb021045eef71ce5ed4b6153863
parenta833b438ba376440920aedf3f36a3bd50ddceb4d (diff)
downloadaur-1ac2431a7d3d53270146c3c95889c976915a9e31.tar.gz
Bump to 0.G and C++17
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0397683e6d0..d86a748415b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cataclysm-dda-git
pkgdesc = A post-apocalyptic roguelike.
- pkgver = 0.F.2022.05.24
+ pkgver = 0.G.2023.03.19
pkgrel = 1
url = https://cataclysmdda.org/
arch = i686
@@ -12,6 +12,7 @@ pkgbase = cataclysm-dda-git
makedepends = freetype2
makedepends = git
depends = ncurses
+ depends = gettext
optdepends = sdl2_image: for tiles
optdepends = sdl2_ttf: for tiles
optdepends = freetype2: for tiles
@@ -19,9 +20,7 @@ pkgbase = cataclysm-dda-git
conflicts = cataclysm-dda
conflicts = cataclysm-dda-ncurses
conflicts = cataclysm-dda-tiles
- source = cataclysm-dda-git::git+https://github.com/CleverRaven/Cataclysm-DDA.git#branch=master
- source = disable_bound_check.patch
+ source = https://github.com/CleverRaven/Cataclysm-DDA/archive/master.zip
sha512sums = SKIP
- sha512sums = 8f4324dc935d3db98a7d5a12b46f2c58c37b6b4b4f2cbcdacc0462b1efa89f191d9fd7a0c8280c21d0abc0d448f66dad015cde7686f498ed4d5ae3d20a0521b1
pkgname = cataclysm-dda-git
diff --git a/PKGBUILD b/PKGBUILD
index 00a9bf11fff9..9e51923cadb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Klemen Košir <klemen913@gmail.com>
pkgname=cataclysm-dda-git
-pkgver=0.F.2022.05.24
-_pkgver=0.F
+pkgver=0.G.2023.03.19
+_pkgver=0.G
pkgrel=1
pkgdesc="A post-apocalyptic roguelike."
#url="http://cataclysmrl.blogspot.com/"
@@ -15,7 +15,7 @@ url="https://cataclysmdda.org/"
arch=('i686' 'x86_64')
license=("CCPL:by-sa")
conflicts=('cataclysm-dda' 'cataclysm-dda-ncurses' 'cataclysm-dda-tiles')
-depends=('ncurses')
+depends=('ncurses' 'gettext')
makedepends=('sdl2_image' 'sdl2_ttf' 'sdl2_mixer' 'freetype2' 'git')
optdepends=('sdl2_image: for tiles'
'sdl2_ttf: for tiles'
@@ -27,10 +27,8 @@ optdepends=('sdl2_image: for tiles'
# (you may uncomment the alternate source/pkgver() if you would prefer to use that)
source=(
'https://github.com/CleverRaven/Cataclysm-DDA/archive/master.zip'
- "disable_bound_check.patch"
)
-sha512sums=('SKIP'
- '8f4324dc935d3db98a7d5a12b46f2c58c37b6b4b4f2cbcdacc0462b1efa89f191d9fd7a0c8280c21d0abc0d448f66dad015cde7686f498ed4d5ae3d20a0521b1')
+sha512sums=('SKIP')
pkgver() {
cd "Cataclysm-DDA-master"
@@ -42,13 +40,12 @@ pkgver() {
prepare() {
cd "Cataclysm-DDA-master"
sed -i 's/ncursesw5-config/ncursesw6-config/' Makefile
- patch --strip 1 < "${srcdir}/disable_bound_check.patch"
}
build() {
cd "Cataclysm-DDA-master"
- make PREFIX=/usr RELEASE=1 USE_XDG_DIR=1 LANGUAGE="all" RUNTESTS=0 LINTJSON=0 ASTYLE=0 PCH=0
- make PREFIX=/usr RELEASE=1 USE_XDG_DIR=1 LANGUAGE="all" RUNTESTS=0 LINTJSON=0 ASTYLE=0 PCH=0 TILES=1 SOUND=1
+ make PREFIX=/usr RELEASE=1 USE_XDG_DIR=1 LANGUAGE="all" LTO=1 RUNTESTS=0 LINTJSON=0 ASTYLE=0 PCH=0
+ make PREFIX=/usr RELEASE=1 USE_XDG_DIR=1 LANGUAGE="all" LTO=1 RUNTESTS=0 LINTJSON=0 ASTYLE=0 PCH=0 TILES=1 SOUND=1
# LOCALIZE = 0 to save 30MB
# DYNAMIC_LINKING = 1 ?