summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgileri2022-05-24 23:52:05 +0200
committergileri2022-05-25 00:02:13 +0200
commita833b438ba376440920aedf3f36a3bd50ddceb4d (patch)
tree9c1037f4dceb401be3f8d06fab856d721e7a0a62
parent7110756ed3f0fc3ae80e51c4f153321b5afea1b6 (diff)
downloadaur-a833b438ba376440920aedf3f36a3bd50ddceb4d.tar.gz
Patch Makefile to ignore array-bounds checks
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--disable_bound_check.patch14
3 files changed, 27 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbdb0ac072ce..e0397683e6d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cataclysm-dda-git
pkgdesc = A post-apocalyptic roguelike.
- pkgver = 0.F.2022.02.22
+ pkgver = 0.F.2022.05.24
pkgrel = 1
url = https://cataclysmdda.org/
arch = i686
@@ -19,7 +19,9 @@ pkgbase = cataclysm-dda-git
conflicts = cataclysm-dda
conflicts = cataclysm-dda-ncurses
conflicts = cataclysm-dda-tiles
- source = https://github.com/CleverRaven/Cataclysm-DDA/archive/master.zip
- md5sums = SKIP
+ source = cataclysm-dda-git::git+https://github.com/CleverRaven/Cataclysm-DDA.git#branch=master
+ source = disable_bound_check.patch
+ sha512sums = SKIP
+ sha512sums = 8f4324dc935d3db98a7d5a12b46f2c58c37b6b4b4f2cbcdacc0462b1efa89f191d9fd7a0c8280c21d0abc0d448f66dad015cde7686f498ed4d5ae3d20a0521b1
pkgname = cataclysm-dda-git
diff --git a/PKGBUILD b/PKGBUILD
index 61987d9c756c..00a9bf11fff9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Klemen Košir <klemen913@gmail.com>
pkgname=cataclysm-dda-git
-pkgver=0.F.2022.02.22
+pkgver=0.F.2022.05.24
_pkgver=0.F
pkgrel=1
pkgdesc="A post-apocalyptic roguelike."
@@ -25,8 +25,12 @@ optdepends=('sdl2_image: for tiles'
# The git repo is more than a GB
# so download a snapshot while waiting for shallow clone support in makepkg
# (you may uncomment the alternate source/pkgver() if you would prefer to use that)
-source=('https://github.com/CleverRaven/Cataclysm-DDA/archive/master.zip')
-md5sums=('SKIP')
+source=(
+ 'https://github.com/CleverRaven/Cataclysm-DDA/archive/master.zip'
+ "disable_bound_check.patch"
+)
+sha512sums=('SKIP'
+ '8f4324dc935d3db98a7d5a12b46f2c58c37b6b4b4f2cbcdacc0462b1efa89f191d9fd7a0c8280c21d0abc0d448f66dad015cde7686f498ed4d5ae3d20a0521b1')
pkgver() {
cd "Cataclysm-DDA-master"
@@ -38,6 +42,7 @@ pkgver() {
prepare() {
cd "Cataclysm-DDA-master"
sed -i 's/ncursesw5-config/ncursesw6-config/' Makefile
+ patch --strip 1 < "${srcdir}/disable_bound_check.patch"
}
build() {
diff --git a/disable_bound_check.patch b/disable_bound_check.patch
new file mode 100644
index 000000000000..02a26d69b510
--- /dev/null
+++ b/disable_bound_check.patch
@@ -0,0 +1,14 @@
+diff --git a/Makefile b/Makefile
+index 56418b4be7a6..39a333e7af9a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -109,7 +109,8 @@ WARNINGS = \
+ -Wsuggest-override \
+ -Wunused-macros \
+ -Wzero-as-null-pointer-constant \
+- -Wno-unknown-warning-option
++ -Wno-unknown-warning-option \
++ -Wno-array-bounds
+ # Uncomment below to disable warnings
+ #WARNINGS = -w
+ DEBUGSYMS = -g