summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2018-06-06 11:40:03 +0200
committerFrederic Bezies2018-06-06 11:40:03 +0200
commit3006228d6dfb44073b10856900b3994d2433c17e (patch)
tree9d8a34195bb7dcfcd9f16d09753c788edd41d7bb
parentcb857eca7e2b76dd871392b7c27cc97782de46cd (diff)
downloadaur-3006228d6dfb44073b10856900b3994d2433c17e.tar.gz
adopted and fixed PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--fix_locale_and_build_error.patch12
3 files changed, 8 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 419ae0c860f2..50462cf5e78d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cataclysm-dda-tiles
pkgdesc = A post-apocalyptic roguelike,tiles only
- pkgver = 0.C.2018.04.12
+ pkgver = 0.C.2018.06.06
pkgrel = 1
url = http://en.cataclysmdda.com/
arch = x86_64
@@ -17,13 +17,11 @@ pkgbase = cataclysm-dda-tiles
optdepends = sdl2_ttf: for tiles
optdepends = freetype2: for tiles
optdepends = sdl2_mixer: for tiles
- conflicts = cataclysm-dda,
+ conflicts = cataclysm-dda
conflicts = cataclysm-dda-ncurses
conflicts = cataclysm-dda-sdl-git
source = https://github.com/CleverRaven/Cataclysm-DDA/archive/master.zip
- source = fix_locale_and_build_error.patch
md5sums = SKIP
- md5sums = 17c1adda49636148ae952f0e03ebcc22
pkgname = cataclysm-dda-tiles
diff --git a/PKGBUILD b/PKGBUILD
index 10d666fa3756..4415a6407915 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Yangtse Su <yangtsesu@gmail.com>
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
# Contributor: Kyle Keen <keenerd@gmail.com>
-# Contributor: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Yangtse Su <yangtsesu@gmail.com>
# Contributor: Fernando Carmona Varo <ferkiwi @t gmail dot com>
# Contributor: Klemen Košir <klemen913@gmail.com>
pkgname=cataclysm-dda-tiles
-pkgver=0.C.2018.04.12
+pkgver=0.C.2018.06.06
_pkgver=0.C
pkgrel=1
pkgdesc="A post-apocalyptic roguelike,tiles only"
@@ -19,11 +19,9 @@ optdepends=('sdl2_image: for tiles'
'sdl2_ttf: for tiles'
'freetype2: for tiles'
'sdl2_mixer: for tiles')
-conflicts=('cataclysm-dda', 'cataclysm-dda-ncurses' 'cataclysm-dda-sdl-git')
-source=('https://github.com/CleverRaven/Cataclysm-DDA/archive/master.zip'
- 'fix_locale_and_build_error.patch')
-md5sums=('SKIP'
- '17c1adda49636148ae952f0e03ebcc22')
+conflicts=('cataclysm-dda' 'cataclysm-dda-ncurses' 'cataclysm-dda-sdl-git')
+source=('https://github.com/CleverRaven/Cataclysm-DDA/archive/master.zip')
+md5sums=('SKIP')
pkgver() {
cd "Cataclysm-DDA-master"
@@ -33,7 +31,6 @@ pkgver() {
build() {
cd "Cataclysm-DDA-master"
- patch -Np1 -i ../fix_locale_and_build_error.patch
make PREFIX=/usr RELEASE=1 LOCALIZE=1 USE_XDG_DIR=1 LUA=1 TILES=1 SOUND=1 LANGUAGES=all
}
diff --git a/fix_locale_and_build_error.patch b/fix_locale_and_build_error.patch
deleted file mode 100644
index 5c63cd9bcb72..000000000000
--- a/fix_locale_and_build_error.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur Cataclysm-DDA-master.orig/Makefile Cataclysm-DDA-master/Makefile
---- Cataclysm-DDA-master.orig/Makefile 2017-07-13 13:39:52.000000000 +0800
-+++ Cataclysm-DDA-master/Makefile 2017-07-14 15:23:47.780860342 +0800
-@@ -389,7 +389,7 @@
- CXXFLAGS += -DMAPSIZE=$(MAPSIZE)
- endif
-
--ifeq ($(shell git rev-parse --is-inside-work-tree),true)
-+ifeq ([ -e ".git" ],true)
- # We have a git repository, use git version
- DEFINES += -DGIT_VERSION
- endif