summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-08-16 07:24:01 +0200
committerCarsten Teibes2014-08-16 07:24:01 +0200
commit24c2903d209e04ea3dcbf4aef411f1e09b13eb09 (patch)
tree161975f0144463765b21fd49bb776b16c342c7a4
downloadaur-24c2903d209e04ea3dcbf4aef411f1e09b13eb09.tar.gz
[add] catacombsdl 1.03
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
-rw-r--r--catacombsdl.desktop8
-rw-r--r--catacombsdl.install9
-rw-r--r--catacombsdl.pngbin0 -> 382 bytes
-rw-r--r--catacombsdl.sh17
6 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a04591864884
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = catacombsdl
+ pkgdesc = SDL2 source port for Catacomb II / The Catacomb
+ pkgver = 1.03
+ pkgrel = 1
+ url = https://github.com/Blzut3/CatacombSDL
+ install = catacombsdl.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = sdl2
+ source = catacombsdl-1.03.tar.gz::https://github.com/Blzut3/CatacombSDL/archive/1.03.tar.gz
+ source = catacombsdl.sh
+ source = catacombsdl.desktop
+ source = catacombsdl.png
+ sha256sums = 8c77d2a82448e163c80971015ace425dabbe1831a647d6034d270dd6892343d8
+ sha256sums = c042d617739a3c63bf0696bda95d48cc34598592db091b832130f552726950dd
+ sha256sums = e0bda5ad8ed14469d5329283240c189f72a4beeed7e34fd82cb54604305f5664
+ sha256sums = b2b305edc0fa7c4e9f884987040ca20e4f2124719ffdb27ad322bc9257def67b
+
+pkgname = catacombsdl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d526e018580
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=catacombsdl
+pkgver=1.03
+pkgrel=1
+pkgdesc="SDL2 source port for Catacomb II / The Catacomb"
+arch=('i686' 'x86_64')
+url="https://github.com/Blzut3/CatacombSDL"
+license=('GPL2')
+depends=('sdl2')
+install=$pkgname.install
+source=($pkgname-$pkgver.tar.gz::"https://github.com/Blzut3/CatacombSDL/archive/$pkgver.tar.gz"
+ "$pkgname.sh"
+ "$pkgname.desktop"
+ "$pkgname.png")
+sha256sums=('8c77d2a82448e163c80971015ace425dabbe1831a647d6034d270dd6892343d8'
+ 'c042d617739a3c63bf0696bda95d48cc34598592db091b832130f552726950dd'
+ 'e0bda5ad8ed14469d5329283240c189f72a4beeed7e34fd82cb54604305f5664'
+ 'b2b305edc0fa7c4e9f884987040ca20e4f2124719ffdb27ad322bc9257def67b')
+
+build() {
+ cd CatacombSDL-$pkgver
+
+ cmake ./
+ make
+}
+
+package() {
+ cd CatacombSDL-$pkgver
+
+ # install executable
+ install -Dm755 catacomb "$pkgdir"/usr/share/$pkgname/catacomb
+
+ # install launcher, icon and desktop files
+ install -Dm755 ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 ../$pkgname.png "$pkgdir"/usr/share/pixmaps/$pkgname.png
+ install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+}
diff --git a/catacombsdl.desktop b/catacombsdl.desktop
new file mode 100644
index 000000000000..d86b26c1c303
--- /dev/null
+++ b/catacombsdl.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=CatacombSDL
+Exec=catacombsdl windowed 800 600
+Icon=catacombsdl
+Type=Application
+Comment=SDL Port of 'The Catacomb' aka 'Catacomb II'
+Categories=Game;
+Terminal=false
diff --git a/catacombsdl.install b/catacombsdl.install
new file mode 100644
index 000000000000..d87756e6abcd
--- /dev/null
+++ b/catacombsdl.install
@@ -0,0 +1,9 @@
+
+post_install() {
+ echo "Remember you need the data files to play. Put all .CA2 files under '~/.catacombsdl',"
+ echo "all filenames are expected to be uppercase currently."
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/catacombsdl.png b/catacombsdl.png
new file mode 100644
index 000000000000..daa21536b2ef
--- /dev/null
+++ b/catacombsdl.png
Binary files differ
diff --git a/catacombsdl.sh b/catacombsdl.sh
new file mode 100644
index 000000000000..33dc11aa8d23
--- /dev/null
+++ b/catacombsdl.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# CatacombSDL launcher // carstene1ns 2014
+#
+# Does some juggling with the path to help finding the data files
+
+[ ! -d $HOME/.catacombsdl ] && mkdir -p $HOME/.catacombsdl
+
+if [ -f $HOME/.catacombsdl/LEVEL1.CA2 ]; then
+
+ cd $HOME/.catacombsdl && exec /usr/share/catacombsdl/catacomb "$@"
+
+else
+
+ echo "Please place 'The Catacomb' / 'Catacomb II' data files in \"~/.catacombsdl\"."
+
+fi