summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVi0L02018-04-08 21:49:54 +0200
committerVi0L02018-04-08 21:49:54 +0200
commita966220f9d39a5ff18710d21464fb3903f1ee468 (patch)
treed7d18bb8cf0e7483d8984f0456c6c8676d3bace8
parentd5e472f377090f3b108bb42384eaa85b33f9aac2 (diff)
downloadaur-a966220f9d39a5ff18710d21464fb3903f1ee468.tar.gz
15.9-19: 4.15 kernel support
-rw-r--r--.SRCINFO8
-rw-r--r--4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch14
-rw-r--r--PKGBUILD13
3 files changed, 27 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e23572b72d3..44dfbe66b006 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jan 21 20:19:26 UTC 2018
+# Sun Apr 8 19:49:07 UTC 2018
pkgbase = catalyst
pkgdesc = AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
pkgver = 15.9
- pkgrel = 18
+ pkgrel = 19
url = http://www.amd.com
install = catalyst.install
arch = i686
@@ -14,7 +14,7 @@ pkgbase = catalyst
makedepends = make
makedepends = linux-headers
depends = linux>=3.0
- depends = linux<4.15
+ depends = linux<4.16
depends = catalyst-utils
conflicts = catalyst-test
source = http://www2.ati.com/drivers/linux/amd-catalyst-15.9-linux-installer-15.201.1151-x86.x86_64.zip
@@ -39,6 +39,7 @@ pkgbase = catalyst
source = 4.12-npfeiler-movsl_mask.patch
source = 4.13-npfeiler-wait_queue_t.patch
source = 4.14-npfeiler-task_struct-mm_segment_t.patch
+ source = 4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
md5sums = d2de2df6946b452c266a3c892e6e46ff
md5sums = fd98b7e486d7fd4cad8de7b95b5b031e
md5sums = 3e1b82bd69774ea808da69c983d6a43b
@@ -61,6 +62,7 @@ pkgbase = catalyst
md5sums = cb25bc7fbb7d5cb1c07d2f3fa5fda826
md5sums = 0a725f40bc980d578cbed3e57a05b765
md5sums = 5ba3bf9f58aa63c1849b056cf23022c9
+ md5sums = 10af58c21e4e972115dda6dbd8279594
pkgname = catalyst
diff --git a/4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch b/4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
new file mode 100644
index 000000000000..1f9b7a4a777b
--- /dev/null
+++ b/4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
@@ -0,0 +1,14 @@
+--- archive_files/common/lib/modules/fglrx/build_mod/firegl_public.c 2015-12-18 19:47:41.000000000 +0100
++++ archive_filesb/common/lib/modules/fglrx/build_mod/firegl_public.c 2018-02-25 17:33:11.469309861 +0100
+@@ -2949,7 +2949,11 @@
+ static void kcl_flush_tlb_one(void *va)
+ {
+ unsigned long *addr = (unsigned long *)va;
++# if (LINUX_VERSION_CODE < KERNEL_VERSION(4,14,21))
+ __flush_tlb_one(*addr);
++# else
++ __flush_tlb_one_kernel(*addr);
++# endif
+ }
+
+ /** /brief Flush one page on all cpus
diff --git a/PKGBUILD b/PKGBUILD
index 431441a30c7e..f2ffdc0d39d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,20 +11,20 @@
# Contributor: gentoo (part of 4.3 kernel patches)
# Contributor: Philip Muller @ Manjaro (4.4 kernel patch)
# Contributor: sling00 (4.10 kernel patch)
-# Contributor: npfeiler (4.11, 4.12, 4.13 and 4.14 kernel patch)
+# Contributor: npfeiler (4.11, 4.12, 4.13, 4.14 and 4.15.5 kernel patch)
_kernver=`uname -r`
pkgname=catalyst
pkgver=15.9
-pkgrel=18
+pkgrel=19
_amdver=15.201.1151
pkgdesc="AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED"
arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
-depends=('linux>=3.0' 'linux<4.15' 'catalyst-utils')
+depends=('linux>=3.0' 'linux<4.16' 'catalyst-utils')
makedepends=('gcc-libs' 'gcc>4.0.0' 'make' 'linux-headers')
conflicts=('catalyst-test')
install=catalyst.install
@@ -54,7 +54,8 @@ source=(
4.12-arch-remove_clts.patch
4.12-npfeiler-movsl_mask.patch
4.13-npfeiler-wait_queue_t.patch
- 4.14-npfeiler-task_struct-mm_segment_t.patch)
+ 4.14-npfeiler-task_struct-mm_segment_t.patch
+ 4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch)
md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'fd98b7e486d7fd4cad8de7b95b5b031e'
@@ -77,7 +78,8 @@ md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'782769206ed12ded10c347be3e476729'
'cb25bc7fbb7d5cb1c07d2f3fa5fda826'
'0a725f40bc980d578cbed3e57a05b765'
- '5ba3bf9f58aa63c1849b056cf23022c9')
+ '5ba3bf9f58aa63c1849b056cf23022c9'
+ '10af58c21e4e972115dda6dbd8279594')
build() {
@@ -120,6 +122,7 @@ build() {
patch -Np1 -i ../4.12-npfeiler-movsl_mask.patch
patch -Np1 -i ../4.13-npfeiler-wait_queue_t.patch
patch -Np1 -i ../4.14-npfeiler-task_struct-mm_segment_t.patch
+ patch -Np1 -i ../4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
cd ${srcdir}/archive_files/common/lib/modules/fglrx/build_mod
cp ${srcdir}/archive_files/arch/${_archdir}/lib/modules/fglrx/build_mod/libfglrx_ip.a .