summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVi0L02018-01-21 21:20:32 +0100
committerVi0L02018-01-21 21:20:32 +0100
commitd5e472f377090f3b108bb42384eaa85b33f9aac2 (patch)
tree5b1005ed6e1f00eadfd7d8a064f3f86707adef53
parent9fb3698bc366b007b83f993e00ad65a49d921162 (diff)
downloadaur-d5e472f377090f3b108bb42384eaa85b33f9aac2.tar.gz
15.9-18: 4.14 kernel support
-rw-r--r--.SRCINFO8
-rw-r--r--4.14-npfeiler-task_struct-mm_segment_t.patch12
-rw-r--r--PKGBUILD13
3 files changed, 26 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42df045cef0c..0e23572b72d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Jan 21 20:19:26 UTC 2018
pkgbase = catalyst
pkgdesc = AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
pkgver = 15.9
- pkgrel = 17
+ pkgrel = 18
url = http://www.amd.com
install = catalyst.install
arch = i686
@@ -12,7 +14,7 @@ pkgbase = catalyst
makedepends = make
makedepends = linux-headers
depends = linux>=3.0
- depends = linux<4.14
+ depends = linux<4.15
depends = catalyst-utils
conflicts = catalyst-test
source = http://www2.ati.com/drivers/linux/amd-catalyst-15.9-linux-installer-15.201.1151-x86.x86_64.zip
@@ -36,6 +38,7 @@ pkgbase = catalyst
source = 4.12-arch-remove_clts.patch
source = 4.12-npfeiler-movsl_mask.patch
source = 4.13-npfeiler-wait_queue_t.patch
+ source = 4.14-npfeiler-task_struct-mm_segment_t.patch
md5sums = d2de2df6946b452c266a3c892e6e46ff
md5sums = fd98b7e486d7fd4cad8de7b95b5b031e
md5sums = 3e1b82bd69774ea808da69c983d6a43b
@@ -57,6 +60,7 @@ pkgbase = catalyst
md5sums = 782769206ed12ded10c347be3e476729
md5sums = cb25bc7fbb7d5cb1c07d2f3fa5fda826
md5sums = 0a725f40bc980d578cbed3e57a05b765
+ md5sums = 5ba3bf9f58aa63c1849b056cf23022c9
pkgname = catalyst
diff --git a/4.14-npfeiler-task_struct-mm_segment_t.patch b/4.14-npfeiler-task_struct-mm_segment_t.patch
new file mode 100644
index 000000000000..d90d4f3c509a
--- /dev/null
+++ b/4.14-npfeiler-task_struct-mm_segment_t.patch
@@ -0,0 +1,12 @@
+--- archive_files/common/lib/modules/fglrx/build_mod/kcl_ioctl.c 2017-12-05 16:21:41.450899943 +0100
++++ archive_filesb/common/lib/modules/fglrx/build_mod/kcl_ioctl.c 2017-12-05 16:24:04.919602271 +0100
+@@ -31,7 +31,9 @@
+ */
+
+ #include <linux/cache.h>
++#include <linux/sched.h> // for task_struct in asm/current.h
+ #include <linux/version.h>
++#include <asm/processor.h> // for mm_segment_t in asm/uaccess.h
+ #include <asm/uaccess.h>
+
+ #ifdef __x86_64__
diff --git a/PKGBUILD b/PKGBUILD
index 55fe0a129aee..431441a30c7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,20 +11,20 @@
# Contributor: gentoo (part of 4.3 kernel patches)
# Contributor: Philip Muller @ Manjaro (4.4 kernel patch)
# Contributor: sling00 (4.10 kernel patch)
-# Contributor: npfeiler (4.11, 4.12 and 4.13 kernel patch)
+# Contributor: npfeiler (4.11, 4.12, 4.13 and 4.14 kernel patch)
_kernver=`uname -r`
pkgname=catalyst
pkgver=15.9
-pkgrel=17
+pkgrel=18
_amdver=15.201.1151
pkgdesc="AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED"
arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
-depends=('linux>=3.0' 'linux<4.14' 'catalyst-utils')
+depends=('linux>=3.0' 'linux<4.15' 'catalyst-utils')
makedepends=('gcc-libs' 'gcc>4.0.0' 'make' 'linux-headers')
conflicts=('catalyst-test')
install=catalyst.install
@@ -53,7 +53,8 @@ source=(
4.12-npfeiler-PUD_OFFSET.patch
4.12-arch-remove_clts.patch
4.12-npfeiler-movsl_mask.patch
- 4.13-npfeiler-wait_queue_t.patch)
+ 4.13-npfeiler-wait_queue_t.patch
+ 4.14-npfeiler-task_struct-mm_segment_t.patch)
md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'fd98b7e486d7fd4cad8de7b95b5b031e'
@@ -75,7 +76,8 @@ md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'f090e47160403e4ba65d1e0de69973c9'
'782769206ed12ded10c347be3e476729'
'cb25bc7fbb7d5cb1c07d2f3fa5fda826'
- '0a725f40bc980d578cbed3e57a05b765')
+ '0a725f40bc980d578cbed3e57a05b765'
+ '5ba3bf9f58aa63c1849b056cf23022c9')
build() {
@@ -117,6 +119,7 @@ build() {
patch -Np1 -i ../4.12-arch-remove_clts.patch
patch -Np1 -i ../4.12-npfeiler-movsl_mask.patch
patch -Np1 -i ../4.13-npfeiler-wait_queue_t.patch
+ patch -Np1 -i ../4.14-npfeiler-task_struct-mm_segment_t.patch
cd ${srcdir}/archive_files/common/lib/modules/fglrx/build_mod
cp ${srcdir}/archive_files/arch/${_archdir}/lib/modules/fglrx/build_mod/libfglrx_ip.a .