summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVi0L02015-10-26 20:38:30 +0100
committerVi0L02015-10-26 20:38:30 +0100
commit0941c8c180c3bea059203ece9ac008ba98e2ed45 (patch)
tree354dd8193e48bee8701ada6e9cdd97015f0f5d2e
parent413a266147edfd527297ccfebf0d813eeaab85c5 (diff)
downloadaur-0941c8c180c3bea059203ece9ac008ba98e2ed45.tar.gz
adding 4.2 kernel support workaround
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD6
-rw-r--r--catalyst-test.install8
-rwxr-xr-xcatalyst_build_module2
4 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64e8e93d2d1c..7815541dec18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = catalyst-test
pkgdesc = AMD/ATI Catalyst drivers for linux. catalyst-hook + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
pkgver = 15.9
- pkgrel = 4
+ pkgrel = 5
url = http://www.amd.com
install = catalyst-test.install
arch = i686
arch = x86_64
license = custom
- depends = linux-lts>=3.0
- depends = linux-lts<4.2
- depends = linux-lts-headers
+ depends = linux>=3.0
+ depends = linux<4.3
+ depends = linux-headers
depends = xorg-server>=1.7.0
depends = xorg-server<1.18.0
depends = libxrandr
@@ -23,6 +23,7 @@ pkgbase = catalyst-test
depends = patch
depends = libxinerama
depends = mesa>=10.1.0-4
+ depends = gcc49
optdepends = qt4: to run ATi Catalyst Control Center (amdcccle)
optdepends = libxxf86vm: to run ATi Catalyst Control Center (amdcccle)
optdepends = opencl-headers: headers necessary for OpenCL development
@@ -84,7 +85,7 @@ pkgbase = catalyst-test
source = 4.2-kolasa-fpu_save_init.patch
source = ubuntu_buildfix_kernel_4.2-build.copy_xregs_to_kernel.patch
md5sums = d2de2df6946b452c266a3c892e6e46ff
- md5sums = 601d9c756571dd79d26944e54827631e
+ md5sums = f3aaed0084725304cf607f6915e4bfee
md5sums = af7fb8ee4fc96fd54c5b483e33dc71c4
md5sums = bdafe749e046bfddee2d1c5e90eabd83
md5sums = 9d9ea496eadf7e883d56723d65e96edf
diff --git a/PKGBUILD b/PKGBUILD
index 2e1b040deb2b..db726099531e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,7 +26,7 @@
pkgname=catalyst-test
pkgver=15.9
-pkgrel=4
+pkgrel=5
# _betano=1.0
_amdver=15.201.1151
pkgdesc="AMD/ATI Catalyst drivers for linux. catalyst-hook + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED"
@@ -34,7 +34,7 @@ arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
options=('staticlibs' 'libtool' '!strip' '!upx')
-depends=('linux-lts>=3.0' 'linux-lts<4.2' 'linux-lts-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa>=10.1.0-4')
+depends=('linux>=3.0' 'linux<4.3' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa>=10.1.0-4' 'gcc49')
optdepends=('qt4: to run ATi Catalyst Control Center (amdcccle)'
'libxxf86vm: to run ATi Catalyst Control Center (amdcccle)'
'opencl-headers: headers necessary for OpenCL development'
@@ -98,7 +98,7 @@ source=(
ubuntu_buildfix_kernel_4.2-build.copy_xregs_to_kernel.patch)
md5sums=('d2de2df6946b452c266a3c892e6e46ff'
- '601d9c756571dd79d26944e54827631e'
+ 'f3aaed0084725304cf607f6915e4bfee'
'af7fb8ee4fc96fd54c5b483e33dc71c4'
'bdafe749e046bfddee2d1c5e90eabd83'
'9d9ea496eadf7e883d56723d65e96edf'
diff --git a/catalyst-test.install b/catalyst-test.install
index 4f8248167902..8386887d649c 100644
--- a/catalyst-test.install
+++ b/catalyst-test.install
@@ -35,14 +35,6 @@ whisperer(){
echo "Using uvesafb is a workaround:"
echo "https://wiki.archlinux.org/index.php/uvesafb"
echo -e "\e[1;31m----------------------------------------------------------------\e[0m"
- echo -e "\e[1;31m--------------------- NO 4.2 KERNEL SUPPORT---------------------\e[0m"
- echo "catalyst doesn't support linux kernels >= 4.2"
- echo "please configure bootloader to use proper kernel"
- echo "like linux-lts in example"
- echo ""
- echo "sleeping now for 5 seconds as this is important..."
- echo -e "\e[1;31m----------------------------------------------------------------\e[0m"
- sleep 5
}
bug_whisper(){
diff --git a/catalyst_build_module b/catalyst_build_module
index 02d75f9e4c4a..0afc3130c19a 100755
--- a/catalyst_build_module
+++ b/catalyst_build_module
@@ -35,7 +35,7 @@ install_module(){
## Compile module using _ati_check variables
CFLAGS_MODULE="-DMODULE -DATI -DFGL -DPAGE_ATTR_FIX=$PAGE_ATTR_FIX -DCOMPAT_ALLOC_USER_SPACE=$COMPAT_ALLOC_USER_SPACE $def_smp $def_modversions"
- make -C /usr/lib/modules/${kernver}/build SUBDIRS="`pwd`" ARCH=${arch} \
+ make CC=gcc-4.9 -C /usr/lib/modules/${kernver}/build SUBDIRS="`pwd`" ARCH=${arch} \
MODFLAGS="$CFLAGS_MODULE" \
CFLAGS_MODULE="$CFLAGS_MODULE" \
PAGE_ATTR_FIX=$PAGE_ATTR_FIX COMPAT_ALLOC_USER_SPACE=$COMPAT_ALLOC_USER_SPACE modules || return 1