summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVi0L02018-02-25 19:49:04 +0100
committerVi0L02018-02-25 19:49:04 +0100
commit1d61cbc04cfa1a80c4ee689c4aaa8f42b19648d4 (patch)
tree41ed044b2d4cdb25db17a29218bc56c39de49a38
parent8c9e17ef68027ba7f0e85cd3363155b81150cd5b (diff)
downloadaur-1d61cbc04cfa1a80c4ee689c4aaa8f42b19648d4.tar.gz
15.12-21: 4.14.21 + 4.15.5 kernel support & opencl runtime from 15.9
-rw-r--r--.SRCINFO8
-rw-r--r--4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch14
-rw-r--r--PKGBUILD27
3 files changed, 42 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5291b77e6bc8..dbc57f47fa2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Feb 18 18:59:35 UTC 2018
+# Sun Feb 25 18:46:12 UTC 2018
pkgbase = catalyst-test
pkgdesc = AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons are optionally supported
pkgver = 15.12
- pkgrel = 20
+ pkgrel = 21
url = http://www.amd.com
install = catalyst-test.install
arch = i686
@@ -67,6 +67,7 @@ pkgbase = catalyst-test
options = !strip
options = !upx
source = http://www2.ati.com/drivers/linux/radeon-crimson-15.12-15.302-151217a-297685e.zip
+ source = http://www2.ati.com/drivers/linux/amd-catalyst-15.9-linux-installer-15.201.1151-x86.x86_64.zip
source = lib32-catalyst.sh
source = catalyst.sh
source = atieventsd.sh
@@ -101,7 +102,9 @@ pkgbase = catalyst-test
source = 4.12-npfeiler-movsl_mask.patch
source = 4.13-npfeiler-wait_queue_t.patch
source = 4.14-npfeiler-task_struct-mm_segment_t.patch
+ source = 4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
md5sums = 39808c8a9bcc9041f1305e3531b60622
+ md5sums = d2de2df6946b452c266a3c892e6e46ff
md5sums = af7fb8ee4fc96fd54c5b483e33dc71c4
md5sums = bdafe749e046bfddee2d1c5e90eabd83
md5sums = 9d9ea496eadf7e883d56723d65e96edf
@@ -136,6 +139,7 @@ pkgbase = catalyst-test
md5sums = cb25bc7fbb7d5cb1c07d2f3fa5fda826
md5sums = 0a725f40bc980d578cbed3e57a05b765
md5sums = 5ba3bf9f58aa63c1849b056cf23022c9
+ md5sums = 10af58c21e4e972115dda6dbd8279594
pkgname = catalyst-test
diff --git a/4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch b/4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
new file mode 100644
index 000000000000..1f9b7a4a777b
--- /dev/null
+++ b/4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
@@ -0,0 +1,14 @@
+--- archive_files/common/lib/modules/fglrx/build_mod/firegl_public.c 2015-12-18 19:47:41.000000000 +0100
++++ archive_filesb/common/lib/modules/fglrx/build_mod/firegl_public.c 2018-02-25 17:33:11.469309861 +0100
+@@ -2949,7 +2949,11 @@
+ static void kcl_flush_tlb_one(void *va)
+ {
+ unsigned long *addr = (unsigned long *)va;
++# if (LINUX_VERSION_CODE < KERNEL_VERSION(4,14,21))
+ __flush_tlb_one(*addr);
++# else
++ __flush_tlb_one_kernel(*addr);
++# endif
+ }
+
+ /** /brief Flush one page on all cpus
diff --git a/PKGBUILD b/PKGBUILD
index a8a1eec599c3..40818afcc33e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,8 @@
+# NOTE before builing package - download needed catalyst drivers zip archives from here:
+# https://support.amd.com/en-us/download/desktop?os=Linux%20x86_64
+# https://support.amd.com/en-us/download/desktop/previous?os=Linux%20x86_64
+# and paste it next to this PKGBUILD
+
# Maintainer: Vi0L0 <vi0l093@gmail.com>
# Great Contributor: Shen Miren <dickeny@gmail.com> (build_module/hook idea and code)
# Great Contributor: Eduardo "kensai" Romero (previous catalyst and catalyst-utils maintainer)
@@ -24,7 +29,7 @@
# Contributor: aslmaswd (acpi main script)
# Contributor: npfeiler (libcl/opencl-icd-loader cleaning)
# Contributor: sling00 (4.10 kernel patch)
-# Contributor: npfeiler (4.11, 4.12, 4.13 and 4.14 kernel patch)
+# Contributor: npfeiler (4.11, 4.12, 4.13, 4.14 and 4.15.5 kernel patch)
_old_control=n #for pre-GCN users who has problems with default config, pick =y to enable catalyst 15.9 control file
@@ -32,7 +37,7 @@ _old_control=n #for pre-GCN users who has problems with default config, pick =y
pkgname=catalyst-test
pkgver=15.12
-pkgrel=20
+pkgrel=21
# _betano=1.0
_amdver=15.302
pkgdesc="AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons are optionally supported"
@@ -76,6 +81,7 @@ source=(
# http://www2.ati.com/drivers/linux/amd-catalyst-omega-14.12-linux-run-installers.zip
# http://www2.ati.com/drivers/linux/amd-driver-installer-${_amdver}-x86.x86_64.zip
http://www2.ati.com/drivers/linux/radeon-crimson-15.12-15.302-151217a-297685e.zip
+ http://www2.ati.com/drivers/linux/amd-catalyst-15.9-linux-installer-15.201.1151-x86.x86_64.zip
lib32-catalyst.sh
catalyst.sh
atieventsd.sh
@@ -109,9 +115,11 @@ source=(
4.12-arch-remove_clts.patch
4.12-npfeiler-movsl_mask.patch
4.13-npfeiler-wait_queue_t.patch
- 4.14-npfeiler-task_struct-mm_segment_t.patch)
+ 4.14-npfeiler-task_struct-mm_segment_t.patch
+ 4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch)
md5sums=('39808c8a9bcc9041f1305e3531b60622'
+ 'd2de2df6946b452c266a3c892e6e46ff'
'af7fb8ee4fc96fd54c5b483e33dc71c4'
'bdafe749e046bfddee2d1c5e90eabd83'
'9d9ea496eadf7e883d56723d65e96edf'
@@ -145,11 +153,13 @@ md5sums=('39808c8a9bcc9041f1305e3531b60622'
'782769206ed12ded10c347be3e476729'
'cb25bc7fbb7d5cb1c07d2f3fa5fda826'
'0a725f40bc980d578cbed3e57a05b765'
- '5ba3bf9f58aa63c1849b056cf23022c9')
+ '5ba3bf9f58aa63c1849b056cf23022c9'
+ '10af58c21e4e972115dda6dbd8279594')
prepare() {
## Unpack archive
/bin/sh ./fglrx-${_amdver}/amd-driver-installer-${_amdver}-x86.x86_64.run --extract archive_files
+ /bin/sh ./AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64.run --extract archive_files_2
# mkdir common
# mv etc lib usr common
# mkdir archive_files
@@ -177,7 +187,8 @@ prepare() {
patch -Np1 -i ../4.12-npfeiler-movsl_mask.patch
patch -Np1 -i ../4.13-npfeiler-wait_queue_t.patch
patch -Np1 -i ../4.14-npfeiler-task_struct-mm_segment_t.patch
-
+ patch -Np1 -i ../4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
+
cd ${srcdir}/archive_files/common
patch -Np2 -i ${srcdir}/arch-fglrx-authatieventsd_new.patch
}
@@ -230,9 +241,11 @@ package() {
if [ "${CARCH}" = "i686" ]; then
cd ${srcdir}/archive_files/arch/x86/usr
_lib=lib
+ _amdarch=x86
elif [ "${CARCH}" = "x86_64" ]; then
cd ${srcdir}/archive_files/arch/x86_64/usr
_lib=lib64
+ _amdarch=x86_64
fi
install -m755 X11R6/bin/* ${pkgdir}/usr/bin
@@ -251,6 +264,8 @@ package() {
install -m644 X11R6/${_lib}/*.cap ${pkgdir}/usr/lib
install -m755 X11R6/${_lib}/modules/dri/*.so ${pkgdir}/usr/lib/xorg/modules/dri
install -m755 ${_lib}/*.so* ${pkgdir}/usr/lib
+ ## use opencl runtime from 15.9
+ install -m755 ${srcdir}/archive_files_2/arch/${_amdarch}/usr/${_lib}/libamdocl* ${pkgdir}/usr/lib
rm ${pkgdir}/usr/lib/libOpenCL.so.1 #opencl-icd-loader provides this
# install -m755 ${_lib}/hsa/* ${pkgdir}/usr/lib/hsa #removed in 14.1
@@ -383,6 +398,8 @@ package() {
install -dm755 ${pkgdir}/usr/lib32/xorg/modules/dri
# install -dm755 ${pkgdir}/usr/lib32/hsa #removed in 14.1
install -m755 lib/*.so* ${pkgdir}/usr/lib32
+ ## use opencl runtime from 15.9
+ install -m755 ${srcdir}/archive_files_2/arch/x86/usr/lib/libamdocl* ${pkgdir}/usr/lib32
rm ${pkgdir}/usr/lib32/libOpenCL.so.1 #lib32-opencl-icd-loader provides this
# install -m755 lib/hsa/* ${pkgdir}/usr/lib32/hsa #removed in 14.1
install -m755 X11R6/lib/fglrx/fglrx-libGL.so.1.2 ${pkgdir}/usr/lib32/fglrx