summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVi0L02016-07-25 22:37:11 +0200
committerVi0L02016-07-25 22:37:11 +0200
commit37d92c1f9013698167d70cdf0730ddc35374e0e5 (patch)
treedcf57b929dacf9aed2737b5389b26483ed1ab4da
parent0cf6daa534349a867d1d39f17b45b609b5430094 (diff)
downloadaur-37d92c1f9013698167d70cdf0730ddc35374e0e5.tar.gz
15.12-8: initial 4.7 kernel support
-rw-r--r--.SRCINFO6
-rw-r--r--4.7-arch-cpu_has_pge.patch53
-rw-r--r--PKGBUILD11
3 files changed, 64 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1153664404f..5430df54c21b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = catalyst-test
pkgdesc = AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons ARE NOT SUPPORTED
pkgver = 15.12
- pkgrel = 7
+ pkgrel = 8
url = http://www.amd.com
install = catalyst-test.install
arch = i686
@@ -9,7 +9,7 @@ pkgbase = catalyst-test
license = custom
depends = dkms
depends = linux>=3.0
- depends = linux<4.7
+ depends = linux<4.8
depends = linux-headers
depends = xorg-server>=1.7.0
depends = xorg-server<1.18.0
@@ -80,6 +80,7 @@ pkgbase = catalyst-test
source = 4.6-arch-get_user_pages-page_cache_release.patch
source = dkms.conf
source = makesh-dont-check-gcc-version.patch
+ source = 4.7-arch-cpu_has_pge.patch
md5sums = 39808c8a9bcc9041f1305e3531b60622
md5sums = af7fb8ee4fc96fd54c5b483e33dc71c4
md5sums = bdafe749e046bfddee2d1c5e90eabd83
@@ -105,6 +106,7 @@ pkgbase = catalyst-test
md5sums = 11b7c2e0dc4794801005d66b0e7608a3
md5sums = 23d569abfdd7de433d76e003e4b3ccf9
md5sums = 10829e3b992b3e80a6e78c8e27748703
+ md5sums = fa8cb4422218e251fe2eb7d31a4b0c61
pkgname = catalyst-test
diff --git a/4.7-arch-cpu_has_pge.patch b/4.7-arch-cpu_has_pge.patch
new file mode 100644
index 000000000000..7ea3141a414c
--- /dev/null
+++ b/4.7-arch-cpu_has_pge.patch
@@ -0,0 +1,53 @@
+diff -uNr 16.7/common/lib/modules/fglrx/build_mod/firegl_public.c 16.7b/common/lib/modules/fglrx/build_mod/firegl_public.c
+--- 16.7/common/lib/modules/fglrx/build_mod/firegl_public.c 2015-12-18 19:47:41.000000000 +0100
++++ 16.7b/common/lib/modules/fglrx/build_mod/firegl_public.c 2016-07-25 21:36:39.061216384 +0200
+@@ -4518,7 +4518,7 @@
+ write_cr0(cr0);
+ wbinvd();
+
+- if (cpu_has_pge)
++ if (boot_cpu_has(X86_FEATURE_PGE))
+ {
+ cr4 = READ_CR4();
+ WRITE_CR4(cr4 & ~X86_CR4_PGE);
+@@ -4532,7 +4532,7 @@
+ wbinvd();
+ __flush_tlb();
+ write_cr0(cr0 & 0xbfffffff);
+- if (cpu_has_pge)
++ if (boot_cpu_has(X86_FEATURE_PGE))
+ {
+ WRITE_CR4(cr4);
+ }
+@@ -4559,7 +4559,7 @@
+ write_cr0(cr0);
+ wbinvd();
+
+- if (cpu_has_pge)
++ if (boot_cpu_has(X86_FEATURE_PGE))
+ {
+ cr4 = READ_CR4();
+ WRITE_CR4(cr4 & ~X86_CR4_PGE);
+@@ -4572,7 +4572,7 @@
+ wbinvd();
+ __flush_tlb();
+ write_cr0(cr0 & 0xbfffffff);
+- if (cpu_has_pge)
++ if (boot_cpu_has(X86_FEATURE_PGE))
+ {
+ WRITE_CR4(cr4);
+ }
+diff -uNr 16.7/common/lib/modules/fglrx/build_mod/firegl_public.h 16.7b/common/lib/modules/fglrx/build_mod/firegl_public.h
+--- 16.7/common/lib/modules/fglrx/build_mod/firegl_public.h 2015-12-18 19:47:41.000000000 +0100
++++ 16.7b/common/lib/modules/fglrx/build_mod/firegl_public.h 2016-07-25 21:37:04.751276300 +0200
+@@ -650,8 +650,8 @@
+ #define cpu_has_pat test_bit(X86_FEATURE_PAT, (void *) &boot_cpu_data.x86_capability)
+ #endif
+
+-#ifndef cpu_has_pge
+-#define cpu_has_pge test_bit(X86_FEATURE_PGE, &boot_cpu_data.x86_capability)
++#ifndef boot_cpu_has(X86_FEATURE_PGE)
++#define boot_cpu_has(X86_FEATURE_PGE) test_bit(X86_FEATURE_PGE, &boot_cpu_data.x86_capability)
+ #endif
+
+ /* 2.6.29 defines pgprot_writecombine as a macro which resolves to a
diff --git a/PKGBUILD b/PKGBUILD
index 958a3ddc7b5f..f62de1afd25d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,7 @@
pkgname=catalyst-test
pkgver=15.12
-pkgrel=7
+pkgrel=8
# _betano=1.0
_amdver=15.302
pkgdesc="AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons ARE NOT SUPPORTED"
@@ -35,7 +35,7 @@ arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
options=('staticlibs' 'libtool' '!strip' '!upx')
-depends=('dkms' 'linux>=3.0' 'linux<4.7' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa>=10.1.0-4')
+depends=('dkms' 'linux>=3.0' 'linux<4.8' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa>=10.1.0-4')
optdepends=('qt4: to run ATi Catalyst Control Center (amdcccle)'
'libxxf86vm: to run ATi Catalyst Control Center (amdcccle)'
'opencl-headers: headers necessary for OpenCL development'
@@ -92,7 +92,8 @@ source=(
grsec_arch.patch
4.6-arch-get_user_pages-page_cache_release.patch
dkms.conf
- makesh-dont-check-gcc-version.patch)
+ makesh-dont-check-gcc-version.patch
+ 4.7-arch-cpu_has_pge.patch)
md5sums=('39808c8a9bcc9041f1305e3531b60622'
'af7fb8ee4fc96fd54c5b483e33dc71c4'
@@ -118,7 +119,8 @@ md5sums=('39808c8a9bcc9041f1305e3531b60622'
'8941e91fc58cb44ce21ab9bda135754e'
'11b7c2e0dc4794801005d66b0e7608a3'
'23d569abfdd7de433d76e003e4b3ccf9'
- '10829e3b992b3e80a6e78c8e27748703')
+ '10829e3b992b3e80a6e78c8e27748703'
+ 'fa8cb4422218e251fe2eb7d31a4b0c61')
build() {
@@ -307,6 +309,7 @@ package() {
patch -Np1 -i ../grsec_arch.patch
patch -Np1 -i ../4.6-arch-get_user_pages-page_cache_release.patch
patch -Np1 -i ../makesh-dont-check-gcc-version.patch
+ patch -Np1 -i ../4.7-arch-cpu_has_pge.patch
# Prepare modules source files
install -dm755 ${pkgdir}/usr/src/fglrx-${pkgver}/2.6.x