summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVi0L02019-03-24 22:29:55 +0100
committerVi0L02019-03-24 22:29:55 +0100
commit4a9a00f8e37c6703c32ac19a310ce688ea7b63bf (patch)
tree370ebaa9c114a941643b9a156c475782fee379df
parent540858796b369122432b51c2ba61e39c68cc9bfc (diff)
downloadaur-4a9a00f8e37c6703c32ac19a310ce688ea7b63bf.tar.gz
5.0 kernel support
-rw-r--r--.SRCINFO10
-rw-r--r--5.0-npfeiler.patch110
-rw-r--r--PKGBUILD13
3 files changed, 124 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d01ffaba479f..6517a1a4efd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Sun Jan 20 20:45:37 UTC 2019
+# Sun Mar 24 21:27:03 UTC 2019
pkgbase = catalyst-test
pkgdesc = AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons are optionally supported
pkgver = 15.12
- pkgrel = 28
+ pkgrel = 29
url = http://www.amd.com
install = catalyst-test.install
arch = i686
arch = x86_64
license = custom
depends = dkms
- depends = linux>=3.0
- depends = linux<4.21
+ depends = linux>=5.0
+ depends = linux<5.1
depends = linux-headers
depends = xorg-server>=1.7.0
depends = xorg-server<1.18.0
@@ -103,6 +103,7 @@ pkgbase = catalyst-test
source = 4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
source = 4.17-npfeiler-pci_get_domain_bus_and_slot.patch
source = 4.20-npfeiler-libfglrx_ip.patch
+ source = 5.0-npfeiler.patch
md5sums = 39808c8a9bcc9041f1305e3531b60622
md5sums = af7fb8ee4fc96fd54c5b483e33dc71c4
md5sums = bdafe749e046bfddee2d1c5e90eabd83
@@ -141,6 +142,7 @@ pkgbase = catalyst-test
md5sums = 10af58c21e4e972115dda6dbd8279594
md5sums = 7ed6e1cf3a9719e6a9874e6a18f29bfb
md5sums = 3ca961ceefbc4ddc0eb21452cba79c6c
+ md5sums = 61e709ce66c0479fe3aff7245c71a382
pkgname = catalyst-test
diff --git a/5.0-npfeiler.patch b/5.0-npfeiler.patch
new file mode 100644
index 000000000000..70b662b74595
--- /dev/null
+++ b/5.0-npfeiler.patch
@@ -0,0 +1,110 @@
+--- archive_files/common/lib/modules/fglrx/build_mod/2.6.x/Makefile
++++ archive_files/common/lib/modules/fglrx/build_mod/2.6.x/Makefile
+@@ -87,7 +87,7 @@ fglrx-cfiles = ${fglrx-c-objs:.o=.c}
+ # default:: kmod_build
+
+ kmod_build:: $(fglrx-libs) $(fglrx-cfiles) $(fglrx-hdrs) $(drm-hdrs)
+- $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
++ $(MAKE) -C $(KDIR) M=$(PWD) modules
+
+ %.c:
+ @ln -s ../$@
+--- archive_files/common/lib/modules/fglrx/build_mod/drmP.h
++++ archive_files/common/lib/modules/fglrx/build_mod/drmP.h
+@@ -218,12 +218,10 @@
+ #define DRM_PROC_LIMIT (PAGE_SIZE-80)
+
+ #define DRM_PROC_PRINT(fmt, arg...) \
+- len += sprintf(&buf[len], fmt , ##arg); \
+- if (len > DRM_PROC_LIMIT) { *eof = 1; return len - offset; }
++ if ((len += sprintf(&buf[len], fmt , ##arg)) > DRM_PROC_LIMIT) { *eof = 1; return len - offset; }
+
+ #define DRM_PROC_PRINT_RET(ret, fmt, arg...) \
+- len += sprintf(&buf[len], fmt , ##arg); \
+- if (len > DRM_PROC_LIMIT) { ret; *eof = 1; return len - offset; }
++ if ((len += sprintf(&buf[len], fmt , ##arg)) > DRM_PROC_LIMIT) { ret; *eof = 1; return len - offset; }
+
+ /*@}*/
+
+--- archive_files/common/lib/modules/fglrx/build_mod/firegl_public.c
++++ archive_files/common/lib/modules/fglrx/build_mod/firegl_public.c
+@@ -2741,12 +2741,12 @@ void ATI_API_CALL KCL_UnlockMemPage(void* pt)
+
+ int ATI_API_CALL KCL_MEM_VerifyReadAccess(void* addr, kcl_size_t size)
+ {
+- return access_ok(VERIFY_READ, addr, size) ? 0 : -EFAULT;
++ return access_ok(addr, size) ? 0 : -EFAULT;
+ }
+
+ int ATI_API_CALL KCL_MEM_VerifyWriteAccess(void* addr, kcl_size_t size)
+ {
+- return access_ok(VERIFY_WRITE, addr, size) ? 0 : -EFAULT;
++ return access_ok(addr, size) ? 0 : -EFAULT;
+ }
+
+ /** \brief Get Init kernel PTE by address. Couldn't be used for kernel >= 2.6.25.
+@@ -6602,6 +6602,7 @@ void ATI_API_CALL KCL_create_uuid(void *buf)
+ generate_random_uuid((char *)buf);
+ }
+
++#ifndef CONFIG_X86_64
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,15,0)
+ static int KCL_fpu_save_init(struct task_struct *tsk)
+ {
+@@ -6658,6 +6659,8 @@ static int KCL_fpu_save_init(struct task_struct *tsk)
+ return 1;
+ }
+ #endif
++#endif
++
+
+ /** \brief Prepare for using FPU
+ * \param none
+@@ -6666,12 +6669,7 @@ static int KCL_fpu_save_init(struct task_struct *tsk)
+ void ATI_API_CALL KCL_fpu_begin(void)
+ {
+ #ifdef CONFIG_X86_64
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(4,2,0)
+ kernel_fpu_begin();
+-#else
+- preempt_disable();
+- __kernel_fpu_begin();
+-#endif
+ #else
+ #ifdef TS_USEDFPU
+ struct thread_info *cur_thread = current_thread_info();
+@@ -6718,12 +6716,7 @@ void ATI_API_CALL KCL_fpu_begin(void)
+ */
+ void ATI_API_CALL KCL_fpu_end(void)
+ {
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(4,2,0)
+ kernel_fpu_end();
+-#else
+- __kernel_fpu_end();
+- preempt_enable();
+-#endif
+ }
+
+ /** Create new directory entry under "/proc/...."
+--- archive_files/common/lib/modules/fglrx/build_mod/firegl_public.h
++++ archive_files/common/lib/modules/fglrx/build_mod/firegl_public.h
+@@ -668,7 +668,7 @@ extern unsigned long KCL_SYSINFO_TimerTicksPerSecond;
+ #endif
+
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4,7,0)
+-#ifndef boot_cpu_has(X86_FEATURE_PGE)
++#ifndef boot_cpu_has
+ #define boot_cpu_has(X86_FEATURE_PGE) test_bit(X86_FEATURE_PGE, &boot_cpu_data.x86_capability)
+ #endif
+ #else
+--- archive_files/common/lib/modules/fglrx/build_mod/kcl_ioctl.c
++++ archive_files/common/lib/modules/fglrx/build_mod/kcl_ioctl.c
+@@ -228,7 +228,7 @@ void* ATI_API_CALL KCL_IOCTL_AllocUserSpace32(long size)
+ void __user *ret = COMPAT_ALLOC_USER_SPACE(size);
+
+ /* prevent stack overflow */
+- if (!access_ok(VERIFY_WRITE, ret, size))
++ if (!access_ok(ret, size))
+ return NULL;
+
+ return (void *)ret; \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index a7475aa4e8fc..07853ae8a45b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,13 +24,13 @@
# Contributor: aslmaswd (acpi main script)
# Contributor: npfeiler (libcl/opencl-icd-loader cleaning)
# Contributor: sling00 (4.10 kernel patch)
-# Contributor: npfeiler (4.11, 4.12, 4.13, 4.14, 4.15.5, 4.17 and 4.20 kernel patch)
+# Contributor: npfeiler (4.11, 4.12, 4.13, 4.14, 4.15.5, 4.17, 4.20 and 5.0 kernel patch)
_old_control=n #for pre-GCN users who has problems with default config, pick =y to use control file and opencl runtime from catalyst 15.9
pkgname=catalyst-test
pkgver=15.12
-pkgrel=28
+pkgrel=29
# _betano=1.0
_amdver=15.302
pkgdesc="AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons are optionally supported"
@@ -38,7 +38,7 @@ arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
options=('staticlibs' 'libtool' '!strip')
-depends=('dkms' 'linux>=3.0' 'linux<4.21' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa-noglvnd')
+depends=('dkms' 'linux>=5.0' 'linux<5.1' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa-noglvnd')
optdepends=('qt4: to run ATi Catalyst Control Center (amdcccle)'
'libxxf86vm: to run ATi Catalyst Control Center (amdcccle)'
'opencl-headers: headers necessary for OpenCL development'
@@ -110,7 +110,8 @@ source=(
4.14-npfeiler-task_struct-mm_segment_t.patch
4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
4.17-npfeiler-pci_get_domain_bus_and_slot.patch
- 4.20-npfeiler-libfglrx_ip.patch)
+ 4.20-npfeiler-libfglrx_ip.patch
+ 5.0-npfeiler.patch)
md5sums=('39808c8a9bcc9041f1305e3531b60622'
'af7fb8ee4fc96fd54c5b483e33dc71c4'
@@ -149,7 +150,8 @@ md5sums=('39808c8a9bcc9041f1305e3531b60622'
'5ba3bf9f58aa63c1849b056cf23022c9'
'10af58c21e4e972115dda6dbd8279594'
'7ed6e1cf3a9719e6a9874e6a18f29bfb'
- '3ca961ceefbc4ddc0eb21452cba79c6c')
+ '3ca961ceefbc4ddc0eb21452cba79c6c'
+ '61e709ce66c0479fe3aff7245c71a382')
if [ "${_old_control}" = "y" ]; then
source+=(https://www2.ati.com/drivers/linux/amd-catalyst-15.9-linux-installer-15.201.1151-x86.x86_64.zip)
@@ -192,6 +194,7 @@ prepare() {
patch -Np1 -i ../4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
patch -Np1 -i ../4.17-npfeiler-pci_get_domain_bus_and_slot.patch
patch -Np1 -i ../4.20-npfeiler-libfglrx_ip.patch
+ patch -Np1 -i ../5.0-npfeiler.patch
cd ${srcdir}/archive_files/common
patch -Np2 -i ${srcdir}/arch-fglrx-authatieventsd_new.patch