summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVi0L02017-10-03 22:13:16 +0200
committerVi0L02017-10-03 22:13:16 +0200
commit7e108d01fccf5c31125efede1bb1fd4e472a345f (patch)
tree000add9dbde6835e15c92c30750c3a992b3100ea
parent5ba05f68c65c389921b1e8335da1b8ed4d6239e3 (diff)
downloadaur-7e108d01fccf5c31125efede1bb1fd4e472a345f.tar.gz
15.12-18: 4.13 kernel support
-rw-r--r--.SRCINFO6
-rw-r--r--4.13-npfeiler-wait_queue_t.patch13
-rw-r--r--PKGBUILD13
3 files changed, 25 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8df582f11af..5a951ced5c49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = catalyst-test
pkgdesc = AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons are optionally supported
pkgver = 15.12
- pkgrel = 17
+ pkgrel = 18
url = http://www.amd.com
install = catalyst-test.install
arch = i686
@@ -9,7 +9,7 @@ pkgbase = catalyst-test
license = custom
depends = dkms
depends = linux>=3.0
- depends = linux<4.13
+ depends = linux<4.14
depends = linux-headers
depends = xorg-server>=1.7.0
depends = xorg-server<1.18.0
@@ -97,6 +97,7 @@ pkgbase = catalyst-test
source = 4.12-npfeiler-PUD_OFFSET.patch
source = 4.12-arch-remove_clts.patch
source = 4.12-npfeiler-movsl_mask.patch
+ source = 4.13-npfeiler-wait_queue_t.patch
md5sums = 39808c8a9bcc9041f1305e3531b60622
md5sums = af7fb8ee4fc96fd54c5b483e33dc71c4
md5sums = bdafe749e046bfddee2d1c5e90eabd83
@@ -130,6 +131,7 @@ pkgbase = catalyst-test
md5sums = f090e47160403e4ba65d1e0de69973c9
md5sums = 782769206ed12ded10c347be3e476729
md5sums = cb25bc7fbb7d5cb1c07d2f3fa5fda826
+ md5sums = 0a725f40bc980d578cbed3e57a05b765
pkgname = catalyst-test
diff --git a/4.13-npfeiler-wait_queue_t.patch b/4.13-npfeiler-wait_queue_t.patch
new file mode 100644
index 000000000000..8e5ed7da9ab9
--- /dev/null
+++ b/4.13-npfeiler-wait_queue_t.patch
@@ -0,0 +1,13 @@
+--- archive_files/common/lib/modules/fglrx/build_mod/kcl_wait.c 2015-12-18 19:47:41.000000000 +0100
++++ archive_filesb/common/lib/modules/fglrx/build_mod/kcl_wait.c 2017-09-30 14:13:37.285611187 +0200
+@@ -43,6 +43,10 @@
+ #include "kcl_config.h"
+ #include "kcl_wait.h"
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,13,0)
++typedef wait_queue_entry_t wait_queue_t;
++#endif
++
+ /** \brief Create wait object, init it and add to the kernel queue
+ ** \param object_handle [in] Object handle
+ ** \return Kernel wait handle on success, 0 otherwise
diff --git a/PKGBUILD b/PKGBUILD
index af48624091c2..7cf2fa83c636 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@
# Contributor: aslmaswd (acpi main script)
# Contributor: npfeiler (libcl/opencl-icd-loader cleaning)
# Contributor: sling00 (4.10 kernel patch)
-# Contributor: npfeiler (4.11 and 4.12 kernel patch)
+# Contributor: npfeiler (4.11, 4.12 and 4.13 kernel patch)
_old_control=n #for pre-GCN users who has problems with default config, pick =y to enable catalyst 15.9 control file
@@ -32,7 +32,7 @@ _old_control=n #for pre-GCN users who has problems with default config, pick =y
pkgname=catalyst-test
pkgver=15.12
-pkgrel=17
+pkgrel=18
# _betano=1.0
_amdver=15.302
pkgdesc="AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons are optionally supported"
@@ -40,7 +40,7 @@ arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
options=('staticlibs' 'libtool' '!strip' '!upx')
-depends=('dkms' 'linux>=3.0' 'linux<4.13' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa-noglvnd')
+depends=('dkms' 'linux>=3.0' 'linux<4.14' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa-noglvnd')
optdepends=('qt4: to run ATi Catalyst Control Center (amdcccle)'
'libxxf86vm: to run ATi Catalyst Control Center (amdcccle)'
'opencl-headers: headers necessary for OpenCL development'
@@ -107,7 +107,8 @@ source=(
4.11-npfeiler-signal_vmf.patch
4.12-npfeiler-PUD_OFFSET.patch
4.12-arch-remove_clts.patch
- 4.12-npfeiler-movsl_mask.patch)
+ 4.12-npfeiler-movsl_mask.patch
+ 4.13-npfeiler-wait_queue_t.patch)
md5sums=('39808c8a9bcc9041f1305e3531b60622'
'af7fb8ee4fc96fd54c5b483e33dc71c4'
@@ -141,7 +142,8 @@ md5sums=('39808c8a9bcc9041f1305e3531b60622'
'8e53ba65a0aad42eb2ff771c1ace6609'
'f090e47160403e4ba65d1e0de69973c9'
'782769206ed12ded10c347be3e476729'
- 'cb25bc7fbb7d5cb1c07d2f3fa5fda826')
+ 'cb25bc7fbb7d5cb1c07d2f3fa5fda826'
+ '0a725f40bc980d578cbed3e57a05b765')
build() {
@@ -341,6 +343,7 @@ package() {
patch -Np1 -i ../4.12-npfeiler-PUD_OFFSET.patch
patch -Np1 -i ../4.12-arch-remove_clts.patch
patch -Np1 -i ../4.12-npfeiler-movsl_mask.patch
+ patch -Np1 -i ../4.13-npfeiler-wait_queue_t.patch
# Prepare modules source files
install -dm755 ${pkgdir}/usr/src/fglrx-${pkgver}/2.6.x