summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVi0L02016-12-10 21:34:00 +0100
committerVi0L02016-12-10 21:34:00 +0100
commit810814ee53eb2acfdab918331ab17cb5e0335d4b (patch)
treec54c90808c54efa98ce78c52256573bbcb6015a2
parentb833c83b3ac96ca15ceace76c948967db83fd316 (diff)
downloadaur-810814ee53eb2acfdab918331ab17cb5e0335d4b.tar.gz
15.12-12: initial 4.9 kernel support + optional catalyst 15.9 control file + ocl-icd fixes
-rw-r--r--.SRCINFO12
-rw-r--r--4.9_over_4.6-arch-get_user_pages_remote.patch24
-rw-r--r--PKGBUILD37
-rw-r--r--catalyst-15.9_control_file.tar.gzbin0 -> 8679 bytes
-rw-r--r--catalyst-test.install8
5 files changed, 62 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a5ec8e9768f..94f2696c67ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = catalyst-test
- pkgdesc = AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons ARE NOT SUPPORTED
+ pkgdesc = AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons are optionally supported
pkgver = 15.12
- pkgrel = 11
+ pkgrel = 12
url = http://www.amd.com
install = catalyst-test.install
arch = i686
@@ -9,7 +9,7 @@ pkgbase = catalyst-test
license = custom
depends = dkms
depends = linux>=3.0
- depends = linux<4.9
+ depends = linux<4.10
depends = linux-headers
depends = xorg-server>=1.7.0
depends = xorg-server<1.18.0
@@ -29,6 +29,7 @@ pkgbase = catalyst-test
optdepends = opencl-headers: headers necessary for OpenCL development
optdepends = acpid: acpi event support / atieventsd
optdepends = procps-ng: brings pgrep used in acpi event support
+ optdepends = opencl-icd-loader: OpenCL ICD Bindings
provides = libgl
provides = libatical=15.12
provides = catalyst=15.12
@@ -40,6 +41,7 @@ pkgbase = catalyst-test
provides = libtxc_dxtn
provides = mesa-libgl
provides = mesa-libgl-git
+ provides = opencl-driver
conflicts = libgl
conflicts = catalyst
conflicts = catalyst-daemon
@@ -79,6 +81,8 @@ pkgbase = catalyst-test
source = dkms.conf
source = makesh-dont-check-gcc-version.patch
source = 4.7-arch-cpu_has_pge-v2.patch
+ source = 4.9_over_4.6-arch-get_user_pages_remote.patch
+ source = catalyst-15.9_control_file.tar.gz
md5sums = 39808c8a9bcc9041f1305e3531b60622
md5sums = af7fb8ee4fc96fd54c5b483e33dc71c4
md5sums = bdafe749e046bfddee2d1c5e90eabd83
@@ -105,6 +109,8 @@ pkgbase = catalyst-test
md5sums = 23d569abfdd7de433d76e003e4b3ccf9
md5sums = 10829e3b992b3e80a6e78c8e27748703
md5sums = 37eef5103a11d8136979463e7bc31091
+ md5sums = 194cb44e9e2ab0e65b6267aca66d0400
+ md5sums = e98e50bebe96b08ca680aed6ca505356
pkgname = catalyst-test
diff --git a/4.9_over_4.6-arch-get_user_pages_remote.patch b/4.9_over_4.6-arch-get_user_pages_remote.patch
new file mode 100644
index 000000000000..802ca96b6787
--- /dev/null
+++ b/4.9_over_4.6-arch-get_user_pages_remote.patch
@@ -0,0 +1,24 @@
+--- 16.12/common/lib/modules/fglrx/build_mod/firegl_public.c 2016-12-10 19:44:46.764677311 +0100
++++ 16.12b/common/lib/modules/fglrx/build_mod/firegl_public.c 2016-12-10 19:45:43.941354338 +0100
+@@ -3225,7 +3225,9 @@
+ int ret;
+
+ down_read(&current->mm->mmap_sem);
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,6,0)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,9,0)
++ ret = get_user_pages_remote(current, current->mm, vaddr, page_cnt, 1, (struct page **)page_list, NULL);
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(4,6,0)
+ ret = get_user_pages_remote(current, current->mm, vaddr, page_cnt, 1, 0, (struct page **)page_list, NULL);
+ #else
+ ret = get_user_pages(current, current->mm, vaddr, page_cnt, 1, 0, (struct page **)page_list, NULL);
+@@ -3247,7 +3249,9 @@
+ int ret;
+
+ down_read(&current->mm->mmap_sem);
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,6,0)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,9,0)
++ ret = get_user_pages_remote(current, current->mm, vaddr, page_cnt, 0, (struct page **)page_list, NULL);
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(4,6,0)
+ ret = get_user_pages_remote(current, current->mm, vaddr, page_cnt, 0, 0, (struct page **)page_list, NULL);
+ #else
+ ret = get_user_pages(current, current->mm, vaddr, page_cnt, 0, 0, (struct page **)page_list, NULL);
diff --git a/PKGBUILD b/PKGBUILD
index c94dacfb63ff..ee508f508353 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,28 +22,31 @@
# Contributor: gentoo (part of 4.3 kernel patches)
# Contributor: Philip Muller @ Manjaro (4.4 kernel patch)
# Contributor: aslmaswd (acpi main script)
-# Contributor: npfeiler (libcl/ocl-icd cleaning)
+# Contributor: npfeiler (libcl/opencl-icd-loader cleaning)
+
+
+_old_control=n #for pre-GCN users who has problems with default config, pick =y to enable catalyst 15.9 control file
-# PKGEXT='.pkg.tar.gz' # imho time to pack this pkg into tar.xz is too long, unfortunatelly yaourt got problems when ext is different from .pkg.tar.xz - V
pkgname=catalyst-test
pkgver=15.12
-pkgrel=11
+pkgrel=12
# _betano=1.0
_amdver=15.302
-pkgdesc="AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons ARE NOT SUPPORTED"
+pkgdesc="AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons are optionally supported"
arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
options=('staticlibs' 'libtool' '!strip' '!upx')
-depends=('dkms' 'linux>=3.0' 'linux<4.9' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa>=10.1.0-4')
+depends=('dkms' 'linux>=3.0' 'linux<4.10' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa>=10.1.0-4')
optdepends=('qt4: to run ATi Catalyst Control Center (amdcccle)'
'libxxf86vm: to run ATi Catalyst Control Center (amdcccle)'
'opencl-headers: headers necessary for OpenCL development'
'acpid: acpi event support / atieventsd'
- 'procps-ng: brings pgrep used in acpi event support')
+ 'procps-ng: brings pgrep used in acpi event support'
+ 'opencl-icd-loader: OpenCL ICD Bindings')
conflicts=('libgl' 'catalyst' 'catalyst-daemon' 'catalyst-generator' 'catalyst-hook' 'catalyst-utils' 'catalyst-dkms' 'mesa-libgl' 'mesa-libgl-git')
-provides=('libgl' "libatical=${pkgver}" "catalyst=${pkgver}" "catalyst-utils=${pkgver}" "catalyst-hook=${pkgver}" "catalyst-libgl=${pkgver}" "opencl-catalyst=${pkgver}" 'dri' 'libtxc_dxtn' 'mesa-libgl' 'mesa-libgl-git')
+provides=('libgl' "libatical=${pkgver}" "catalyst=${pkgver}" "catalyst-utils=${pkgver}" "catalyst-hook=${pkgver}" "catalyst-libgl=${pkgver}" "opencl-catalyst=${pkgver}" 'dri' 'libtxc_dxtn' 'mesa-libgl' 'mesa-libgl-git' 'opencl-driver')
if [ "${CARCH}" = "x86_64" ]; then
warning "x86_64 system detected"
@@ -52,7 +55,8 @@ if [ "${CARCH}" = "x86_64" ]; then
warning "OK, lib32-catalyst-utils will be added to the package"
depends+=('lib32-libxext' 'lib32-libdrm' 'lib32-libxinerama' 'lib32-mesa>=10.1.0-4')
conflicts+=('lib32-libgl' 'lib32-catalyst-utils' 'lib32-mesa-libgl' 'lib32-mesa-libgl-git')
- provides+=('lib32-libgl' "lib32-catalyst-utils=${pkgver}" "lib32-catalyst-libgl=${pkgver}" "lib32-opencl-catalyst=${pkgver}" 'lib32-dri' 'lib32-libtxc_dxtn' 'lib32-mesa-libgl' 'lib32-mesa-libgl-git')
+ provides+=('lib32-libgl' "lib32-catalyst-utils=${pkgver}" "lib32-catalyst-libgl=${pkgver}" "lib32-opencl-catalyst=${pkgver}" 'lib32-dri' 'lib32-libtxc_dxtn' 'lib32-mesa-libgl' 'lib32-mesa-libgl-git' 'lib32-opencl-driver')
+ optdepends+=('lib32-opencl-icd-loader: OpenCL ICD Bindings (32-bit)')
else
warning "lib32-catalyst-utils will NOT be added to the package"
fi
@@ -94,7 +98,9 @@ source=(
4.6-arch-get_user_pages-page_cache_release.patch
dkms.conf
makesh-dont-check-gcc-version.patch
- 4.7-arch-cpu_has_pge-v2.patch)
+ 4.7-arch-cpu_has_pge-v2.patch
+ 4.9_over_4.6-arch-get_user_pages_remote.patch
+ catalyst-15.9_control_file.tar.gz)
md5sums=('39808c8a9bcc9041f1305e3531b60622'
'af7fb8ee4fc96fd54c5b483e33dc71c4'
@@ -121,7 +127,9 @@ md5sums=('39808c8a9bcc9041f1305e3531b60622'
'11b7c2e0dc4794801005d66b0e7608a3'
'23d569abfdd7de433d76e003e4b3ccf9'
'10829e3b992b3e80a6e78c8e27748703'
- '37eef5103a11d8136979463e7bc31091')
+ '37eef5103a11d8136979463e7bc31091'
+ '194cb44e9e2ab0e65b6267aca66d0400'
+ 'e98e50bebe96b08ca680aed6ca505356')
build() {
@@ -202,7 +210,7 @@ package() {
install -m644 X11R6/${_lib}/*.cap ${pkgdir}/usr/lib
install -m755 X11R6/${_lib}/modules/dri/*.so ${pkgdir}/usr/lib/xorg/modules/dri
install -m755 ${_lib}/*.so* ${pkgdir}/usr/lib
- rm ${pkgdir}/usr/lib/libOpenCL.so.1 # ocl-icd provides this
+ rm ${pkgdir}/usr/lib/libOpenCL.so.1 #opencl-icd-loader provides this
# install -m755 ${_lib}/hsa/* ${pkgdir}/usr/lib/hsa #removed in 14.1
## QT libs (only 2 files) - un-comment 2 lines below if you don't want to install qt package
@@ -241,6 +249,10 @@ package() {
patch -Np2 -i ${srcdir}/arch-fglrx-authatieventsd_new.patch
install -m644 etc/ati/* ${pkgdir}/etc/ati
chmod 755 ${pkgdir}/etc/ati/authatieventsd.sh
+ if [ "${_old_control}" = "y" ]; then
+ rm ${pkgdir}/etc/ati/control
+ install -m644 ${srcdir}/catalyst-15.9_control_file ${pkgdir}/etc/ati/control
+ fi
install -m644 etc/security/console.apps/amdcccle-su ${pkgdir}/etc/security/console.apps
@@ -311,6 +323,7 @@ package() {
patch -Np1 -i ../4.6-arch-get_user_pages-page_cache_release.patch
patch -Np1 -i ../makesh-dont-check-gcc-version.patch
patch -Np1 -i ../4.7-arch-cpu_has_pge-v2.patch
+ patch -Np1 -i ../4.9_over_4.6-arch-get_user_pages_remote.patch
# Prepare modules source files
install -dm755 ${pkgdir}/usr/src/fglrx-${pkgver}/2.6.x
@@ -343,7 +356,7 @@ package() {
install -dm755 ${pkgdir}/usr/lib32/xorg/modules/dri
# install -dm755 ${pkgdir}/usr/lib32/hsa #removed in 14.1
install -m755 lib/*.so* ${pkgdir}/usr/lib32
- rm ${pkgdir}/usr/lib32/libOpenCL.so.1 # lib32-ocl-icd provides this
+ rm ${pkgdir}/usr/lib32/libOpenCL.so.1 # lib32-opencl-icd-loader provides this
# install -m755 lib/hsa/* ${pkgdir}/usr/lib32/hsa #removed in 14.1
install -m755 X11R6/lib/fglrx/fglrx-libGL.so.1.2 ${pkgdir}/usr/lib32/fglrx
install -m755 X11R6/lib/libAMDXvBA.so.1.0 ${pkgdir}/usr/lib32
diff --git a/catalyst-15.9_control_file.tar.gz b/catalyst-15.9_control_file.tar.gz
new file mode 100644
index 000000000000..df9ed65dd232
--- /dev/null
+++ b/catalyst-15.9_control_file.tar.gz
Binary files differ
diff --git a/catalyst-test.install b/catalyst-test.install
index 62094ecde3cc..68598bc842aa 100644
--- a/catalyst-test.install
+++ b/catalyst-test.install
@@ -24,10 +24,10 @@ whisperer(){
echo -e "\e[0;32m--------------------------- PXP --------------------------------\e[0m"
echo -e "\e[0;32m@pxp_user:\e[0m I switched GL/glx links to catalyst again..."
echo -e "\e[0;32m----------------------------------------------------------------\e[0m"
- echo -e "\e[1;31m------------ DROPPED SUPPORT FOR RADEONS HD 5 6 k --------------\e[0m"
- echo "Please note that this release SADLY :( is"
- echo "dropping support for pre-GCN cards so mainly"
- echo "Radeons of series 5000 and 6000"
+ echo -e "\e[1;31m---------------- SUPPORT FOR RADEONS HD 5 6 k ------------------\e[0m"
+ echo "If you are user of pre-GCN cards so mainly Radeons of series"
+ echo "5000 and 6000 and have problems, try to build this package"
+ echo "with _old_control variable set to y in PKGBUILD"
echo -e "\e[1;31m----------------------------------------------------------------\e[0m"
}