summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVi0L02015-11-03 19:46:21 +0100
committerVi0L02015-11-03 19:46:21 +0100
commitcbddf59ab97ff0667d2339c135ae8a48a577e9e0 (patch)
tree0bb30e1a0f606066ea7ddefc0ae768e9b32e34e9
parent0941c8c180c3bea059203ece9ac008ba98e2ed45 (diff)
downloadaur-cbddf59ab97ff0667d2339c135ae8a48a577e9e0.tar.gz
added initial 4.3 kernel support
-rw-r--r--.SRCINFO8
-rw-r--r--4.3-gentoo-mtrr.patch27
-rw-r--r--4.3-kolasa-seq_printf.patch16
-rw-r--r--PKGBUILD17
4 files changed, 61 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7815541dec18..90fe3a20c936 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = catalyst-test
pkgdesc = AMD/ATI Catalyst drivers for linux. catalyst-hook + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
pkgver = 15.9
- pkgrel = 5
+ pkgrel = 6
url = http://www.amd.com
install = catalyst-test.install
arch = i686
arch = x86_64
license = custom
depends = linux>=3.0
- depends = linux<4.3
+ depends = linux<4.4
depends = linux-headers
depends = xorg-server>=1.7.0
depends = xorg-server<1.18.0
@@ -84,6 +84,8 @@ pkgbase = catalyst-test
source = 4.2-fglrx-has_fpu.patch
source = 4.2-kolasa-fpu_save_init.patch
source = ubuntu_buildfix_kernel_4.2-build.copy_xregs_to_kernel.patch
+ source = 4.3-kolasa-seq_printf.patch
+ source = 4.3-gentoo-mtrr.patch
md5sums = d2de2df6946b452c266a3c892e6e46ff
md5sums = f3aaed0084725304cf607f6915e4bfee
md5sums = af7fb8ee4fc96fd54c5b483e33dc71c4
@@ -113,6 +115,8 @@ pkgbase = catalyst-test
md5sums = ed7748a593d6b894269f8c7856b7ae50
md5sums = dd51495a1d8f2d1042f04a783bf01e08
md5sums = 2f7d42fde403a1b4a22e5db8de738d0f
+ md5sums = 0e0666e95d1d590a7a83192805679485
+ md5sums = 98828e3eeaec2b3795e584883cc1b746
pkgname = catalyst-test
diff --git a/4.3-gentoo-mtrr.patch b/4.3-gentoo-mtrr.patch
new file mode 100644
index 000000000000..86d7ffc3cc2b
--- /dev/null
+++ b/4.3-gentoo-mtrr.patch
@@ -0,0 +1,27 @@
+--- 15.9/common/lib/modules/fglrx/build_mod/firegl_public.c 2015-09-09 00:57:14.000000000 +0200
++++ 15.9/common/lib/modules/fglrx/build_mod/firegl_public.c 2015-11-03 19:00:09.121884973 +0100
+@@ -3412,7 +3412,11 @@
+ int ATI_API_CALL KCL_MEM_MTRR_AddRegionWc(unsigned long base, unsigned long size)
+ {
+ #ifdef CONFIG_MTRR
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,3,0)
++ return arch_phys_wc_add(base, size);
++#else
+ return mtrr_add(base, size, MTRR_TYPE_WRCOMB, 1);
++#endif
+ #else /* !CONFIG_MTRR */
+ return -EPERM;
+ #endif /* !CONFIG_MTRR */
+@@ -3421,7 +3425,12 @@
+ int ATI_API_CALL KCL_MEM_MTRR_DeleteRegion(int reg, unsigned long base, unsigned long size)
+ {
+ #ifdef CONFIG_MTRR
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,3,0)
++ arch_phys_wc_del(reg);
++ return reg;
++#else
+ return mtrr_del(reg, base, size);
++#endif
+ #else /* !CONFIG_MTRR */
+ return -EPERM;
+ #endif /* !CONFIG_MTRR */
diff --git a/4.3-kolasa-seq_printf.patch b/4.3-kolasa-seq_printf.patch
new file mode 100644
index 000000000000..6cd08a93acad
--- /dev/null
+++ b/4.3-kolasa-seq_printf.patch
@@ -0,0 +1,16 @@
+--- 15.9/common/lib/modules/fglrx/build_mod/firegl_public.c 2015-09-09 00:57:14.000000000 +0200
++++ 15.9b/common/lib/modules/fglrx/build_mod/firegl_public.c 2015-11-02 21:02:06.124639919 +0100
+@@ -623,8 +623,13 @@
+
+ len = snprintf(buf, request, "%d\n", major);
+ #else
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,3,0)
++ seq_printf(m, "%d\n", major);
++ len = 0;
++#else
+ len = seq_printf(m, "%d\n", major);
+ #endif
++#endif
+
+ KCL_DEBUG1(FN_FIREGL_PROC, "return len=%i\n",len);
+
diff --git a/PKGBUILD b/PKGBUILD
index db726099531e..505eb3a3afd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,13 +20,14 @@
# Contributor: solar (authatieventsd' patch s/-1/255)
# Contributor: Cold (current_euid patch)
# Contributor: ubuntu (parts of 4.0, 4.1 and 4.2 kernel patches)
-# Contributor: kolasa (part of 4.2 kernel patches)
+# Contributor: kolasa (parts of 4.2 and 4.3 kernel patches)
+# Contributor: gentoo (part of 4.3 kernel patches)
# PKGEXT='.pkg.tar.gz' # imho time to pack this pkg into tar.xz is too long, unfortunatelly yaourt got problems when ext is different from .pkg.tar.xz - V
pkgname=catalyst-test
pkgver=15.9
-pkgrel=5
+pkgrel=6
# _betano=1.0
_amdver=15.201.1151
pkgdesc="AMD/ATI Catalyst drivers for linux. catalyst-hook + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED"
@@ -34,7 +35,7 @@ arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
options=('staticlibs' 'libtool' '!strip' '!upx')
-depends=('linux>=3.0' 'linux<4.3' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa>=10.1.0-4' 'gcc49')
+depends=('linux>=3.0' 'linux<4.4' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa>=10.1.0-4' 'gcc49')
optdepends=('qt4: to run ATi Catalyst Control Center (amdcccle)'
'libxxf86vm: to run ATi Catalyst Control Center (amdcccle)'
'opencl-headers: headers necessary for OpenCL development'
@@ -95,7 +96,9 @@ source=(
ubuntu_buildfix_kernel_4.2.patch
4.2-fglrx-has_fpu.patch
4.2-kolasa-fpu_save_init.patch
- ubuntu_buildfix_kernel_4.2-build.copy_xregs_to_kernel.patch)
+ ubuntu_buildfix_kernel_4.2-build.copy_xregs_to_kernel.patch
+ 4.3-kolasa-seq_printf.patch
+ 4.3-gentoo-mtrr.patch)
md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'f3aaed0084725304cf607f6915e4bfee'
@@ -125,7 +128,9 @@ md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'88832af8d6769aa51fa9b266a74394e0'
'ed7748a593d6b894269f8c7856b7ae50'
'dd51495a1d8f2d1042f04a783bf01e08'
- '2f7d42fde403a1b4a22e5db8de738d0f')
+ '2f7d42fde403a1b4a22e5db8de738d0f'
+ '0e0666e95d1d590a7a83192805679485'
+ '98828e3eeaec2b3795e584883cc1b746')
build() {
@@ -316,6 +321,8 @@ package() {
patch -Np1 -i ../4.2-fglrx-has_fpu.patch
patch -Np1 -i ../4.2-kolasa-fpu_save_init.patch
patch -Np1 -i ../ubuntu_buildfix_kernel_4.2-build.copy_xregs_to_kernel.patch
+ patch -Np1 -i ../4.3-kolasa-seq_printf.patch
+ patch -Np1 -i ../4.3-gentoo-mtrr.patch
# Prepare modules source files
_archdir=x86_64